Einführung - Überblick

Überblick

Mit dem "LayerManager Professional V4" für AutoCAD R14 und AutoCAD 2000(i)/2002 steht eine einzigartige Tool-Software zur Verfügung, welche im Bereich des Layer-Managements neue Maßstäbe setzt. Durch die Kombination leistungsfähiger, erweiterter Layersteuerungs-Funktionen mit dem Bedienkomfort eines Windows-Explorers sowie einer ganzen Reihe pfiffiger Detaillösungen eröffnen sich völlig neue Möglichkeiten zum Umgang mit Layern und der gesamten Zeichnung.

Sie als Anwender profitieren von dieser Software in mehrfachem Sinne: Neben deutlich gehobenem Arbeitskomfort gewährleistet der "LayerManager Professional" massive Zeitersparnis und Auswahlsicherheit beim Umgang mit Layern, sowie die Möglichkeit, Hunderte Layer überhaupt erst sinnvoll, mit wenigen Mausklicks, steuern zu können. Selbst komplexeste Layer-Systeme mit oft kryptischen Layernamen bleiben dank erweitertem Beschreibungstext stets lesbar und identifizierbar.

Engagierte AutoCAD-Anwender kennen das Problem seit Jahren – wird die Zeichnung ordentlich strukturiert, so steht man nach kürzester Zeit einer endlosen Zahl von Layern gegenüber, welche manuell (fast) nicht mehr zu beherrschen sind – Abhilfe bietet der neue LayerManager "LaymanPro" durch das Zusammenfassen logisch zusammengehöriger Layer in Gruppen und Hierarchien, die beliebig tief und komplex sein können. Alle Layer und Gruppen dürfen in beliebigen Strukturen, auch mehrfach, enthalten sein und besitzen einen Beschreibungstext, der permanent in der Statuszeile oder als ToolTip eingeblendet wird.

Ordnung ist nur das halbe Leben ... Layergruppen verbessern nicht nur Übersichtlichkeit der Zeichnung – sie bieten auch Möglichkeiten zur schnellen, sicheren Layersteuerung. "LaymanPro" entfaltet seine besonderen Stärken in der Nutzung dieser Objekte: mehr als ein Dutzend spezieller Funktionen bringen dem Anwender einen deutlichen Effektivitätsgewinn. Hierzu zählen die "Display"-Funktion zum "Blättern" in der Zeichnung, zur Analyse fremder Zeichnungen und der schnellen Daten-Sichtung. Aus den Zeichnungs-elementen der Layer und Gruppen lassen sich Auswahlsätze und WBlocks erstellen. Die "Kopieren/Klonen"-Funktionen erlauben das Kopieren der Layer inklusive Layer-Eigenschaften und -Elemente. Sind Objekte markiert, so können die enthaltenen Elemente angezeigt oder in den Vordergrund/Hintergrund verschoben werden. Zur Dokumentation der Zeichnungen lassen sich frei konfigurierbare Layer-Listing-Dateien speichern. Erstellte Strukturen werden mit der Import-Export-Funktion zwischen den Zeichnungen ausgetauscht oder (nur R2000(i)) einfach per Drag-&-Drop übertragen. Abgerundet wird das Leistungsspektrum durch die "LayerTools": diese steuern die Layer über Referenzelemente der Zeichnung. Insbesondere ist auch die Steuerung NICHT-gewählter Layer und das "Restaurieren" des Layerzustandes möglich.

Keine Hürde : Papierbereich, Blöcke und XRefs Spezielle Fähigkeiten zeigen sich im Papierbereich. Die Unterschiede der Layersteuerung zwischen Modell- und Papierbereich fängt "LaymanPro" vollständig ab, so daß der Anwender stets die gleichen Funktionen vorfindet. Ein Highlight ist die Trennung der Modell- und Papierbereichs-Layer: wechselt der Anwender zwischen den Bereichen, werden die Layer automatisch dem aktuellen Bereich angepaßt und der letzte Zustand wieder restauriert. Im Falle mehrerer Viewports sind die Operationen parallel in frei wählbaren Viewports ausführbar, womit der Papierbereich schnell eingestellt wird. XRefs und Blöcke analysiert "LaymanPro" automatisch; deren Layergruppen/Hierarchien stehen sofort bereit.

Kleine Extras: intelligente Fenster-Steuerung: Als Windows-Programm im Explorer-Design nutzt "Layman Pro" alle üblichen Standards. Vertikale oder horizontaler Fenster, freie Schriftwahl, ToolTips, Drag&Drop, Kontextmenüs gehören ebenso dazu wie andockbare Menüleiste und ToolBar sowie ein/ausblendbare Statuszeile und Suchleiste. Für Harmonie mit AutoCAD sorgt eine intelligente Fenstersteuerung. So bleibt das Programm-Fenster auf Wunsch permanent sichtbar. AutoCAD-Applikationen wie MAP oder MD nutzen Projektfenster, die sich an AutoCAD andocken. Dadurch reduziert sich die effektive Arbeitsfläche in der Zeichnung z.T. drastisch. Hier zeigt sich der LayerManager überlegen: ist der Mauszeiger im AutoCAD-Fenster, rollt sich das Programm bis auf die Titelzeile zusammen und benötigt (fast) keinen Platz mehr.

AutoCAD 2000(i): alle Highlights voll integriert: Alle Neuerungen von Release 2000(i) sind im LayerManager vollständig integriert, inklusive MDE-Fähigkeiten: mit LaymanPro steuern Sie auch die nicht-aktiven Zeichnungen im Hintergrund ! Mit Drag-&-Drop zwischen den LaymanPro-Fenstern übertragen Sie komplette Strukturen in wenigen Sekunden und gleichen Layer, Gruppen und Hierarchien vollständig ab.

Die wichtigsten Leistungs-Merkmale in der Übersicht:

  • Zusammenfassung von Layern zu Layergruppen; Anordnung von Layergruppen zu Hierarchien

  • Kommentierung von Layern, Layergruppen und Hierarchien mit beliebigem Beschreibungstext

  • Anwendung aller AutoCAD-Layeroperationen auch auf Layergruppen und Hierarchien

  • Zuordnung von Ansichten (View) und Koordinatensystemen (BKS) zu Gruppen und Hierarchien

  • Technologisches Highlight: Modell- und Papierbereich werden vollständig entkoppelt; beim Wechsel zwischen den Bereichen kann LaymanPro alle Layer auf den jeweils letzten Zustand restaurieren

  • Automatische Erkennung und Nutzung XREF-abhängiger und in XREFS sowie Blöcken vorhandener LayerManager-Daten, d.h. auch Layer, LayerGruppen, Hierarchien innerhalb von XREFS und Blöcken werden korrekt und ohne Limitierung der Schachtelungstiefe ausgewertet

  • Im Papierbereich können Layer, Layergruppen, Hierarchien in beliebig vielen und frei wählbaren Viewports simultan eingestellt werden

  • Mit der Auto-Strukturierung erhalten Ihre Zeichnungen die Intelligenz, um Layergruppen und Hierarchien automatisch anzulegen, wenn in den zugeordneten Templates entsprechende Layer definiert sind – "LaymanPro" beobachtet Ihre Zeichnung und führt die Zeichnungsstrukturierung im Hintergrund durch

  • Mit dem integrierten 3D-Orbit-Viewer (nur R2000) steht eine komfortable Möglichkeit bereit, den Inhalt von Layer/Gruppen/Hierarchien als 3D-Voransicht einzusehen, ohne die Zeichnung selbst zu beeinflussen

  • Das "Arbeits-Layer-Fenster" beinhaltet vom Anwender vorgewählte Layer, und bleibt in AutoCAD ständig sichtbar – so kann der aktuelle Zeichnungslayer mit nur einem einzigen (!) Mausklick gewechselt werden

  • Die "Layer-History" speichert benannte Schnappschüsse inklusive Layouts und Viewports direkt in der Zeichnung – diese können jederzeit wieder restauriert werden

  • Display/Highlight-Funktion zur schnellen Darstellung/Anzeige von Layern, Layergruppen und Hierarchien

  • Benannte und speicherbare Vordergrund-/Hintergrund-Steuerung mit Layern, Layergruppen, Hierarchien

  • Komplette Drag-&-Drop-Fähigkeiten zwischen allen LayerManager-Fenstern und zwischen Zeichnungen

  • WBlock-Funktion zur Speicherung des Zeichnungsinhaltes von Layern, Layergruppen, Hierarchien

  • Auswahlsatz-Bildung mit den Elementen von Layern, Layergruppen, Hierarchien zur Nutzung in AutoCAD

  • Kopieren und Klonen von Layern, Gruppen, Hierarchien, optionales Kopieren der Zeichnungselemente

  • Suchfunktion : Lokalisieren von Layern, Layergruppen, Hierarchien über beschreibende Eigenschaften

  • Speicherbare Anzeige-Filter erlauben reduzierte und angepasste Anzeigen (im rechten Anzeige-Fenster)

  • Spezielle Import-/Export-Funktionen zum Austausch von Layer-Strukturen zwischen Zeichnungen

  • Integrierte LayerTools zur Steuerung der Zeichnungslayer über Referenzobjekte

  • "SchnappSchuss"-Funktion zur Speicherung der aktuellen Layerkonstellation der Zeichnung in eine frei wählbare Textdatei; "Layer-SchnappSchüsse" können natürlich auch nach Belieben wiede restauriert werden; arbeitet auch im Papierbereich und mit Viewports

  • Ausgabe eines Layer-Listing mit frei wählbarer Angabe von Eigenschaften (Status, Farbe, Linientyp, Linienstärke, Plotstatus, Plotstil, Zugehörigkeit zu LayerGruppen und Hierarchien)

  • Alle üblichen Funktionen zur Administrierung von Layern, Layergruppen, Hierarchien wie Kopieren, Umbenennen, Löschen, Aufräumen etc. sind vorhanden

  • Vollständige Unterstützung des "Multiple Document Environment" in AutoCAD 2000(I) ist integriert, z.B. Drag-&-Drop mit LayerManager-Daten zwischen verschiedenen Zeichnungen

  • Anzeige der aktuellen Zeichnung oder Zuordnung einer beliebigen Zeichnung zu jedem LayerManager-Fenster in AutoCAD 2000(i)

  • Einfachste Installation; automatischer Programmstart mit AutoCAD kann eingestellt werden

  • und noch vieles, vieles mehr ...


Was ist neu in Version v4.1 ?

In die Version v4.1 sind eine Fülle neuer und verbesserter Leistungsmerkmale eingeflossen – viele basieren unmittelbar auf Anregungen, Wünschen und Hinweisen engagierter Anwender. Hier die Wichtigsten :

Neue Leistungsmerkmale und Features:

  • LayerManager arbeitet nun auch mit AutoCAD LT 2000(i)/2002 ohne Einschränkungen !!

  • Der integrierte 3D-Orbit-View (nur R2000) ist eine komfortable Möglichkeit, den Inhalt von Layer/Gruppen/Hierarchien als 3D-Voransicht einzusehen, ohne die Zeichnung selbst zu beeinflussen

  • beim Wechsel zwischen Modellbereich, Papierbereich und Layouts werden alle Layer-Eigenschaften des jeweiligen Bereiches automatisch gespeichert, und nach dem Wechsel in einen anderen Bereich werden (wählbare) Layer-Eigenschaften des aktuellen Bereiches automatisch restauriert.

  • Mit der Auto-Strukturierung erhalten Ihre Zeichnungen die Intelligenz, um Layergruppen und Hierarchien automatisch anzulegen, wenn in den zugeordneten Templates entsprechende Layer definiert sind – "LaymanPro" beobachtet die Zeichnung und führt die Zeichnungsstrukturierung im Hintergrund durch

  • Das Arbeits-Layer-Fenster beinhaltet vom Anwender vorgewählte Layer, und bleibt in AutoCAD ständig sichtbar – so kann der aktuelle Zeichnungslayer mit nur einem einzigen (!) Mausklick gewechselt werden

  • Die Layer-History speichert benannte Schnappschüsse inklusive Layouts und Viewports direkt in der Zeichnung – diese können jederzeit wieder restauriert sowie exportiert/importiert werden

  • die Anzeige-Reihenfolgen und Layer-Histories mit Layout-abhängigen Layer-Eigenschaften können nun exportiert und importiert werden - damit sind komplette Layout-Konfigurationen in andere Zeichnungen bzw. in andere Layouts übertragbar

  • Speicherbare Display-Filter erlauben reduzierte und angepasste Anzeigen im rechten Anzeige-Fenster

  • Ein neuer Dialog zur Erstellung von Gruppen und Hierarchien vereinfacht die manuelle Zeichnungs-Strukturierung

  • Neue Funktionen mit Zeichnungselementen gewählter Layer/Gruppen/Hierarchien: Farbe, Linientyp, Linienstärke, Plotstatus/stil etc. können nun direkt gesetzt werden

  • Mit der neuen Druck-, Druck-Setup- und Druck-Vorschau-Funktion können nun die Inhalte des linken und rechten Anzeige-Fensters auch ausgedruckt werden

Verbesserte Leistungsmerkmale und Features:

  • Die Netzwerk-/Multi-User-Fähigkeiten wurden deutlich verbessert: alle Anwender finden im gesamten Netzwerk stets ihre jeweils eigene, letztbenutzte LayerManager-Konfiguration mit allen Details und an allen PCs wieder.

  • Vorder/Hintergund-Steuerung : Anzeige-Reihenfolgen für Layer, Gruppen, Hierarchien werden nun als "benannte Reihenfolgen" gespeichert - damit stehen Ihnen auf Knopfdruck verschiedenste Reihenfolgen (z.B. für Modellbereich und verschiedene Papierbereiche) getrennt zur Verfügung ! Ausserdem können die Anzeige-Reihenfolgen nun auch exportiert/importiert werden.

  • Spalten-Anordnung : (nur R2000) die im rechten Fenster angezeigten Eigenschafts-Spalten können nun auch per Drag-&-Drop umsortiert werden.

  • Spalten-Anordnung : für die im rechten Fenster angezeigten Eigenschafts-Spalten steht ein neues Kontextmenü zur Verfügung, um die Spalten auszublenden, zu sortieren, optimal einzustellen etc.

  • Anzeige-Aktualisierung: Aufbau und Update der Listen im rechten Anzeige-Fenster konnten deutlich beschleunigt werden (z.B. bei Sortierung nach Spalten und Anzeige abhängiger Layer/Gruppen).

  • Anzeige und Darstellung: neben der Schriftart kann nun auch deren Farbe eingestellt werden; unter "Konfiguration/Erweitert" bestehen weitere Möglichkeiten, bestimmte Objekte gesondert darzustellen.

  • Drag & Drop verfeinert: wenn Sie Objekte in das linke/obere Fenster ziehen, so können Sie mit gedrückter STRG-Taste die Layergruppe/Hierarchie öffnen, auf der sich der Mauszeiger befindet; mit SHIFT-Taste wird die Layergruppe/Hierarchie wieder geschlossen. Voraussetzung ist, dass unter <Konfiguration> die entsprechende Option aktiviert ist.

  • Erweiterte ToolTips : neben dem kurzen ToolTip-Text steht oft ein erweiterter Hilfetext zur Verfügung - es erscheint ein kleiner schwarzer Pfeil am rechten Rand des ToolTip-Fensters: bewegen Sie einfach die Maus in das ToolTip-Fenster hinein, und es wird ein ausführlicherer Hilfetext angezeigt.

  • Benutzer-Oberfläche: zu den Neuerungen in der Benutzer-Oberfläche zählen u.a. ToolTips und Icons auch in den Menüs, modernisierte ToolBars, Hilfslinien und variierende Cursor in den Anzeige-Fenstern,

  • Tip-des-Tages : in den "Tages-Tips" werden Neuerungen und Tips&Tricks zum Programm vorgestellt

  • Web-Support : auf der Web-Site www.LayerManager.de finden Sie stets aktuelle Updates, Tips & Tricks, eine umfangreiche FAQ-Liste sowie Erfahrungs-Austausch mit anderen Anwendern

Ein weiterer wichtiger Aspekt besteht in der erhöhten Stabilität des Programmes – es wurde sehr viel Aufwand darauf verwendet, bekannt gewordene Fehler und "Macken" des LayerManagers zu beseitigen. In diesem Zusammenhang wurde auch die programm-interne Absturz-Sicherung weiter ausgebaut und verfeinert. Es sei hier auch allen Anwendern ausdrücklich und herzlichst gedankt, welche mit ihrer Mühe (und auch mit ihrem Risiko) so wertvolle Hilfe geleistet und mit zahlreichen Hinweisen und Fehlerreports wesentlich zum vorliegenden Stand beigetragen haben.


System-Voraussetzungen

"LayerManager Professional" benötigt als Grundlage ein installiertes AutoCAD R14/2000(i)/2002 bzw. AutoCAD LT 2000/2000i//2002 unter Windows 95/98/ME/ NT4.0 (mit Servicepack 5 oder höher) oder Windows 2000/XP auf PC mit x86-kompatiblem Prozessor.

Der "LayerManager Professional" kann hierbei auch problemlos im Netzwerk eingesetzt werden !


Durchführung der Installation

Wichtig: bitte beenden Sie unbedingt AutoCAD vor der Installation des LayerManagers !

Die Installation erfolgt äußerst einfach: Starten Sie bitte das Setup-Programm, "Setup.exe", welche dem Installations-Paket beiliegt (auf CD-Rom oder durch Download), z.B. aus dem Windows-Explorer heraus.

Speziell bei Installation von CD: ist die "CD-AutoRun"–Funktion des Betriebssystems aktiv, so genügt es, die CD ins CD-ROM-Laufwerk einzulegen und die Installation startet automatisch; anderenfalls starten Sie bitte, wie oben beschrieben, das Setup-Programm "Setup.exe" manuell.

Das Setup-Programm benötigt lediglich die Angabe des Zielverzeichnisses für den LayerManager – wählen Sie am Besten ein eigenes Verzeichnis für LaymanPro (z.B.: "d:\acadapps\LaymanPro.R14")

Unmittelbar nach dem Kopieren der Programm-dateien in das Zielverzeichnis wird im Window-Startmenü eine Programmgruppe für den LayerManager angelegt (u.a. mit Online-Hilfe, LayerManager-Registrierungs-Tool "Register 2 AutoCAD" und Deinstallations-Routine).
Zum Schluß wird das Registrierungs-Tool gestartet, um den LayerManager erstmals bei AutoCAD und AutoCAD LT anzumelden.

Wählen Sie bitte die betreffende(n) AutoCAD-Installation(en) und wählen Sie jeweils die Profile, in denen der LayerManager arbeiten soll sowie ggf. die Sprachversion. Optional kann das LayerManager-PullDown-Menü angezeigt werden (ist aber nicht erforderlich). Speichern Sie nun Ihre Einstellungen – damit ist die Installation beendet.

Mit dem LayerManager-Registrierungs-Tool "Register 2 AutoCAD" können Sie jederzeit auch nachträglich die Einbindung des LayerManagers in AutoCAD prüfen und ändern – AutoCAD darf hierbei nicht aktiv sein.

Wichtiger Hinweis: Arbeiten Sie sowohl mit AutoCAD R14 als auch mit AutoCAD 2000(i)/2002/LT 2000(i)/2002 und möchten daher den LayerManager mit diesen AutoCAD-Versionen nutzen, so installieren Sie die LayerManager für R14 und 2000(i)/2002/ LT 2000(i)/2002 wegen unterschiedlicher ARX-Versionen bitte unbedingt in getrennte Verzeichnisse !

Der LayerManager selbst ist bzgl. seiner eigenen Daten aber problemlos abwärts- und aufwärtskompatibel (bis hinunter zu AutoCAD-R12/DOS-Version des LayerManagers).


Start in AutoCAD

Das LayerManager-Registrierungs-Tool "Register 2 AutoCAD" übernimmt die korrekte Anmeldung des LayerManagers bei AutoCAD bzw. AutoCAD LT, wodurch die LayerManager-Programmdateien beim AutoCAD-Start (entsprechend den eingestellten Profilen) geladen werden. Um den LayerManager zu starten (falls dies noch nicht selbstständig erfolgte), geben Sie am AutoCAD-Befehlsprompt bitte einen der Befehle "laymanpro" oder "lmpro" ein – das Programmfenster öffnet sich nun.

Automatischer Start: Damit der Anwender die Befehlseingabe nicht jedesmal neu wiederholen muß, kann jetzt auch der automatische Programmstart des LayerManagers in AutoCAD konfiguriert werden. Hierzu öffnen Sie bitte den LayerManager- Options-Dialog (Menü/Datei/Konfiguration) und schalten auf der Registerkarte "LaymanPro" die Option "LAYMAN automatisch laden und starten" aktiv – damit startet sich der LayerManager zukünftig automatisch, wenn der AutoCAD-Startprozeß beendet ist.

Wichtiger Hinweis: Es ist kein Problem, wenn Sie den LayerManager wiederholt (bei laufendem Programm) vom AutoCAD-Prompt aus mit einem der Befehle ("laymanpro", "lmpro") starten – der LayerManager wird dadurch nicht erneut gestartet, vielmehr werden alle Programm-Fenster auf ihre volle Größe restauriert und in den Vordergrund geholt (siehe "Tips & Tricks: LayerManager-Fenster verschwunden" ). Das bedeutet, Sie können "verschwundene" LayerManager wieder sichtbar machen. Um mehrfache LaymanPro-Programm-fenster zu erhalten, nutzen Sie die Funktion "Neues Fenster" ( Menü/Ansicht/Neues Fenster ).


Online-Hilfe

Der "LayerManager Professional" verwendet die sogenannte "HTML-Hilfe" – ein auf der Microsoft-Internet-Technologie basierendes Hilfesystem, welches Text-, Graphik- und Video-Informationen in komprimierten Dateien (*.chm) kombiniert und diese in einem speziellen, Web-Browser-ähnlichen HTML-Anzeige-Modul darstellt. Die HTML-Hilfe verfügt über eine ausgezeichnete Navigation, ausgeklügelte Suchfunktionen, einem Index, einem Glossar, sowie der Möglichkeit, oft benötigte Hilfethemen als Favoriten abzuspeichern

Beim Anwender müssen die HTML-Help Runtime-Komponenten vorhanden sein. Im Gegensatz zur Standard-Windows-Hilfe, die in jedem Windows-System integriert ist, ist die HTML-Hilfe in Windows 95 und Windows NT 4.0 ein separates Programm (die HTML-Hilfe ist standardmäßig erst ab Windows 98/2000 integriert; auf anderen Systemen ist sie vorhanden, wenn der Internet-Explorer 4 oder später installiert wurde). Daher muß eventuell die HTML-Hilfe auf dem System installiert werden. Dies geschieht durch Ausführen der Datei "HHUPD.EXE" im Verzeichnis "Htmlhelp.upd" auf der LayerManager-CD (oder Download von der Website).

Achtung: Der Internet-Explorer ab 3.02 (IE5.0 oder später wird empfohlen) muß auf dem System vorhanden sein. Es muß nicht der Vorgabe-Browser des Systems sein (Sie können auch Opera oder Netscape nutzen), aber Teile des Internet-Explorers werden für die HTML-Hilfe benötigt. Die Ausführung von HHUPD.EXE ist immer sinnvoll, weil so die aktuellste Version der HTML-Hilfe installiert wird. Im IE 4.01 und Win98 ist die Version HTML-Help 1.1 enthalten, die bereits von neueren Versionen eingeholt wurde. Die aktuellste Version kann von den MS-Seiten im Internet geladen werden (Suche nach HHUPD.EXE).


De-Installation

Um den "LayerManager Professional" zu deinstallieren, führen Sie bitte diese 2 Schritte aus :

  1. 1. Beenden Sie bitte AutoCAD und starten zunächst das Registrierungs-Tool "Register 2 AutoCAD", um den LayerManager aus allen AutoCAD-Profilen und aus AutoCAD LT abzumelden.

  2. 2. Starten Sie danach die Deinstallations-Routine aus der LayerManager-Programmgruppe oder nutzen alternativ die Windows-Deinstallation unter Startmenü/Einstellungen/Systemsteuerung/Software.

Damit ist der LayerManager bereits vollständig und ohne die üblichen "Reste" entfernt; es werden generell keine Einträge in der System-Registry oder sonstigen System-Dateien vorgenommen.

Speziell bei Nutzung des LayerManagers unter AutoCAD LT :

Hier ist es besonders wichtig, den LayerManager mit dem Registrierungs-Tool "Register 2 AutoCAD" vor der De-Installation bei AutoCAD LT abzumelden – anderenfalls erscheint einmalig beim nächsten Start von AutoCAD LT eine (harmlose) Fehlermeldung zu vermissten LayerManager-Menü; Sie können diese ignorieren.


Layer

Zeichnungslayer dienen in AutoCAD als primäres (und praktisch einziges !) Ordnungskriterium – dementsprechend zentral ist auch die Bedeutung der Layer im gesamten AutoCAD-System. Zudem spielen die Layer (wiederum als Strukturierungsmerkmal) auch eine entscheidende Rolle beim Datenaustausch mit anderen CAD-Systemen.

Ebenso grundlegend ist daher die Bedeutung, welche ihnen der LayerManager beimißt – und es sich daher zum Ziel gemacht hat, dem Anwender ein Arbeitsmittel zur Verfügung zu stellen, welches bzgl. Handhabung und Funktionalität in der alltäglichen Arbeit den Zeichnungslayern samt ihrer zentralen Bedeutung gerecht wird.

Um die Handhabung der Layer zu vereinfachen, erweitert der LayerManager die Zeichnungslayer um einen zusätzlichen Beschreibungstext – insbesondere, wenn die Layer auf Grund von Normungen oder Zeichnungs-Vorschriften einen kryptischen/codierten Namen tragen, erhöht der Beschreibungstext die Übersichtlichkeit und Wiederauffindbarkeit beträchtlich. Der Layer-Beschreibungstext kann insgesamt 255 Zeichen beliebigen Text umfassen.

Neben den AutoCAD-üblichen Layerfunktionen, welche lediglich den Layerzustand beeinflussen, bietet der LayerManager mehr als ein Dutzend weitergehender, praxisbezogener Funktionen an, um direkt mit den Layern in der Zeichnung arbeiten zu können – beispielsweise Layer inklusive der Zeichnungselemente kopieren und klonen, oder die Vordergrund/Hintergrund-Steuerung layerbezogen zu definieren.

Eine der herausragendsten Fähigkeiten des LayerManagers besteht in der Trennung der Layersteuerung zwischen Modellbereich und Papierbereich, sowie der Möglichkeit, (nicht nur) die Layer in mehreren Papierbereichs-Viewports simultan zu steuern. Dadurch wird insbesondere die Strukturierung der Viewports drastisch vereinfacht und beschleunigt; außerdem entfällt bei häufigem Wechsel zwischen Modell- und Papierbereich die notwendige Anpassung der Layer (Layer müssen im Papierbeich getaut sein, um im Papier-bereich sinnvoll nutzbar zu sein).

Selbstverständlich arbeitet der LayerManager mit den Layern vollständig kompatibel zu AutoCAD.


Layergruppen

Als Erweiterung des AutoCAD-Layer-Konzeptes bietet der LayerManager mit den Layergruppen ein neues, weitergehendes Ordnungskriterium innerhalb der Zeichnung an – und damit zugleich hocheffektive Objekte, um die Zeichnung zu steuern und Zeichnungselemente zu beeinflussen.

Eine Layergruppe stellt die Zusammenfassung von Layern zu einer Einheit dar - und kann später auch als Einheit gehandhabt werden. Der Name einer Layergruppe ist frei wählbar, ohne Einschränkung der verwendbaren Zeichen, und kann bis 255 Zeichen lang sein. Ebenso wie die Layer können auch Layergruppen mit einem zusätzlichen Beschreibungstext versehen werden (bis 255 Zeichen).

Die in einer Layergruppe zusammengefassten Layer können natürlich auch in beliebigen weiteren Layergruppen enthalten sein – in einer Layergruppe werden die enthaltenen Layer generell als Links/Verweise betrachtet, nicht als Zeichnungslayer selbst !

Praktisch alle Operationen, welche AutoCAD mit den Layern anbietet, können Sie ebenso und völlig identisch mit einzelnen oder mehreren Layergruppen (oder beliebigen Teilen davon) im LayerManager ausführen - gerade hierin liegt die eigentliche Leistungsstärke des Programms. So können Sie in der Zeichnung durch Layergruppen blättern, Layergruppen ein- und ausschalten, miteinander kombinieren, Farben, Linientypen etc. zuweisen und vieles, vieles mehr. So wie der AutoCAD-Layerdialog die Zeichnungslayer darstellt, sehen Sie sowohl die Layer als auch die Layergruppen mit all ihren Eigenschaften angezeigt – auch hierin zeigt sich die vollständige Übertragung des Layerkonzeptes auf Layergruppen im LayerManager.

Für AutoCAD selbst sind die Layergruppen nicht erkennbar (leider), d.h. Layergruppen können nicht in Zusammenhang mit normalen AutoCAD-Befehlen verwendet werden – ihre Anwendung ist z.Zt. nur innerhalb des LayerManager möglich. LaymanPro stellt jedoch alle Funktionen, welche Sie im AutoCAD-Layerdialog vorfinden, sowohl für Layer als auch für Layergruppen (und Hierarchien !) identisch zur Verfügung – und ist somit mehr als nur ein kompatibler Ersatz für den die AutoCAD-Dialog ...

Die Layergruppen werden (wie alle LayerManager-Objekte) direkt in der Zeichnung gespeichert (als Elemente auf dem Layer "$LAYMAN") und sind für AutoCAD lediglich ganz normale Zeichnungselemente – somit sind keine negativen Rückwirkungen auf Ihre Zeichnung zu befürchten; andererseits sind somit die LayerManager-Strukturen und –Daten immer verfügbar, selbst innerhalb von Zeichnungsblöcken und XRefs. Weitere Details zur Speicherung der LayerManager-Daten finden Sie unter "Speicherung der LayerManager-Daten".


Hierarchien

Die logische Fortsetzung des Layergruppen-Konzeptes sind die Hierarchien. Das Konzept der Hierarchien entspricht nahezu identisch dem Verzeichnis-/Ordner-Konzept, mit welchem die Daten auf einer Festplatte verwaltet werden. Layergruppen können ebenso in Verzeichnisbäumen geordnet und strukturiert werden, welche beliebig komplex und beliebig tief sein können.

Mit dem Hierarchie-Konzept wird die Verwaltung einer größeren Zahl von Layergruppen nicht nur einfacher und übersichtlicher, sondern Ihre Zeichnung kann zudem wesentlich besser gegliedert und definierte Zusammenhänge zwischen Layern, Layergruppen und Hierarchien schneller sichtbar gemacht werden.

Jede Hierarchie besteht zunächst aus einem Namen (bis 255 Zeichen) sowie einem zugehörigen Beschreibungstext (bis 255 Zeichen) und kann beliebig weitere Sub-Hierarchien und/oder Layergruppen enthalten – so, wie ein Verzeichnis auf der Festplatte weitere Unter-Verzeichnisse und Dateien enthalten kann. Die Hierarchien entsprechen hierbei den Verzeichnissen, die Layergruppen darin enthaltenen Dateien. Auch im LayerManager sind Hierarchien (Verzeichnisse) und Layergruppen (Dateien) verschiedenartgie, getrennte Objekte :

  1. jede Hierarchie kann beliebig weitere Hierarchien und Layergruppen enthalten;

  2. Hierarchien und Layergruppen können (logischerweise) nicht den gleichnamig benannt werden

  3. Layergruppen selbst können keine weiteren Sub-Hierarchien oder Layergruppen enthalten

In einer Hierarchie enthaltene Sub-Hierarchien und Layergruppen werden gererell als Links/Verweise behandelt – daher kann jede Layergruppe und jede Sub-Hierarchie in beliebig anderen Hierarchien enthalten sein – es wird dadurch stets das absolut gleiche Objekt referenziert. Beispielsweise kann eine Layergruppe z.B. in 3 Hierarchien enthalten sein – die Layergruppe selbst existiert nur ein einziges Mal !

Generell gilt im LayerManager: Jedes Objekt (Hierarchien, Layergruppe, Layer) besteht nur einmal, kann aber beliebig oft in übergeordneten Objekte referenziert werden – dadurch wird die Eindeutigkeit in der Zeichnung gewährleistet.

Hierin liegt ein wichtiger Unterschied zum Windows-Explorer; ein Beispiel soll das verdeutlichen :

Auf der Festplatte kann eine Datei mit Namen "xyz.txt" beliebig oft in verschiedenen Verzeichnissen existieren – es sind real dann wirklich verschiedene Dateien, welche durchaus verschiedenen Inhalt haben können; Gleiches gilt analog auch für Verzeichnisse. Haben Sie dagegen im LayerManager eine Layergruppe mit Namen "Gruppe_Rot" erstellt, so können Sie diese dann in verschiedene Hierarchien (Verzeichnissen) einfügen – die Layergruppe selbst besteht aber real nur einmal in der Zeichnung ! Ebenso können Sie eine vorhandene Hierarchie (im Sinne eines Unter-Verzeichnisses) nach Belieben als Sub-Hierarchie in weitere Hierarchien einfügen, kopieren oder verschieben – es handelt sich dann stets nur um Verweise auf die entsprechende Hierarchie; das Hierarchie-Objekt slebst ist nur einmal vorhanden.

Der LayerManager bietet ausnahmslos alle Funktionen, welche zur Verwaltung und Anwendung der Layer und Layergruppen zur Verfügung stehen, in völlig identischer Weise auch für Hierarchien an. Sie finden somit eine sehr homogene und konsistente Bedienung und Anwendung aller LayerManager-Objekte vor. Ebenso wie Layergruppen werden auch die Hierarchien unmittelbar in der Zeichnung gespeichert und stehen als solche auch nur im LayerManager zur Verfügung – für AutoCAD bestehen keine derartigen Strukturen.

Hierarchiebäume werden generell (und nur) im linken Anzeige-Fenster dargestellt.


Grundlagen des LayerManagers - Layer-History

Layer-History

Eines der interesantesten Leistungsmerkmale des LayerManagers zeigt sich im Umgang mit Modellbereich, Papierbereich und den Layouts – auf Knopfdruck kann die aktuelle Layer-Konfiguration, versehen mit einem Beschreibungstext, in der Zeichnung gespeichert werden. Diese Art eines "Schnappschusses" wird als "History-Position" bezeichnet, und erlaubt das Aufheben und Wiederherstellen von Layer-Konfigurationen.

Damit lassen sich insbesondere folgende Aufgaben schnell und einfach realisieren:

  1. alternativ und als Ergänzung zum Layergruppen/Hierarchie-Konzept können komplexe Layer-Konfigurationen gespeichert werden, welche nur aufwendig über Layergruppen/Hierarchien hergestellt werden können – zwischen diesen Layer-Konfigurationen können Sie somit sehr einfach wechseln

  2. für temporäre Layer-Konfigurationen, welche nicht oder nur unvollständig mit Layergruppen/Hierarchien erstellt werden können, bietet sich so eine Form der Speicherung und Wiederherstellung

  3. insbesondere im Papierbereich bzw. in den Layouts wird ausserdem auch die viewport-spezifische Layer-Einstellung gespeichert, womit beim Restaurieren der Papierbereich bzw. das Layout vollständig wiederhergestellbar sind.

Historie-Positionen beinhalten generell nur die Layer-Sichtbarkeit (Ein/Aus, Frieren/Tauen) - es werden keine sonstigen Layer-Eigenschaften (wie Farbe, Linientyp etc.) gespeichert. Somit wird beim Restaurieren von History-Positionen auch nur die Sichtbarkeit der Layer geschaltet.

Die Speicherung der "History-Positionen" erfolgt generell getrennt für Modell-/Papierbereich und Layouts, so daß Sie problemlos auch gleichnamige Positionen in den verschiedenen Bereichen nutzen können. Alle Funktionen zur Verwaltung, Speicherung und Wiederherstellung von History-Positionen finden Sie als Icons in der Statuszeile sowie auf dem Kontextmenü, welches sich mit der rechten Maustaste über den Icons öffnet.

 Mit einem Klick der rechten Maustaste öffnet sich das abgebildete Kontextmenü, welches alle Funktionen zur "Layer-History" beinhaltet:

Restaurieren: stellt die aktuelle History-Position in der Zeichnung wieder her

Speichern: speichert die aktuelle Layer-Konfiguration mit Infotext ab

Aktualisieren: Update der History-Position mit der aktuellen Layer-Konfiguration

Infotext ändern: erlaubt die Änderung des Beschreibungstextes der Position

Vorherige/Nächste Position: Positionierung auf den entsprechenden History-Eintrag

Übersichtsliste: zeigt eine Übersichts-Liste mit allen History-Positionen zur Auswahl

Position löschen: löscht die aktuelle History-Position nach Rückfrage

History übertragen: kopiert eine History-Position in andere Layouts

Export/Import History: erstellt bzw. lädt die History-Export/Import-Datei; damit können gespeicherte Layer-Konfigurationen einfach und schnell zwischen Zeichnungen ausgetauscht werden

Insbesondere die Funktionen zum Export/Import sowie zum Übertragen von History-Positionen in andere Layouts bieten enorme Möglichkeiten, gesamte Layout-Konfigurationen in andere Zeichnungen bzw. in andere Layouts zu übertragen – damit konfigurieren Sie neue Layouts in kürzester Zeit mit hoher Sicherheit oder gleichen bestehende Layouts aufeinander ab. Weitere Details finden Sie im Kapitel "Layer-History".


Grundlagen des LayerManagers - Layout-abhängige Layer-Eigenschaften

Layout-abhängige Layer-Eigenschaften

Eine weitere, äußerst leistungsfähige Funktion bietet der LayerManager mit den sogenannten "Layout-abhängigen Layer-Eigenschaften" an, welche insbesondere dann sehr hilfreich ist, wenn Sie mit (vielen) unterschiedlich konfigurierten Layouts arbeiten.

Grundprinzip: für alle Modell-/Papierbereiche und für alle Layouts speichert der LayerManager komplett die aktuell verwendeten Layer-Eigenschaften, um diese (konfigurierbar) im jeweiligen Bereich automatisch wieder zu restaurieren. Beim Verlassen eines Bereiches/Layouts erfolgt die Speicherung der aktuell eingestellten Layer-Eigenschaften, beim Eintritt in einen anderen Bereich/Layout wird dieser mit seinen spezifischen Eigenschaften automatisch wieder restauriert.

Wenn Sie in der LayerManager-Konfiguration die Option "M-/P-Bereich automatische restaurieren" aktiviert haben, ist die Funktion zur Nutzung der "Layout-abhängigen Layer-Eigenschaften" einsatzbereit und bei jedem Wechsel in ein anderes Layout wird dieses auf die hier zuletzt verwendeten Layer-Eigenschaften eingestellt. Die Speicherung der Layer-Eigenschaften erfolgt auch bei ausgeschalteter Option !

Zur Erleichterung der Handhabung sowie zur schnellen Einflussnahme auf die Arbeitsweise dieser Funktion steht eine eigene Toolbar zur Verfügung – hier können Sie ebenfalls die automatische Restaurierung ein-/ausschalten sowie die zu restaurierenden Layer-Eigenschaften konfigurieren.

Damit besteht erstmals in AutoCAD die wirkliche Möglichkeit, alle Layouts vollständig unabhängig voneinander zu konfigurieren und zu nutzen – insbesondere beim Plotten mit verschiedenen Layouts eine enorme Erleichterung und Zeiteinsparung und Sicherheit gegen Fehleinstellungen !

Weitere Details zur Anwendung finden Sie im Kapitel "Layout-abhängige Layer-Eigenschaften".


LayerManager-Objekte in XRefs und Blöcken

Eines der interessantesten und wichtigsten Leistungsmerkmale des LayerManagers zeigt sich in der Nutzung von LayerManager-Objekten, welche in zugeordneten bzw. gebundenen XRefs und in Blöcken gefunden werden.

Beim ersten Durchsuchen einer Zeichnung nach LayerManager-Daten werden auch die zur Zeichnung gehörenden XRefs und die in der Zeichnung vorhandenen Blöcke analysiert. Dabei spielt es keine Rolle, ob eine XRef-Zeichnung in der Form "zugeordnet" oder "gebunden" verwendet wird. Gleiches gilt für Blöcke: diese können sowohl als nornale Blockreferenz wie auch als aufgelöste Blockreferenz vorliegen; auch wenn ein geladener Block in der Zeichnung nicht durch eine entsprechende Blockreferenz genutzt wird, erkennt der LayerManager die im Block ggf. enthaltenen LayerManager-Objekte. Die Darstellung von in XRefs enthaltenen Layern, Layergruppen und Hierarchien entspricht der von AutoCAD bekannten Form; zusätzlich stellt LaymanPro auch die in Blöcken gefundenen Objekte so dar.

Darstellung von XRefs-bezogenen Layern, Layergruppen und Hierarchien:

XRef (zugeordnet) | XRefname | Layer | XRefname | Layergruppe | XRefname | Hierarchie
XRef (gebunden) | XRefname $0$ Layer | XRefname $0$ Layergruppe | XRefname $0$ Hierarchie
Block | Als normaler Layer | Blockname | Layergruppe | Blockname | Hierarchie

Wird ein zugeordnetes XRef gebunden/gelöst, so wird dies automatisch erkannt, falls die Option "Rx-Automation" eingeschaltet ist; anderenfalls muß der LayerManager re-initialisiert werden ("Menü/Datei/Re-Initialisierung"), um die Änderung zu registrieren und alle Daten wieder korrekt anzuzeigen.


Speicherung der LayerManager-Daten

Die Speicherung der LayerManager-Daten direkt in der Zeichnung bietet den Vorteil, daß alle Strukturen stets vorhanden sowie aktuell sind – auch bei Verwendung einer Zeichnung als Block oder XRef.

Hierfür erzeugt LaymanPro sowohl einen Layer als auch einen Block mit Namen "$LAYMAN" sowie diverse Zeichnungselemente. Hierbei tragen diese Elemente die eigentlichen Steuerdaten des LayerManagers als sogenannte "Extended Entitiy Data (EED)". Der Block "$LAYMAN" dient dem schnellen Auffinden dieser Elemente. Alle Elemente auf dem Layer "$LAYMAN" werden immer und generell unsichtbar erzeugt – es besteht keine Gefahr, daß diese Elemente z.B. auf einem Plot erscheinen könnten. Möchten Sie die LayerManager-Daten aus der Zeichnung entfernen, so besteht unter "Menü/Extras/Entferne Daten" die Möglichkeit, diese Daten restlos zu löschen – das Programm beendet sich nach Fertigstellung der "Aufräum-Arbeiten" automatisch und Sie haben eine saubere Zeichnung.

Wichtig: als Anwender lassen Sie bitte den Layer "$LAYMAN" stets eingeschaltet, getaut und entsperrt.

Hinweis: weder Zeichnungselemente noch Block "$LAYMAN" haben negative Rückwirkung, wenn die Zeichnung auf einem Rechner ohne LayerManager verwendet wird – alle Daten bleiben bestehen und stören AutoCAD-Applikationen nicht. Sollte es notwendig sein, die LayerManager-Daten aus der Zeichnung zu entfernen, so bietet der LayerManager mit "Daten entfernen" eine passende Funktion.


Hinweise zu AutoCAD LT

Ab der Version v4.1a (August 2001) ist der LayerManager vollständig und identisch auch mit AutoCAD LT in den Versionen LT 2000/2000i/2002 einsetzbar. Hierbei arbeitet die LayerManager-Version für AutoCAD 2000/2000i/2002 vollständig identisch mit AutoCAD LT 2000/2000i/2002.

AutoCAD LT 97/98 wird gegenwärtig nicht unterstützt – es ist jedoch nicht ausgeschlossen, daß dies zu einem späteren Zeitpunkt integriert wird.

Um den LayerManager mit AutoCAD LT einzusetzen, brauchen Sie das Programm lediglich bei AutoCAD LT anzumelden – dies erfolgt sicher und komfortabel mit dem Registrierungs-Tools "Register 2 AutoCAD", welches in der LayerManager-Programmgruppe im Startmenü zu finden ist. Damit können Sie LaymanPro problemlos mit allen Ihren installierten AutoCAD/AutoCAD LT Versionen einsetzen – auch im Netzwerk !

Die technische Realisierung der Integration des LayerManagers in AutoCAD LT basiert auf unserer LTE2000-Kernel-Technologie – dieser LTE2000-Kernel bietet Anwendungen sowohl das ARX- als auch das LISP-Interface unter AutoCAD LT an.

Hinweis: wenn Sie den LayerManager deinstallieren möchten, so melden Sie bitte das Programm vor der Deinstallation unbedingt bei AutoCAD LT ab - anderenfalls erscheint einmalig eine (harmlose) Fehlermeldung zum vermissten LayerManager-Menü – Sie können dies einfach ignorieren !


Das Programm-Fenster - Überblick

Überblick

Die Oberfläche des LayerManagers orientiert sich optisch und funktionell stark am bekannten Windows-Explorer von Windows95/98/NT40 – und verhält sich weitestgehend auch so. Daher findet der Anwender eine ihm bekannte und gewohnte Oberfläche vor, und kann sich ganz dem Schwerpunkt seiner Arbeit widmen. Ebenso wurde weitestgehend auch die Bedienung von AutoCAD berücksichtigt, d.h. alle mit AutoCAD-Dialogen vergleichbare Dialoge des LayerManagers verhalten sich praktisch gleich, so daß dem Anwender eine ständige Umgewöhnung erspart bleibt. Zur effizienten und schnellen Handhabung stehen alle üblichen Dialogelemente zur Verfügung; die gesamte Programmoberfläche sowie alle Dialogelemente können beliebig konfiguriert werden. Der LayerManager speichert alle die Oberfläche betreffenden Einstellungen, so daß der Anwender stets die zuletzt benutzte Programmoberfläche wiederfindet.

Der LayerManager arbeitet, analog zum Windows-Explorer, generell mit 2 Anzeigefenstern. Hierbei besitzt das linke Anzeigefenster Priorität gegenüber dem rechten Anzeigefenster. Das bedeutet, daß sich das rechte Anzeigefenster (je nach Einstellung beider) dem linken ggf. unterordnet. Dieses Verhalten wird detailliert in den Kapiteln zum linken Anzeigefenster bzw. rechten Anzeigefenster beschrieben.

Der Begriff "linkes Anzeigefenster" steht sinngemäß auch für das "obere Anzeigefenster" (bei horizontaler Teilung); analog steht "rechtes Anzeigefenster" auch für das "untere Anzeigefenster".

Zu den konfigurierbaren Dialogelementen gehören :

· Ein/Ausschaltbare Menüleiste

· Ein/Ausschaltbare Statuszeile

· verschiedene ein/ausschaltbare ToolBars, (freiliegend oder angedockt)

· Ein/Ausschaltbare Suchleiste (freiliegend oder angedockt)

· angedockte Zeichnungsliste zum schnellen Wechsel der zugeordneten Zeichnung (nur R2000)

Das Programm-Fenster selbst bietet zusätzlich folgende Möglichkeiten:

· Öffnen weiterer Programm-Fenster ;

· Größe und Position sind frei einstellbar;

· Die Fensterteilung kann vertikal und horizontal erfolgen

· Schriftart und Schriftgröße sind frei einstellbar

· beide Fensterhälften bieten weitere Einstellungen bzgl. der Darstellung ihres Inhaltes

Das LayerManager-Fenster kann hierbei mehrfach geöffnet werden; jedes übernimmt anfänglich alle Einstellungen des vorherigen Fensters, arbeitet dann aber vollständig autonom. Jedoch unterscheidet sich die Bedienung in einigen Feinheiten von jener des Windows-Explorers. Die Erweiterung des Bedienkonzeptes ist notwendig, um wesentlichen LayerManager-Konzepte und Funktionen sinnvoll anwendbar zu machen. Alle Details zu Oberfläche und Bedienung werden nachfolgend ausführlich dargestellt – insbesondere werden die Unterschiede zum Windows-Explorer deutlich hervorgehoben.


Oberfläche konfigurieren

Der LayerManager erlaubt sehr weitgehend die Anpassung seines Erscheinungsbildes gemäß den Wünschen des Anwenders. Insbesondere unter dem Aspekt, die Fläche in einem Anzeigefenster zu vergrößern, oder um bestimmte Funktionen schnell zu erreichen, können Sie gewünschte Teile der Oberfläche aus- bzw. einschalten. LaymanPro merkt sich Ihre zuletzt verwendete Oberfläche, und stellt diese beim nächsten Programmstart wieder her. Haben Sie mehrere LayerManager-Fenster Auto-Strukturierung geöffnet, kann jedes separat konfiguriert werden ! Dabei beachten Sie bitte, daß die Oberfläche des zuletzt geschlossenen LayerManagers als Grundlage für den nächsten Programmstart (in der nächsten AutoCAD-Sitzung) dient.

Folgende Objekte der Programmoberfläche sind konfigurierbar: Menüleiste, Statuszeile, verschiedene ToolBars, Suchleiste, ToolTips, Zeichnungsliste (nur in R2000(i)), Schriftart/größe, Außerdem bieten das linke und das rechte Anzeige-Fenster eigene, weitergehende Einstellungen, die den angezeigten Inhalt betreffen.

Schriftart, Schriftgröße, Schriftfarbe anpassen: Mit dem Menüpunkt "Menü/Ansicht/Schriftart" öffnet sich der Windows-übliche Dialog zur Auswahl der Anzeige-Schriftart – wählen Sie Textfont, Größe und Farbe nach Wunsch aus. Nach Verlassen des Dialoges wird Ihre Auswahl dann eingestellt und dauerhaft gespeichert.


Mehrfache Programm-Fenster

Der LayerManager kann mehrfach geöffnet werden – d.h. Sie können 2, 3 oder mehr LayerManager-Fenster gleichzeitig nutzen, um beispielsweise (in AutoCAD 2000(i)) mehrere Zeichnungen simultan zu bearbeiten, oder verschiedene Darstellungen einer Zeichnung gleichzeitig zu erhalten, oder auch, um per Drag-&-Drop LayerManager-Daten innerhalb der gleichen bzw. zwischen verschiedenen Zeichnungen (in AutoCAD 2000(i)) zu übertragen. Um ein neues LayerManager-Fenster zu öffnen, nutzen Sie die Funktion "Neues Fenster" (Menü/Ansicht/Neues Fenster). Das neue Fenster übernimmt zunächst alle Einstellungen des vorherigen – arbeitet dann jedoch vollständig autonom, d.h. Sie können das neu geöffnete Programm-Fenster nach Belieben einstellen, ohne andere Fenster zu beeinflussen.

Hinweis: Wenn Sie am AutoCAD-Prompt den LayerManager-Befehl (laymanpro, lmpro) wiederholt eingegeben, wird kein neues Programm-Fenster geöffnet – vielmehr werden alle geöffneten LayerManager auf normale Größe restauriert und in den Vordergrund gesetzt. Sie können dies nutzen, um verdeckte, minimierte oder nicht sichtbare Fenster wiederherzustellen.


Linkes Anzeige-Fenster

Im linken Anzeige-Fenster werden alle Layergruppen bzw. Hierarchien angezeigt. Die Anzeige erfolgt als "Baumliste" (TreeView), die Sie zwischen den Modi "Gruppen" und "Hierarchien" umschalten können.

Modus "Layergruppen": Es werden alle Layergruppen angezeigt, inklusive der enthaltenen Layer.

Modus "Hierarchien": Es werden alle Hierarchien angezeigt, inklusive der enthaltenen Sub-Hierarchien und.Layergruppen; die in den angezeigten Layergruppen enthaltenen Layer werden nicht angezeigt.

Nachfolgend eine Beschreibung der Titelzeile von links nach rechts:

Alle Icons erscheinen normalerweise flach und in Schwarz-Weiss-Darstellung; erst wenn sich der Mauszeiger über einem Icon befindet, erscheint dieses plastisch (3D-Look) und wird farbig; in der Statuszeile erscheint eine Beschreibung zum entsprechenden Icon.

"Auswahl-Filter" – (Ctrl-F) öffnet den Filter-Dialog zur Wahl von Layergruppen bzw. Hierarchien

"Alles auswählen" – (Ctrl-A) wählt alle (sichtbaren) Objekte (Hierarchien/Gruppen)

"Auswahl umkehren" – (Ctrl-R) kehrt die angezeigte Auswahl um

"Nichts auswählen" – (Ctrl-N) hebt die aktuelle Auswahl auf

"Anzeige-Modus" – Anzahl gewählter/verfügbarer Objekte im Anzeige-Modus

"Modus: Hierarchie-Modus" – schaltet die Anzeige in den Modus "Hierarchie

"Modus: Gruppen-Modus" – schaltet die Anzeige in den Modus "Layergruppen"

Im Gegensatz zum Windows-Explorer können Sie auch im linken Anzeige-Fenster mehrere Objekte markieren und die zur Verfügung stehenden Bearbeitungsfunktionen auf die gesamte Auswahl anwenden. Gewählte Objekte erkennen Sie (außer am Auswahlbalken) auch an den rot gefärbten Objekt-Icons.


Rechtes Anzeige-Fenster

Im rechten Anzeige-Fenster werden, je nach Anzeige-Modus, die vorhandenen Layergruppen der Zeichnung oder eingeschlossene Layergruppen gewählter Hierarchien, oder 4 verschiedene Layerlisten bzgl. der Zeichnung oder der im linken Fenster gewählten Objekte angezeigt. Die Anzeige erfolgt hier generell als sogenannte "Iconliste". Mit den Icons in der rechten Titelzeile können Sie können den Anzeige-Modus zwischen insgesamt 6 verschiedenen Darstellungen umschalten.

Sowohl bei der Anzeige von Layern wie auch der Anzeige von Layergruppen werden stets alle Eigenschaften (wie Sichtbarkeit, Farbe, Sperrung, Linientyp und Beschreibung) angezeigt. Nur ab AutoCAD 2000(i) werden zusätzlich auch Linienstärke, Plotstatus und Plotstil angezeigt.

Modus "Alle Layergruppen":

Es werden alle in der Zeichnung verfügbaren Layergruppen, inklusive aller Eigenschaften angezeigt. Art und Anzahl der im linken Fenster gewählten Objekte hat keinen Einfluß auf die Anzeige.

Modus "Abhängige Layergruppen": (Bedingung: linkes Fenster ist im Anzeige-Modus "Hierarchien")

Es werden alle Layergruppen angezeigt, welche Bestandteil der im linken Anzeige-Fenster gewählten Hierarchien sind. Haben Sie im linken Fenster mehere Hierarchien gewählt, so sehen Sie die Summe aller (lin den inks gewählten Hierarchien) enthaltenen Layergruppen.

Hinweis: wenn Sie im linken Fenster statt einer/mehrerer Hierarchien eine oder mehrere Layergruppen wählen, so wechselt die Anzeige im rechten Fenster automatisch von "Abhängige Layergruppen" in "Abhängige Layer", um eine sinnvolle Anzeige zu ermöglichen.

Modus "Alle Layer":

Es werden alle in der Zeichnung verfügbaren Layer, inklusive aller Eigenschaften angezeigt. Art und Anzahl der im linken Fenster gewählten Objekte hat keinen Einfluß auf die Anzeige.

Modus "Abhängige Layer": (Bedingung: linkes Fenster ist im Anzeige-Modus "Layergruppen")

Es werden alle Layer angezeigt, welche Bestandteil der im linken Anzeige-Fenster gewählten Objekte (Gruppen oder Hierarchien) sind. Haben Sie im linken Fenster mehrere Objekte gewählt, so sehen Sie die Summe aller in den links gewählten Objekten enthaltenen Layer.

Modus "Sichtbare Layer":

Es werden alle Layer der Zeichnung angezeigt, welche momentan sichtbar (also getaut und eingeschaltet) sind. Art und Anzahl der im linken Fenster gewählten Objekte hat keinen Einfluß.

Modus "Nicht sichtbare Layer":

Es werden alle diejenigen Layer der Zeichnung angezeigt, welche momentan nicht sichtbar (also gefroren oder ausgeschaltet) sind. Art und Anzahl der im linken Fenster gewählten Objekte hat keinen Einfluß auf die Anzeige.

Zur besseren Handhabung und Identifizierung verwenden Layergruppen und Layer verschiedene Icons für jedes Objekt, wie in den beiden Bildern ersichtlich ist :

Nachfolgend eine Beschreibung der Titelzeile von links nach rechts:

Alle Icons erscheinen normalerweise flach und in Schwarz-Weiss-Darstellung; erst wenn sich der Mauszeiger über einem Icon befindet, erscheint dieses plastisch (3D-Look) und wird farbig; in der Statuszeile erscheint eine Beschreibung zum entsprechenden Icon.

"Auswahl-Filter" – (Ctrl-F) öffnet den Filter-Dialog zur Wahl von Layergruppen bzw. Hierarchien

"Alles auswählen" – (Ctrl-A) wählt alle Objekte (Gruppen oder Layer)

"Auswahl umkehren" – (Ctrl-R) kehrt die angezeigte Auswahl um

"Nichts auswählen" – (Ctrl-N) hebt die aktuelle Auswahl auf

"Anzeige-Modus" – Anzahl und Modus gewählter/verfügbarer Objekte

"Display Filter" – öffnet den Display-Filter-Dialog zur individuellen Anpassung der Anzeige-Liste

"Modus: Alle Gruppen" – schaltet die Anzeige in den Modus "Alle Gruppen"

"Modus: Abhängige Gruppen" – schaltet die Anzeige in den Modus "Abhängige Gruppen"

"Modus: Alle Layer" – schaltet die Anzeige in den Modus "Alle Layer"

"Modus: Abhängige Layer" – schaltet die Anzeige in den Modus "Abhängige Layer"

"Modus: Sichtbare Layer" – schaltet die Anzeige in den Modus "Sichtbare Layer"

"Modus: Nicht Sichtbare Layer" – schaltet die Anzeige in den Modus "Nicht Sichtbare Layer"

Analog zum AutoCAD-Layerdialog können Sie Layer und Layergruppen direkt mit den Eigenschaften-Spalten steuern. Durch Klicken in eine Spalte wird für die markierten Objekte, bzw. für das Objekt in der angeklickten Zeile, die entsprechende Einstellungsfunktion gestartet. Weiterhin besteht die Möglichkeit, gewünschte Objekte auch im Bereich der Eigenschafts-Spalten zu wählen, ohne die Einstellungsfunktion zu starten. Details hierzu finden Sie im Kapitel "Objekte auswählen / markieren".

Einstellung der Anzeigespalten : Für das rechte Anzeige-Fenster besteht zusätzlich die Möglichkeit, Anzahl und Reihenfolge der zu nutzenden Eigenschaften-Spalten zu bestimmen. Die entsprechende Funktion finden Sie im Menü bzw. Kontextmenü für das rechte Anzeige-Fenster unter "Menü/Anzeige/Spalten einstellen".

Sortierung der Anzeige nach Spalten :

Die Sortierung der Anzeige im rechten Fenster kann auch über die angezeigten Spalten erfolgen – klicken Sie einfach auf den Kopf derjenigen Spalte, nach welcher die Sortierung erfolgen soll.

siehe auch :

Anzeige-Spalten einstellen

Anzeige-Sortierung nach Spalten

Display-Filter einstellen und anwenden


Anzeige-Spalten einstellen

Für das rechte Anzeige-Fenster besteht die Möglichkeit, Anzahl und Reihenfolge der sichtbaren Spalten zu bestimmen. Damit steht eine komfortable Methode bereit, das rechte Anzeige-Fenster genau auf die gewünschte Darstellung anzupassen. Diese Funktion finden Sie im Menü bzw. Kontextmenü für das rechte Anzeige-Fenster unter "Menü/Anzeige/Spalten einstellen".

Alternativ können die Spaltenköpfe auch per Drag-&-Drop verschoben werden. Mit einem rechten Mausklick auf einen Spaltenkopf erscheint ein Kontext-Menü, welche alle Spalten-Optionen enthält.

Um eine Spalte ein- oder auszublenden, klicken Sie in das Kontrollkästchen der entsprechenden Spalte; um die Reihenfolge der Anzeige-Spalten zu ändern, wählen Sie eine Spalte und bewegen diese mit den Button "Auf"/"Ab" an die gewünschte Position und wiederholen den Vorgang ggf. mit der nächsten Spalte usw., bis die gewünschte Reihenfolge aller Spalten Ihren Wünschen entspricht. Alle Funktionen zur Einstellung der Anzeige-Spalten sind auch per Kontextmenü verfügbar: klicken Sie mit der rechten Maustaste auf einen Spalten-Kopf, um das Kontextmenü der Spalte zu öffnen.

Die Einstellung der Spalten (Spalte ein/aus, Reihenfolge, Spaltenbreite) wird dauerhaft gespeichert und bei späteren Programmstarts auch wieder, entsprechend dem letzten Zustand, hergestellt.


Anzeige-Sortierung nach Spalten

Mit den Spaltenköpfen kann die Anzeige des rechten Fenster nach der jeweiligen Spalten-Eigenschaft sortiert werden. Duch einen Mausklick (linke Maustaste) auf den Spaltenkopf wird die Anzeige neu sortiert. Mit jedem weiteren Klick auf den Spalten-Kopf wird die Richtung der Sortierung umgekehrt (wechselweise aufsteigend und absteigend). Damit ergeben sich vielfältige Möglichkeiten, die Anzeige nach einem gewünschten Kriterium aufzubauen. Beispielsweise wird durch die Sortierung nach der Spalte "Sichtbarkeit" erreicht, daß sich alle sichtbaren und auch alle nicht (oder nur teilweise) sichtbaren Objekte jeweils zusammen am Anfang bzw. am Ende der Anzeigeliste befinden.


Display-Filter einstellen und anwenden

Für die Anzeige der Layer und Layergruppen im rechten Anzeige-Fenster steht ein sogenannter "Display-Filter" bereit, mit dessen Hilfe Sie die Anzeige nach Wunsch einstellen und filtern können. Damit erhöhen Sie zum einen die Übersichtlichkeit, andererseits können so einfache Analysen durchgeführt werden.

Features:

  • benannte Filter bleiben in der Zeichnung gespeichert

  • alle Layer-Eigenschaften sind beliebig kombinierbar

  • alle Filter-Eigenschaften können jederzeit editiert werden

2 vordefinierte Filter sind generell vorhanden:

  • <Objekte: Benutzt>

  • <Objekte: Unbenutzt>

Diese beiden Filter zeigen Layer bzw. Gruppen, welche in anderen LayerManager-Objekten genutzt bzw. nicht genutzt werden.

Das Display-Filter-Fenster öffnet sich stets in der zuletzt benutzten Form und Position. Ein Doppelklick auf einen Filter-Namen aktiviert diesen sofort – das Display-Filter-Icon erscheint nun eingedrückt. Ein ToolTip zeigt auch den Namen des gerade aktiven Display-Filters an.

Display-Filter sind direkt in der Zeichnung gespeichert und mit allen Ansichts-Modi anwendbar.


Menüleiste

Die Menüleiste kann, wie alle anderen Dialogelemente des LayerManagers, abgeschaltet werden - dadurch erhalten Sie etwas mehr Platz für die Anzeige-Listen.Jedoch ist zu beachten, daß einige (seltener benutzte) Funktionen ausschließlich über die Menüleiste zur Verfügung stehen. Jeder Menüspalte ist eine entsprechende (und gleichnamige) ToolBar zugeordnet – dort finden Sie zwar nicht alle, doch die wichtigsten Funktionen ebenfalls. Wenn Sie eine der layer-, gruppen- oder hierarchie-bezogenen Funktionen aus der Menüleiste auswählen, so bezieht sich diese Funktion stets auf die im aktuellen Fenster gewählten Objekte (das aktuelle Fenster ist durch den cyan-farbigen Texthintergrund gekennzeichnet). Sind im aktuellen Fenster keine Objekte gewählt, so werden die entsprechenden Funktionen deaktiviert bzw. es erscheint ein diesbezüglicher Hinweis.

Um die ausgeblendete Menüleiste wieder anzuzeigen, nutzen Sie die entsprechende Funktion aus der ToolBar (ToolBar/Ansicht/Menüleiste) oder dem Kontextmenü (Kontextmenü/Ansicht/Menüleiste).


Statuszeile

In der Statuszeile am unteren Rand des Programm-Fensters zeigt der LayerManager die verschiedensten Informationen und Hinweise an – daher sollte die Statuszeile auch sinnvollerweise eingeschaltet sein. Möchten Sie jedoch die Anzeigefläche der beiden Fensterseiten maximal vergrößern, so kann die Statuszeile auch ausgeblendet werden. In diesem Falle werden die Beschreibungstexte der Layer, Gruppen und Hierarchien auch weiterhin, jetzt als gelbes "ToolTip"-Fähnchen unmittelbar am Mauszeiger, angezeigt.

Die Funktion zum Ein- und Ausschalten der Statuszeile finden Sie unter Menü/Ansicht/Statuszeile (analog in den Kontextmenüs der rechten Maustaste) sowie in der ToolBar "Ansicht".


ToolBars

Schnellstmöglichen Zugriff auf häufig benutzte LayerManager-Funktionen erlauben die ToolBars. Jeder Menüspalte entspricht eine ToolBar – jedoch sind nur die wichtigsten Funktionen einer Menüspalte auch in der zugehörigen ToolBar vorhanden.

ToolBars ein/ausblenden: Die Funktionen zum Einschalten/Ausschalten einer ToolBar finden Sie unter (Menü/Ansicht/Symbolleisten); hier finden Sie alle ToolBars aufgelistet. Ein kleines Häkchen zeigt an, ob die ToolBar sichtbar ist. Jede ToolBar kann separat angezeigt, an einer Fensterseite angedockt oder auch freiligend sein. Der LayerManager stellt beim Programmstart stets die zuletzt offenen ToolBars wieder her.


ToolTips

Für die meisten Menü-Einträge und Dialog-Elemente steht ein spezieller ToolTip mit hilfreichen Informationen zur Verfügung: dieser besitzt oft einen 2-teiligen Hilfetext. Erscheint am rechten Rand des ToolTip-Fensters ein kleines Dreieck, so steht ein weiterer, ausführlicherer Text bereit – bewegen Sie den Mauszeiger auf das ToolTip-Fenster, und es erscheint Teil 2 des Hilfetextes; bewegen Sie den Mauszeiger wieder aus dem ToolTip-Fenster heraus, so erscheint der ursprüngliche, kürzere Hilfetext.


Suchleiste

Die ein-/ausblendbare Suchleiste bietet schnellen Zugriff auf Objekte, welche dem angegebenen Suchtext entsprechen und verhält sich wie ein ToolBar, d.h. sie kann am oberen/unteren Dialogrand angedockt werden.

Mit den Schaltern "Name" und "Info" legen Sie fest, in welchen Datenwerten die Suche erfolgen soll. Den Suchtext geben Sie bitte (auch mit "Wildcards") direkt in der Klappliste ein oder wählen einen der früheren Suchtexte aus der Liste. Die Suche starten Sie mit den Buttons "Suche" bzw. "Suche Neu" – bei "Suche" werden die vorherigen Suchergebnisse erweitert, bei "Suche Neu" erfolgt unmittelbar eine neue Suche. Die Suche erfolgt stets im aktuellen Fenster und ausschließlich in den angezeigten Werten ! Die Suchergebnisse werden dann als Auswahl-Markierung im aktuellen Fenster angezeigt.

Hinweis: Möchten Sie komplexere Kriterien verwenden, oder eine Auswahl unabhängig von den angezeigten Fensterinhalten erstellen, so nutzen Sie bitte den Auswahlfilter. Diesen Auswahlfilter finden Sie sowohl in der Menüleiste sowie in den Kontextmenüs (Menü/Auswahl/Auswahlfilter).


Zeichnungsliste

(nur ab AutoCAD 2000(i))

Eine der herausragendsten Fähigkeiten des LayerManagers unter AutoCAD 2000(i) ist die Möglichkeit, eine der geöffneten Zeichnungen dem Programm-Fenster zuzuordnen. Jedes LayerManager-Fenster zeigt immer nur 1 Zeichnung, diese aber frei wählbar, an.

Um die Zeichnungsliste ein- und wieder auszublenden, nutzen Sie bitte die Funktion "Menü/Ansicht/Dwg-Liste". Diese Liste ermöglicht sowohl schnellen Zugriff/Wechsel der dem LayerManager-Fenster zugeordneten Zeichnung als auch die ständige Anzeige des vollständigen Zeichnungsnamens.

Prinzipiell können Sie im LayerManager (für jedes Fenster) unter folgenden Arbeitsmodi wählen :

· es wird stets die in AutoCAD aktuelle Zeichnung angezeigt

· es wird stets die gewählte Zeichnung angezeigt

Im Modus "aktuelle Zeichnung" (dargestellt mit <*AKTUELL*>) wird stets die in AutoCAD aktuelle Zeichnung angezeigt – wechseln Sie in eine andere Zeichnung, wechselt der LayerManager mit.

Im Modus "gewählte Zeichnung" wird dagegen die vom Anwender gewünschte Zeichnung angezeigt – auch wenn diese nicht die aktuelle AutoCAD-Zeichnung ist.

In beiden Modi wird die jeweilige Zeichnung immer auch mit vollem Namen inkl. Pfad angezeigt – spätestens wenn 2 gleichnamige Zeichnungen aus verschiedenen Verzeichnissen geöffnet sind, ein wichtiges Detail ... Unabhängig davon, ob die dem LayerManager-Fenster zugeordnete Zeichnung auch die in AutoCAD aktive Zeichnung ist, steht der gesamte Funktionsumfang zur Verfügung – Layer, Layergruppen und Hierarchien können problemlos auch in nicht-aktiven Zeichnungen gesteuert werden. Sehr wenige Funktionen (weil technisch nicht anders realisierbar) aktivieren die betreffende Zeichnung ggf. automatisch. Sie brauchen also, anders als in AutoCAD, die betreffende Zeichnung nicht zwangsweise in den Vordergrund setzen. Da beliebig viele Programm-Fenster geöffnet sein können, ist es somit kein Problem, auch mehrere Zeichnungen gleichzeitig im Blick zu behalten – und es besteht die Möglichkeit, gewählte LayerManager-Objekte per Drag-&-Drop zwischen den Zeichnungen auszutauschen ! Voraussetzung ist nur, daß zumindest 1 LayerManager-Fenster fest mit einer Zeichnung verbunden ist (also nicht alle Fenster im Modus "aktuelle Zeichnung" sind).

Zur Wahl der zugeordneten Zeichnung kann auch der Zeichnungs-Auswahl-Dialog genutzt werden.


Zeichnungs-Auswahl

(nur ab AutoCAD 2000(i) verfügbar)

Den Zeichnungs-Auswahl-Dialog erreichen Sie unter "Menü/Datei/Zeichnung" bzw. analog in den Kontextmenüs.

Eine der herausragendsten Fähigkeiten des LayerManagers unter AutoCAD 2000(i) ist die Möglichkeit, eine der geöffneten Zeichnungen dem Fenster zuzuordnen. Jedes LayerManager-Fenster zeigt immer nur 1 Zeichnung, diese aber frei wählbar, an.

Prinzipiell können Sie im LayerManager (für jedes Fenster) unter folgenden Arbeitsmodi wählen :

· es wird stets die in AutoCAD aktuelle Zeichnung angezeigt

· es wird stets die gewählte Zeichnung angezeigt

Im Modus "aktuelle Zeichnung" (dargestellt mit <*AKTUELL*>) wird stets die in AutoCAD aktuelle Zeichnung angezeigt – wechseln Sie in eine andere Zeichnung, wechselt der LayerManager mit.

Im Modus "gewählte Zeichnung" wird dagegen die vom Anwender gewünschte Zeichnung angezeigt – auch wenn diese nicht die aktuelle AutoCAD-Zeichnung ist.

Unabhängig davon, ob die dem LayerManager-Fenster zugeordnete Zeichnung auch die in AutoCAD aktive Zeichnung ist, steht der gesamte Funktionsumfang des Programmes zur Verfügung – Layer, Layergruppen und Hierarchien können völlig problemlos auch in nicht-aktiven Zeichnungen gesteuert werden. Bei sehr wenigen Funktionen (weil technisch nicht anders realisierbar) wird die betreffende Zeichnung ggf. automatisch aktiviert. Sie brauchen also, anders als in AutoCAD selbst, die betreffende Zeichnung nicht zwangsweise in den Vordergrund setzen.

Da beliebig viele Programm-Fenster geöffnet sein können, ist es somit kein Problem, auch mehrere Zeichnungen gleichzeitig im Blick zu behalten – und es besteht die Möglichkeit, gewählte LayerManager-Objekte per Drag-&-Drop zwischen den Zeichnungen auszutauschen ! Voraussetzung hierfür ist, daß zumindest 1 LayerManager-Fenster fest mit einer Zeichnung verbunden ist (sich also nicht alle Fenster im Modus "aktuelle Zeichnung" befinden ...). Benötigen Sie häufiger und schnelleren Zugriff auf die dem LayerManager-Fenster zugeordnete Zeichnung, so empfiehlt es sich, die sogenannte " Zeichnungsliste " einzublenden. Diese Popup-Liste dockt sich ähnlich einer ToolBar unterhalb der Menüleiste an; durch die permanent Sichtbarkeit dieser Auswahl-Liste ist schnellster Zugriff gewährleistet.


Kontextmenüs

Der LayerManager macht intensiven Gebrauch von situationsbezogenen Kontextmenüs; auch sind praktisch (bis auf sehr wenige Ausnahmen) alle relevanten Funktionen hier zu finden. Die Kontextmenüs stehen im Bereich der beiden Anzeige-Fenster zur Verfügung; außerhalb dieser Bereiche öffnen sich keine Kontextmenüs. Prinzipiell unterscheidet LaymanPro 2 verschiedene Situationen beim Öffnen von Kontextmenüs, d.h. beim Klicken mit der rechten Maustaste :

Der Mauszeiger befindet sich AUSSERHALB VON OBJEKTEN – dann wird das abgebildete objekt-neutrale Kontextmenü angezeigt.

Dieses objekt-neutrale Kontextmenü finden Sie identisch im linken und rechten Anzeige-Fenster: Im rechten Anzeige-Fenster kann das Kontextmenü auch im Bereich der Eigenschafts-Spalten durch Klicken mit der rechten Maustaste geöffnet werden.
Der Mauszeiger befindet sich AUF OBJEKT(EN) - dann wird das objektbezogenen Konext-Menü angezeigt.

Dieses Kontextmenü besitzt 2 sogenannte "Menü-Seiten"; hierbei beinhaltet die 1. Seite die meistbenutzten Anwendungs- und Verwaltungsfunktionen, auf der 2. Menüseite finden Sie die etwas weniger häufig benutzten Funktionen.

Das objektbezogene Kontextmenü öffnet sich stets mit der zuletzt benutzten Seite; zwischen den beiden Seiten wechseln Sie mit einem Klick auf den Eintrag "Anderes Menü".

Generell sind die Untermenüs in den genannten Kontextmenüs völlig identisch zu den entsprechenden Menüs aus der Menüzeile aufgebaut, so daß Sie benötigten Funktionen auch dort finden, wo sich diese im Pulldown-Menü befinden.


Objekte auswählen / markieren

Die weitaus meisten LayerManager-Funktionen beziehen sich auf die gewählten Objekte (auch als Auswahl bezeichnet). In diesem Kapitel werden Details zu verschiedenen Methoden der Objektwahl erläutert. Kompatibel zum Windows-Explorer, können Sie übliche Tasten- und Maustasten-Kombinationen verwenden. Der LayerManager bietet zusätzliche Methoden zur Objektwahl, die höheren Bedienkomfort erlauben.

Tasten-Kombinationen zur Objektwahl:

· CTRL/STRG-A: Alles auswählen (All)

· CTRL/STRG-R: Auswählen umkehren (Reverse)

· CTRL/STRG-N: Nichts auswählen (None)

· CTRL/STRG-F: Auswahl mit Filter (Filter)

Maustasten-Kombinationen zur Objektwahl:

· Linke Maustaste ohne CTRL/SHIT-Taste: normale Auswahl eines Objektes (Einzel-Auswahl)

· Linke Maustaste und CTRL-Taste: zusätzliche Anwahl oder Abwahl eines Objektes

· Linke Maustaste und SHIFT-Taste: Bereichsauswahl, alle Objekte ab dem zuletzt Gewählten

Hinweis: Eine Erweiterung der Explorer-Bedienung ist die Möglichkeit, mehrere Bereiche zu wählen – nach Wahl eines Bereiches (z.B. mit SHIFT) kann der Anfang eines weiteren Bereiches mit CTRL-Mausklick, das Ende des Bereiches mit SHIFT-Mausklick gewählt werden. Anders ausgedrückt: SHIFT wählt generell das Ende eines Bereiches, welches sich auf den letzten Bereichsanfang bezieht – wurde dieser mit CTRL gewählt, so ist es ein additiver, sonst ein normaler Bereich.

Hinweis: Ebenfalls als Erweiterung zum Explorer-Konzept, besteht auch im linken Anzeige-Fenster die Möglichkeit, mehrere Objekte zu wählen !

Auswahl/Markieren von Objekten im Bereich der Eigenschaften-Spalten (nur rechtes Fenster): Sehr nützlich ist auch die Methode, im rechten Anzeige-Fenster (Layer- und Gruppen-)Objekte im Bereich der Eigenschafts-Spalten wählen zu können. Mit einem normalen Mausklick im Bereich der Eigenschafts-Spalten wird bekanntlich die entsprechende Bearbeitungsfunktion für das/die gewählte(n) Objekt(e) ausgeführt. Um ein Objekt an- bzw. abzuwählen, muss zusätzlich die CTRL/STRG-Taste zusätzlich gedrückt werden, analog zum Hinzuwählen. Ebenso besteht auch die Möglichkeit, mit der SHIFT-Taste Bereiche zu markieren. Prinzipiell erfolgt das Wählen von Objekten im Bereich der Eigenschafts-Spalten genauso wie im Bereich der Namens-Spalte – nur, daß hier die CTRL/STRG-Taste bzw. SHIFT-Taste immer notwendig ist. Der LayerManager erkennt so, daß Sie Objekte an/abwählen wollen, statt die Spalten-Eigenschaft zu ändern.

Objektwahl mit Suchfilter: Auch der Suchfilter kann zur Objektwahl verwendet werden, sofern Sie Objekte mit bestimmten Namen oder Beschreibungstexten auswählen wollen. Details zur Anwendung finden Sie im Kapitel zum Suchfilter.

Objektwahl mit Objektfilter: Möchten Sie Objekte nach komplexeren Kriterien auswählen, steht Ihnen dafür der leistungsfähige Objektfilter bereit. Eine ausführliche Beschreibung finden Sie im Kapitel zum Objektfilter.


Objekte mit Objektfilter wählen

Mit dem Objektfilter steht eine sehr leistungsfähige Funktion bereit, welche Sie bei der Auswahl von Objekten nach bestimmten Kriterien unterstützt. Sie starten den Filterdialog über Menü/Auswahl/Auswahlfilter oder über die Tasten-Kombination CTRL-F.

Nach dem Öffnen bleibt der Auswahlfilter (ebenso wie der LayerManager) permanent im Vordergrund und reagiert auf das jeweilige aktive Anzeige-Fenster im LayerManager – wechseln Sie dieses, so wechselt auch die Anzeige im Auswahlfilter. Die im Auswahlfilter festgelegte Auswahl wird mit dem Button "Anwenden" dann in eben jenes aktive Anzeige-Fenster übertragen, Sind mehrere LayerManager-Fenster geöffnet, so besitzt jedes der Programm-Fenster einen eigenen Objektwahl-Filter.

Button "Anwenden":

Die im Auswahlfilter markierten Objekte werden als Auswahl in das aktive Anzeige-Fenster übertragen. Der Auwahlfilter wird dadurch nicht geschlossen.

Buttons "Alle", "Umkehren", "Keine":

Es werden entweder alle angezeigten Objekte ("Alle") gewählt, oder die aktuelle Auswahl umgekehrt ("Umkehren") oder die Auswahl aufgehoben ("Keine").

Kontrollkästchen "Nur Auswahl":

Wenn bereits eine Auswahl (also Objekte bereits markiert sind), so wird dieses Kontrollkästchen aktiviert – wird diese Option dann eingeschaltet, so werden nur noch diese gewählten Objekte angezeigt, also die Anzeige reduziert, und die Markierung aufgehoben. Jetzt können erneut Auswahlbedingungen gewählt werden, welche sich nur auf die angezeigten Objekte beziehen. So können schrittweise Anzeige und Auswahl verfeinert werden, insbesondere, wenn sehr viele Objekte vorhanden sind.

Auswahlfunktionen (Klappliste):

Je nach Modus im aktiven Anzeige-Fenster (Layer, Gruppen oder Hierarchien), welcher ja auch den Modus des Objektfilters bestimmt, finden Sie in der Klappliste eine ganze Reihe von Auswahlkriterien zu den angezeigten Objekten. So können Objekte mit bestimmten Farben, Linientypen, Sichtbarkeit, XRef-Abhängigkeiten etc. oder auch Objekte aus anderen Gruppen/Hierarchien gewählt werden. Je nach Auswahlfunktion erscheint nachfolgend ein Prameter-Dialog zu Festlegung/Auswahl des Auswahl-Parameters. Die dem Kriterium entsprechenden Objekte werden dann markiert. Natürlich kann diese Auswahl noch manuell und/oder in Kombination mit dem Schalter "Nur Auswahl" verfeinert werden.

Button "Alles":

Wurde die Anzeige mit einer der Auswahlfunktionen (aus der Klappliste) oder mittels Kontrollkästchen "Nur Auswahl" reduziert, so wird mit dem Button "Alles" wieder die gesamte Objektliste angezeigt (also alle Layer, alle Gruppen oder alle Hierarchien) – dabei wird auch eine bestehende Auswahl aufgehoben.

Button "Suchen":

Die angezeigten Objekte werden nach dem nebenstehenden Textmuster (auch mit Wildcards) in Objektnamen und –Beschreibung durchsucht und die entsprechend passenden Objekte markiert.


Doppelklicks

Die Nutzung von Doppelklicks ist im LayerManager frei konfigurierbar. Einstellbar (unter "Menü/Konfiguration/Erweitert") sind die Funktionen, welche bei Doppelklick mit der linken Maustaste auf Layer bzw. Gruppen/Hierarchie-Objekte (auch in Kombination mit CTRL/STRG und SHIFT-Taste) ausgeführt werden. Voreingestellt sind bereits sinnvolle Funktionen (z.B. Öffnen/Schliessen von Gruppen/Hierarchien bzw. das Setzen eines Layers als aktuellen Layers).

Hinweis: Windowsgemäß wird ein Doppelklick nur dann beachtet, wenn er auf den Objektnamen erfolgt; in den Eigenschaftsspalten im rechten Anzeige-Fenster ist ein Doppelklick ohne Wirkung. Der Doppelklick hat auch dann keine Wirkung, wenn mehr als 1 Objekt ausgewählt, d.h. markiert ist.


Zweifaches Anklicken

Unter "zweifachem Anklicken" versteht man das wiederholte Anklicken eines bereits markierten Objektes mit der linken Maustaste – dies ist nicht zu verwechseln mit einem Doppelklick. Windowsgemäß wird damit die Editierung des markierten Objektes begonnen – der LayerManager unterstützt dieses Editieren für alle angezeigen Objekte. Zusätzlich besteht diese Möglichkeit zur Editierung auch für die Beschreibungstexte von Layern und Gruppen, sofern diese im rechten Anzeige-Fenster dargestellt sind.

Hinweis: die Editierung wird nicht aktiviert, wenn bereits mehrere Objekte markiert sind !

Ist der Editiermodus aktiv, so erscheint ein kleines gelbes Editierfenster direkt auf dem Objekt, und dessen Objektname kann nun bearbeitet werden (inkl. Kopieren / Einfügen mit Kontextmenü). Der Editiermodus kann durch die "Return/Enter"-Taste oder einen Mausklick außerhalb des Editierfensters beendet werden – mit der "Escape"-Taste wird die Bearbeitung abgebrochen.

Nutzen Sie diese Methode zum Editieren der Objektnamen bzw. der Objekt-Beschreibungstexte.


Drag-&-Drop

Für viele Bearbeitungsvorgänge ist die "Drag-&-Drop"-Technik (dt. "Ziehen und Loslassen") eine äußerst effektive Methode – werden doch sowohl Ausgangsobjekt(e) als auch Zielobjekt(e) bereits im Vornherein bestimmt. So werden insbesondere Funktionen zur Zeichnungs-Strukturierung (wie Neuerstellen, Einfügen, Verschieben etc.), aber auch Funktionen bzgl. der Zeichnungselemente (Elemente von Layern, Gruppen, Hierarchien auf Ziellayer kopieren/verschieben etc.) angeboten.

Der LayerManager unterstützt Drag-&-Drop in folgenden Varianten:

· innerhalb des gleichen Anzeige-Fensters

· zwischen den Anzeige-Fenstern eines LayerManager-Fensters

· zwischen 2 LayerManager-Fenstern

Hinweis: unter AutoCAD 2000(i) kann Drag-&-Drop auch zwischen verschiedenen Zeichnungen erfolgen, welche dem jeweiligen LayerManager-Fenster zugeordnet sind – die schnellste und eleganteste Möglichkeit, LayerManager-Daten zu übertragen !

Den Drag-&-Drop-Vorgang können Sie sowohl mit der rechten als auch mit der linken Maustaste ausführen – im Gegensatz zum Windows-Explorer erscheint beim Loslassen der Maustaste generell ein Drag-&-Drop-Menü mit den möglichen Funktionen.

Entscheidend für den Drag-&-Drop-Vorgang und die im Kontextmenü angezeigten Funktionen sind weniger die Ausgangs- und Zielfenster, als vielmehr Art und Anzahl der Ausgangsobjekte und Zielobjekte. Der Anzeige-Modus der jeweiligen Fensterhälfte ist nur von indirekter Bedeutung. Während des Ziehens mit der Maus erscheint am Cursor ein kleines ToolTip-Fähnchen mit Hinweisen zu möglichen Zielobjekten; geeignete Zielobjekte werden hierbei mit der üblichen (meist blauen) Auswahl-Markierung hinterlegt. Während des Drag-&-Drop variiert der Mauszeiger in Abhängigkeit von Ausgangs- und Zielobjekt(en) seine Form.

Die gesamte Darstellung aller Drag-&-Drop-Operationen finden in Kapitel " Drag-&-Drop-Operationen "


Konfigurations-Dialog

Der LayerManager besitzt eine Viehlzahl von Optionen, mit denen der Anwender sowohl Arbeitsweise als auch das Erscheinungsbild des Programmes nach persönlichen Vorlieben in grossem Umfang beeinflussen kann. Alle Einstellungen werden zentral in einem übersichtlichen Dialog vorgenommen. Der Dialog verwendet Registerkarten, um die verschiedenen Programmparameter je nach Geltungsbereich zusammen zufassen.

Den Konfigurations-Dialog erreichen Sie über "Menü/Datei/Konfiguration" und "Kontextmenü/Konfiguration" (rechte Maustaste).

Alle Einstellungen werden in der Datei "Layman.ini" im Unter-Verzeichnis "…\Ini\<UserName>" benutzerabhängig gespeichert.

Hinweis: die Konfigurations-Datei kann (v.a. im Netzwerk) problemlos schreibgeschützt werden !


LaymanPro-Optionen

Auf dieser Registerkarte können Sie all jene Optionen einstellen, welche die Arbeitsweise des LayerManagers bezüglich der Zeichnung selbst betreffen.

Details

siehe auch :

LAYMAN automatisch laden und starten

Frieren-Tauen verwenden (sonst Ein-Aus)

Sortierte Darstellung der Anzeige-Listen

Konsistenz-Prüfung nur bei Re-Initialisierung

M-P-Bereich automatisch restaurieren

Neue Blöcke und XRefs automatisch durchsuchen


LAYMAN automatisch laden und starten

Unmittelbar nach der Installation muss der LayerManager zunächst einmal manuell geladen (AutoCAD-Menü Werkzeuge/Anwendungen...) und mit dem Befehl "LaymanPro" oder LmPro" gestartet werden. Wenn gewünscht, kann diese Option verwendet werden, um den LayerManager permanent in AutoCAD einzubinden. Dies bedeutet, daß der LayerManager zusammen mit AutoCAD geladen und gestartet wird..

Empfehlung: Eingeschaltet (LaymanPro startet automatisch mit AutoCAD)


Frieren-Tauen verwenden (sonst Ein-Aus)

Sie können wählen, ob LaymanPro die "Ein/Aus"-Technik oder die "Frieren/Tauen"-Technik nutzen soll, um die Zeichnungslayer zu steuern. Jede der beiden Methoden hat Vor- und Nachteile, diese sind im Wesentlichen von der Zeichnungsgröße abhängig. Mit "Ein/Aus" kann LaymanPro die Aktivierungs- und Display-Funktionen schneller ausführen, mit "Frieren/Tauen" ist der Bildaufbau großer Zeichnungen schneller; testen Sie bitte, was für Ihre Zeichnungen besser geeignet ist. Wegen der Performance von AutoCAD R14/R2000(i) und aktueller PC's ist es aber kein Problem mehr, generell nur mit "Ein/Aus" zu arbeiten.

Empfehlung: Ausgeschaltet (d.h. Layer werden mit Ein/Aus gesteuert)

Hinweis: Wenn Sie diese Option ändern, werden alle Zeichnungslayer nach Beenden des Options-Dialoges entsprechend Ihrer Auswahl "reorganisiert" – d.h. alle Layer behalten ihren aktuellen Sichtbarkeits-Status bei, werden ggf. aber von "Gefroren" auf "Aus" und umgekehrt eingestellt.

Hinweis: Wenn Sie in der AutoCAD-Layersteuerung mit "Frieren/Tauen" arbeiten, im LayerManager jedoch "Ein/Aus" verwenden, so wird empfohlen, gelegentlich die Funktion "Layer Reorganisieren" auszuführen (Menü/Bearbeiten/Layer/Reorgansieren), wodurch alle Zeichnungslayer wieder einheitlich auf die im LayerManager gewählte Methode eingestellt werden.


Sortierte Darstellung der Anzeige-Listen

Sie können die Sortierung der Anzeige-Listen (Layer, Gruppen und Hierarchien) bei Bedarf deaktivieren. Das kann sinnvoll sein, wenn Sie viele Layer (> 500) in Ihrer Zeichnung nutzen, und Ihnen daher der Aufbau der LayerManager-Anzeigelisten wegen der Sortierung zu lange dauert.

Empfehlung: Eingeschaltet

Hinweis: Auch bei eingeschalteter Sortierung kann es vorkommen, daß die Anzeige-Liste des rechten Fensters nicht mehr sortiert wird – Ursache hierfür sind technischen Eigenheiten der Icon/Spalten-Listen. In diesem Fall erzwingen Sie den sortierten Neu-Aufbau der Anzeige-Listen mit "Aktualisieren" aus dem Pulldown-Menü oder dem Kontextmenü der rechten Maustaste (Menu/Ansicht/Aktualisieren).


Konsistenz-Prüfung nur bei Re-Initialisierung

Unter (seltenen) Umständen und wenn die "Rx-Automation" deaktiviert ist, kann nach verschiedenen Arbeiten (z.B. "INSERT", "DXFIN") ein unsauberer Zustand bzgl. der LayerManager-Daten entstehen. Dieser wird mit der Konsistenzprüfung aufgedeckt und mit Unterstützung des Anwenders behoben. Ist diese Programm-Option nicht eingeschaltet, so führt LaymanPro diese Prüfung mit jedem Programmstart und nach bestimmten Operationen durch. Das kann bei sehr vielen Layergruppen in großen Zeichnungen eine spürbare Zeitdauer kosten. Diese Verhalten ist abschaltbar – die Konsistenzprüfung erfolgt dann nur beim Laden und Speichern der Zeichnung sowie bei manuell ausgeführter Re-Initialisierung (Menü/Datei/Re-Initialisierung).

Empfehlung: Eingeschaltet (Konsistenzprüfung nur bei Laden/Speichern sowie Re-Initialisierung)


M-P-Bereich automatisch restaurieren

Wenn Sie mit oft zwischen Modellbereich und Papierbereich ("Tilemode=1/0") bzw. auch zwischen den Papierbereichs-Layouts wechseln, so kann LaymanPro nach einem Wechsel den jeweils letzten Zustand der Layer inklusive aller oder wählbarer Layer-Eigenschaften restaurieren. Wenn Sie den Schalter aktivieren, so führt LaymanPro die Restaurierung automatisch aus. Unter "Details" können Sie einstellen, welche Layer-Eigenschaften restauriert werden sollen; gespeichert werden jedoch stets alle Layer-Eigenschaften, wenn der aktuelle Bereich verlassen wird.

Hinweis: Sie finden diese Option sowie die Einstellung der zu restaurierenden Layer-Eigenschaften auch in der Toolbar "Layout-abhängige Layer", um die Layer-Restaurierung direkt und schnell einzustellen.

Grundlage für diese Option ist die Tatsache, daß im Papierbereich nur jene Layer sinnvoll verwendet werden können, welche im Modellbereich nicht gefroren sind. Damit wird jedoch Ihre Layer-Konfiguration im Modellbereich aufgehoben. Müssen Sie nun öfters zwischen Modell-/Papierbereich wechseln, so müssen Sie in jeden Bereich die Layer neu einstellen. Genau diesen Konflikt löst der LayerManager, indem bei einem Bereichswechsel die Layer-Eigenschaften des jeweils verlassenen Bereiches gesichert und die Layer-Eigenschaften des aktuellen Bereiches restauriert werden. Durch dieses einmalige Leistungsmerkmal sind Modell- und Papierbereich vollständig entkoppelt und der Anwenders kann, erstmals in AutoCAD überhaupt, Layern unabhägig in beiden Bereichen bearbeiten.

Empfehlung: Eingeschaltet (automatische Restaurierung des aktuellen Bereiches)


Neue Blöcke und XRefs automatisch durchsuchen

LaymanPro kann NEU in die Zeichnung geladene Blöcke und XRefs automatisch nach den darin ggf. enthaltenen LayerManager-Daten durchsuchen. Sie können festlegen, ob das Durchsuchen neuer Blöcke und XRefs bereits direkt beim ERSTEN Einfügen (weitere Einfügungen sind nur Referenzen) eines Blockes/XRefs in eine Zeichnung automatisch erfolgen soll. Anderenfalls erscheint eine Anfrage zum optionalen Durchsuchen dieser Objekte.

Empfehlung: Ausgeschaltet (es erfolgt eine Anfrage zum Durchsuchen)

Hinweis: Ist diese Option ausgeschaltet und Sie haben die Anfrage zum Durchsuchen eines Blockes/XRefs verneinend beantwortet, so stehen die im Block/XRef enthaltenen LayerManager-Daten NICHT zur Verfügung. Mit der Funktion "Re-Initialisierung" können Sie die Zeichnung später komplett neu nach LayerManager-Daten scannen lassen, wobei dann optional auch diese Blöcke und XRefs durchsucht werden und deren LayerManager-Daten dann wieder zur Verfügung stehen.


Windows-Optionen

Hier finden Sie einige Einstellungen, welche das Verhalten des LayerManagers als Windows-Programm betreffen und welche dadurch auch großen Einfluss auf Komfort und Effektivität im Zusammenspiel von AutoCAD und LaymanPro haben.

Empfehlung: einfach alle Einstellungen, auch in Kombination, ausprobieren – die verschiedenen optischen Effekte erleben Sie so unmittelbar ...

siehe auch :

Fenster permanent im Vordergrund halten

Fenster automatisch auf Titelzeile minimieren

Aktives Fenster folgt der Maus aktivieren

Drag & Drop öffnet/schließt Objekte (mit Strg/Shift)

ToolTips in Pulldown-/Kontext-Menüs anzeigen

"Flaches Design" verwenden (Cool Controls)


Fenster permanent im Vordergrund halten

Ist diese Option aktiv, bleibt das LayerManager-Programm-Fenster stets im Vordergrund – jedoch immer nur vor dem AutoCAD-Fenster; weitere sich öffnende Programme werden nicht verdeckt. Wenn Sie den Minimieren-Button anwenden, so legt sich der LayerManager nicht in die Taskleiste, sondern bleibt als Icon auf dem Desktop im Vordergrund – dieses Icon kann beliebig plaziert werden und speichert seine Position !

Ist diese Option dagegen nicht aktiv, so verhält sich LaymanPro wie jedes andere "normale" Windows-Programm, welches sich beim Minimieren als Button in die Taskleiste legt, und von dort aus Auch wieder aktiviert werden kann. Jedoch sei angemerkt, daß diese Einstellung spätestens bei 3...4 offenen LayerManager-Fenstern keine optimale Bedienung mehr zuläßt, da der Platz der Taskleiste bekanntlich beschränkt ist, und ja oft auch noch genügend andere Programme aktiv sind.

Empfehlung: Eingeschaltet (immer im Vordergrund)


Fenster automatisch auf Titelzeile minimieren

Eine der interessantesten (und effektivsten) Möglichkeiten, den LayerManager permanent offen und im Vordergrund zu halten, ergibt sich in Kombination mit dieser Option zur automatischen Minimierung des Programm-Fensters. Ausgangspunkt für diese Option ist die Tatsache, daß in modernen Programm-Designs immer mehr Fenster permanent offen und parallel zu AutoCAD aktiv sind (z.B. diverse Projektfenster in AutoCAD MAP, den verschiedenen AutoCAD Desktops, oder auch der Eigenschaften-Manager in AutoCAD 2000(i) usw. usf.). So effektiv ein derartiges Programm-Design bzgl. der schnellen Erreichbarkeit und des effizienten Datenzugriffs auch sein mag – so soll ein schwerwiegender Nachteil nicht unerwähnt bleiben :

Es wird Sie sicherlich keine Mühe kosten, 2,3 oder auch mehr derartige Fenster zu öffnen und ggf. anzudocken – und dann dürfen Sie sich an Ihrem schönen, neuen, teuren 21-Zoll-Monitor über eine effektive Zeichenfläche von vielleicht 17-Zoll erfreuen ... AutoCAD 2000(i) macht es Ihnen da besonders leicht, die Zeichenfläche auf das Niveau von 1990 zu reduzieren ....

LaymanPro bietet mit dieser Option deutlich mehr Intelligenz : Sobald Sie mit der Maus wieder in der AutoCAD-Zeichenfläche sind, "rollt" sich der LayerManager bis auf die Titelzeile zusammen. Klicken Sie dann wieder mit der Maus auf diese Titelzeile, so klappt das Programm-Fenster wieder auf. Außerdem kann die (eingerollte) Titelzeile beliebig plaziert werden, z.B. in den Bereich der AutoCAD-Titelzeile oder der Statuszeile. Daduch ist der Verlust an Arbeitsfläche praktisch gleich Null. Die Position der (eingerollten) Titelzeile wird übrigens ebenfalls gespeichert, so daß das eingerollte wie auch das aufgeklappte Programm-Fenster an ganz verschiedenen Positionen erscheinen können.

Empfehlung: Eingeschaltet (automatisches Minimieren)

Beispiel für das normal geöffnete Programm-Fenster:

Beispiel für das eingerollte Programm-Fenster:


Aktives Fenster folgt der Maus aktivieren

Normalerweise benötigen Sie stets einen Mausklick, um zwischen verschiedenen Fenstern zu wechseln – z.B. zwischen AutoCAD und dem LayerManager. Mit dieser Option kann dieses (je nach persönlichem Geschmack) durchaus auch lästige Klicken vermieden werden. Ist diese Option aktiv, so überwacht LaymanPro die Mausbewegungen und aktiviert das/die LayerManager-Fenster bzw. das AutoCAD-Fenster je nach Mausposition.

Empfehlung: bitte testen Sie, und aktivieren oder deaktivieren diese Option je nach Geschmack


Drag & Drop öffnet/schließt Objekte (mit Strg/Shift)

Ist diese Option aktiv, so kann während des Drag-&-Drop-Vorganges das "angepeilte" Zielobjekt geöffnet (d.h. aufgeklappt) werden, indem zusätzlich die STRG-Taste gedrückt wird, wenn der Mauszeiger sich auf dem Zielobjekt bewegt. Umgekehrt werden "angepeilte" Zielobjekte geschlossen, wenn stattdessen die SHIFT-Taste gedrückt wird. Mit dieser Möglichkeit soll der Drag-&-Drop-Vorgang vereinfacht werden, da ein vorheriges separates Aufklappen möglicher Zielobjekte nicht notwendig ist.

Ist diese Option nicht aktiv, werden Ziel-Objekte generell nicht geöffnet.

Empfehlung: Eingeschaltet


ToolTips in Pulldown-/Kontext-Menüs anzeigen

Mit dieser Option werden ToolTips nicht nur in Dialogen, sondern auch für alle Menü-Einträge angezeigt – insbesondere beim anfänglichen Kennenlernen des LayerManagers sicherlich eine hilfreiche Unterstützung.

Empfehlung: Eingeschaltet


"Flaches Design" verwenden (Cool Controls)

Mit dieser Option erhält der LayerManager insgesamt ein moderneres Outfit, indem alle Dialog-Elemente flacher als gewöhnlich erscheinen, und sich diese Dialog-Elemente etwas anheben, sobald der Mauszeiger darüber positioniert ist – die Handhabung der Maus wird dadurch etwas "fühlbarer". Ist diese Option nicht aktiv, so erscheint der LayerManager im Standard-Outfit eines Windows-Programmes.

Empfehlung: Ganz nach persönlichem Geschmack


Erweiterte Optionen

Hier finden Sie weitergehende, spezielle Einstellungen für den LayerManager.

siehe auch :

Rx-Automation aktivieren

Für neu erstellte Objekte das Auswahl-Fenster öffnen

Gruppen und Hierarchien in fetter Schrift anzeigen

Eigene Farbe für Gruppen und Hierarchien

Farbe für Nicht-AutoStruktur-Objekte

Maustasten-Funktionen

Funktionstasten-Belegung

Sprache der Benutzer-Oberfläche


Rx-Automation aktivieren

Ist diese Option aktiviert, so kann LaymanPro alle Ereignisse und Vorgänge bzgl. der Zeichnungslayer (und der Zeichnungs-Datenbank insgesamt) beobachten und die Anzeige-Listen im Programm stets aktuell halten sowie auf bestimmte Vorgänge selbstständig reagieren. Ist diese Option nicht aktiv, so müssen Sie öfters manuell die Anzeige-Listen aktualisieren (Menü/Ansicht/Aktualisieren), damit im LayerManager die Zeichnungslayer mit korrekten Parametern angezeigt werden.

Beispiel: Sie speichern die Zeichnung – ohne Rx-Automation müßten Sie zuvor auch im LayerManager speichern, damit Ihre Layerstrukturen nicht verloren gehen !

Empfehlung: Eingeschaltet (Rx-Automation aktiv)


Für neu erstellte Objekte das Auswahl-Fenster öffnen

Beim Erstellen neuer Layergruppen bzw. Hierarchien per Drag-&-Drop werden 3 Schritte durchlaufen:

  1. Eingabe des Namens des neuen Objektes

  2. Eingabe eines (optionalen) Beschreibungstextes für das neu erstellte Objekt

  3. Auswahl der Inhalte (Layer bzw. Layergruppen/Sub-Hierarchien) für das neu erstellte Objekt

Ist diese Option aktiv, wird der 3. Schritt (Auswahl der Inhalte) nicht verwendet – dies kann von Vorteil sein, wenn viele Layergruppen/Hierarchien nur angelegt, aber nicht gefüllt werden sollen, um Zeit zu sparen. Die Inhalte können jederzeit später ebenfalls per Drag-&-Drop mit gewünschten Inhalten versehen werden.

Empfehlung: Eingeschaltet (Auswahl-Dialog aktiv)


Gruppen und Hierarchien in fetter Schrift anzeigen

Dieser Option bewirkt, daß im linken Anzeige-Fenster die Gruppen bzw. Hierarchien (also die übergeordneten Objekte) in Fettschrift angezeigt werden; Lesbarkeit und Übersichtlichkeit können deutlich verbessert werden.

Empfehlung: Eingeschaltet


Eigene Farbe für Gruppen und Hierarchien

Ist diese Option aktiv, werden Layergruppen bzw. Hierarchien (also immer die übergeordneten Objekte) im linken Anzeige-Fenster in einer wählbaren Farbe dargestellt werden, wodurch Lesbarkeit und Übersichtlichkeit verbessert werden können. Ist diese Option nicht aktiv, ist der Farbauswahl-Knopf deaktiviert, und für die Objekte wird die normale Schriftfarbe verwendet.

Empfehlung: bitte nach persönlichem Geschmack aktivieren und Farbe wählen


Farbe für Nicht-AutoStruktur-Objekte

Mit dieser Option ist es möglich, im rechten Anzeige-Fenster all diejenigen Layer und Layergruppen, welche aktuell nicht von den Definitionen der AutoStruktur-Templates erfasst werden, in einer anderen Farbe anzu-zeigen; damit steht eine sehr effektive Methode bereit, die Wirkung und Nutzung der AutoStruktur-Templates sowie die aktuelle Zeichnungsstruktur zu überprüfen.

Empfehlung: bitte nach konkreten Erfordernissen aktivieren und Farbe wählen


Maustasten-Funktionen

LaymanPro legt sehr viel Wert auf umfangreiche Möglichkeiten, das Programm dem Arbeitstil und den Vorlieben des Anwenders anzupassen – in diesem Sinne können Sie festlegen, welche Aktionen LaymanPro bei Doppelklick mit der linken Maustaste (auch in Kombination mit der SHIFT- und STRG-Taste) auf Layer, Gruppen und Hierarchien ausführen soll.

Empfehlung: Es sind sinnvolle Funktionen voreingestellt – prüfen Sie dennoch die Einstellungen.


Funktionstasten-Belegung

Auch wenn es den Anschein hat, allmählich aus der Mode zu kommen (insbesondere AutoCAD 2000(i) ist ja der Meinung, daß die Arbeit mit der Tastatur so langsam sei ...), verzichtet LaymanPro bewußt nicht auf die Möglichkeit, Funktionstasten frei mit LayerManager-Funktionen belegen zu können.

Die Effektivität werden Sie sehr schnell kennenlernen, wenn Sie einige Layer oder Layergruppen markieren und dann die <F2>-Taste drücken ("Zeichnungselemente anzeigen") ....

Empfehlung: Es sind sinnvolle Funktionen voreingestellt – prüfen Sie dennoch die Einstellungen.


Sprache der Benutzer-Oberfläche

In der Popup-Liste kann die Sprache der Programm-Oberfläche ausgewählt werden; es werden hierbei alle installierten Programm-Sprachen angezeigt. Die ausgewählte Sprache betrifft selbstverständlich auch die Online-Hilfe. Ein Wechsel der Programm-Sprache wird erst nach AutoCAD-Neustart wirksam !

Hinweis: Abhängig von Installation und LayerManager-Version kann die Sprach-Auswahl abgeschaltet sein.


Druck- und Druck-Vorschau

Ab der Version v4.1 bietet der LayerManager auch den Druck der Inhalte beider Fenster, inklusive des Druck-Setup und der Druck-Vorschau. Sie finden die Druck-Funktionen unter "Menü/Datei/Druck-Setup", "Menü/Datei/Druck-Vorschau" und "Menü/Datei/Druck". Aktivieren Sie die Fenster-Hälfte, deren Inhalt Sie drucken möchten – nun sind die Druck-Funktionen bereit.

LaymanPro verwendet für jede Fensterseite ein separates Drucker- und Seiten-Setup : Sie können z.B. das linke Fenster im Hochformat, das rechte Fenster dagegen im Querformat, ausdrucken. Die Dialoge zur Seiten-Einrichtung sowie der Druckdialog entsprechen den üblichen Windows-Standard-Funktionen, so daß sich der Anwender schnell zurechtfindet.


Arbeits-Layer-Fenster

Unter "Menü/Ansicht/Arbeits-Layer" und im Kontext-Menü "Ansicht/Arbeits-Layer" öffnet sich ein kleines Fenster, welches permanent im Vordergrund bleibt. Sobald Sie im LayerManager ein/mehrere Objekte (Layer/Layergruppen/Hierarchien) markieren, erscheint die Gesamtheit der Layer aus diesen Objekten im Arbeits-Layer-Fenster aufgelistet, zusammen mit der Layer-Beschreibung. Das Arbeits-Layer-Fenster bleibt auch dann offen, wenn Sie den LayerManager minimieren oder zusammen-klappen – nun stehen die Layer auch für die Anwendung in AutoCAD zur Verfügung : mit einem einzigen Mausklick wird der gewählte Layer als aktueller AutoCAD-Layer gesetzt. Besonders bei Nutzung vieler Layer sparen Sie beim Wechsel des aktuellen Layers enorm Zeit und erhalten eine deutlich erhöhte Sicherheit !

Beispiel: Sie wollen Schraffuren auf diversen Layern erstellen– markieren Sie die Layer (bzw. entsprechende Layergruppen/Hierarchien) und öffnen das Arbeits-Layer-Fenster : Sie finden die Layer nun hier wieder. Für den Wechsel zu einem anderen Schraffur-Layer brauchen Sie nur den gewünschten Layer anklicken – ohne durch eine Layerliste zu scrollen und ohne den Layer suchen zu müssen (und verwechseln zu können !).

Nach dem "Einsammeln" aller Layer, mit denen Sie arbeiten möchten, wechseln Sie den aktuellen Layer mit 1 Mausklick – ohne Suchen und Scrollen! Umgekehrt wird der aktuelle AutoCAD-Layer automatisch immer auch markiert.

Das Fenster ist beliebig skalierbar und merkt sich auch die zuletzt benutzte Position.


Tip-des-Tages

Wenn gewünscht, so erscheint bei jedem ersten Programmstart des Layer-Managers ein Tages-Tip : hier werden stets die Neuerungen der aktuellen Programm-Version sowie viele Tips & Tricks zum Programm vorgestellt.

Dieses Hilfe-Fenster kann jederzeit auch aus dem Hilfe-Menü separat aufgerufen werden.

Möchten Sie den "Tip-des-Tages" beim Programmstart abschalten, so de-aktivieren Sie bitte die Option auf dem Dialog-Fenster.


Web-Support

In der Statuszeile des LayerManagers finden Sie neben den Icons zur Layer-History das Icon für den direkten Zugriff auf die LayerManager-Homepage :

http://www.LayerManager.de

Hier finden Sie stets die aktuellste Programm-Version, viele Tips & Tricks, eine ausführliche FAQ (frequently asked questions) sowie ein Anwender-Forum (Newsgroup).

Ausserdem finden Sie dort auch die gesamte Dokumentation als druckfähige PDF-Datei.

Auf der Website besteht natürlich auch die Möglichkeit, Ihre Anregungen, Hinweise sowie auch Fehlermeldungen und Bugreports zu hinterlegen – dieses Feedback ist uns stets willkommen !

Hierzu können Sie auch folgende E-Mail-Adressen verwenden:

  1. Info@LayerManager.de :für allgemeine Anfragen zum LayerManager

  2. Feedback@LayerManager.de :für alle Hinweise und Anregungen zum Programm

  3. Bugreport@LayerManager.de :für Ihre Fehlermeldungen und Bugreports


Objekte mit Beschreibungstext versehen

Der LayerManager ermöglicht es, alle Layer, Layergruppen und Hierarchien mit einem sogenannten Beschreibungstext zu versehen. Diese zusätzliche Objektinformation ist ein vom Anwender frei zu vergebender Text mit maximal 255 Zeichen Länge.

Es stehen verschiedene Methoden bereit, den Beschreibungstext zu bearbeiten.

Kontextmenü/Infotext:

Markieren Sie das betreffende Objekt, und wählen aus dem Kontextmenü (rechte Maustaste) die Funktion "Infotext". Daraufhin öffnet sich am unteren Bidschirmrand das gelb hinterlegte Editierfeld. Hier kann der Beschreibungstext bearbeitet werden. Beendet wird die Editierung durch <Return/Enter> oder durch einen Mausklick ausserhalb des Editierfeldes; mit <Escape> kann die Editierung abgebrochen werden.

Hinweis: Haben Sie mehrere Objekte markiert, so wird generell der Infotext-Dialog geöffnet.

Editierung direkt in der Spalte "Beschreibung":

Wird im rechten Anzeigefenster die Spalte "Beschreibung" angezeigt, so kann der Beschreibungstext direkt im Anzeige-Fenster editiert werden: klicken Sie mit der linken Maustaste (ohne gedrückte Ctrl/Strg/Shift-Taste) einfach in den Bereich der Spalte "Beschreibung" des betreffenden Objektes. Es öffnet sich das gelbe Editierfeld zum Bearbeiten des Beschreibungs-Textes. Beendet wird die Editierung mit <Return/Enter> oder Mausklick ausserhalb des Editierfeldes; mit <Escape> wird die Editierung abgebrochen.

Hinweis: bei Bedarf scrollen Sie bitte das Anzeige-Fenster (horizontal) soweit, daß die Spalte "Beschreibung" möglichst vollständig sichtbar ist; ggf. verbreitern Sie diese Spalte auch.

Bearbeitung der Beschreibungstexte im Infotext-Dialog:

Eine weitere Möglichkeit, die Beschreibungstexte der Layer, Layergruppen und Hierarchien sehr komfortabel und übersichtlich zu bearbeiten, besteht in der Nutzung des Infotext-Dialoges. Diese Methode bietet sich insbesondere dann an, wenn Sie Bearbeitungen in größerem Umfang vornehmen möchten. Eine umfassende Darstellung des Infotext-Dialoges finden Sie im Kapitel "Beschreibungstexte bearbeiten".


Beschreibungstexte bearbeiten

Der LayerManager ermöglicht es, alle Layer, Layergruppen und Hierarchien mit einem sogenannten Beschreibungstext zu versehen. Diese zusätzliche Objektinformation ist ein vom Anwender frei zu vergebender Text mit maximal 255 Zeichen Länge.

Im Infotext-Dialog bestehen vielfältige Möglichkeiten zur Bearbeitung von Beschreibungstexten; insbesondere zur Bearbeitung vieler Objekte in einem Durchgang oder zur Vergabe gleicher Ausgangstexte für mehrere Objekte ist diese Methode sehr vorteilhaft. Eine vorherige Markierung der zu bearbeitenden Objekte im LayerManager-Fenster ist nicht notwendig. Die Funktion für den Infotext-Dialog finden Sie unter "Menü/Bearbeiten/Infotexte". Der Infotext-Dialog verwendet zunächst den Modus (Layer, Layergruppen, Hierarchien) des jeweils aktiven Anzeige-Fensters, kann dann aber nach Wunsch umgestellt werden. Ebenso steht eine Suchfunktion (auch mit Wildcards) bereit. Mit den Schaltern "Hierarchien", "Gruppen" und "Layer" bestimmen Sie die Art der anzuzeigenden Objekte.

Wählen Sie zunächst die betreffenden Objekte aus – der Beschreibungstext des zuletzt gewählten Objektes erscheint als Vorgabe im unteren Editierfeld. Nach der Auswahl kann der Beschreibungstext dort bearbeitet werden. Mit "Ändern" wird der neue Beschreibungstext für alle markierten Objekte übernommen. Sie können im Editierfeld auch einen Suchbegriff (auch mit Wildcards) angeben – mit "Suchen" werden dann die Objektnamen und Beschreibungstexte nach passenden Einträgen durchsucht, und die Fundstellen markiert. Dann kann für die gefundenen und markierten Objekte der Beschreibungstext bearbeitet werden.

Mit dem Kontrollkästchen "Markierung" kann bei Schliessen des Dialoges die Objektauswahl auch in das aktive Anzeige-Fenster übernommen werden.


Layer neu anlegen

Die Funktion zum Anlegen eines neuen Layers finden Sie um Pulldown-Menü bzw. Kontextmenü unter "Menü/Datei/Neu/Layer".

Stellen Sie zuerst das rechte Anzeige-Fenster auf einen der Darstellungsmodi "Alle Layer", "Abhängige Layer", "Aktive Layer", oder "Nicht aktive Layer" ein. Wählen Sie dann die Funktion "Menü/Datei/Neu/Layer" aus der Menüleiste, dem Kontextmenü oder der ToolBar "Datei".

Im rechten Anzeige-Fenster wird ein neuer Eintrag mit Namen "Neuer Layer..." angelegt und es erscheint das gelbe Editierfeld - geben Sie den gewünschten Namen des Layers ein.
Nach der Eingabe des Namens erscheint am unteren Bildschirmrand das gelbe Editierfeld mit dem Beschreibungstext für den neuen Layer – geben Sie den gewünschten Beschreibungstext ein.

Allgemeiner Hinweis: Haben Sie im rechten Anzeige-Fenster den Modus "Abhängige Layer" eingestellt, so muss im linken Fenster eine (oder mehrere) Layergruppe(n) markiert sein – ein neu erstellter Layer wird dann automatisch in die gewählte(n) Layergruppe(n) eingefügt – Sie haben dadurch 2 Arbeitsschritte zusammengefasst. Im Modus "Nicht aktive Layer" ist der neue Layer zusätzlich ausgeschalten/gefroren.


Layergruppen erstellen

Einer der zentralen Aspekte bei der Strukturierung der Zeichnung ist die Erstellung von Layergruppen. Daher wird auf die verschiedenen Methoden zur Erstellung von Layergruppen sehr ausführlich eingegangen. Eine Layergruppe besteht aus dem Namen der Layergruppe (max. 255 Zeichen), einem ergänzenden Beschreibungstext (max. 255 Zeichen) und natürlich einer Anzahl von Layern, welche den Inhalt der Layergruppe bilden (kann aber auch leer sein). Die Namen der Layergruppen müssen eineindeutig sein, d.h. es können keine Gruppennamen mehrfach vergeben sein. Spätere Bezugnamen auf Layergruppen erfolgen stets als Verweise (Links). Layergruppen werden, wie alle LayerManager-Objekte, direkt in der Zeichnung gespeichert und bleiben somit Bestandteil Ihrer Zeichnung.

Es stehen verschiedene Methoden bereit, um Layergruppen zu erstellen :

über Menüfunktion "Menü/Datei/Neu/Layergruppe":

Stellen Sie zuerst das linke oder rechte Anzeige-Fenster auf den Darstellungsmodus "Layergruppen" oder "Abhängige Layergruppen" ein. Wählen Sie die Funktion "Menü/Datei/Neu/Layergruppe" aus der Menüleiste oder dem Kontextmenü. Die Erstellung der neuen Layergruppe erfolgt in 3 Schritten :

Im aktuellen Anzeige-Fenster wird ein neuer Eintrag mit Namen "Neue Layergruppe ..." angelegt und es erscheint das gelbe Editierfeld - geben Sie den gewünschten Namen der Layergruppe ein.
Nach der Eingabe des Namens erscheint am unteren Bildschirmrand das gelbe Editierfeld mit dem Beschreibungstext der neuen Layergruppe – geben Sie den gewünschten Beschreibungstext ein.
Als letztes sind die Layer zu bestimmen, welche die neue Layergruppe enthält– es öffnet sich der Objektfilter zur Layerauswahl - wählen Sie die gewünschten Layer aus und drücken "Anwenden".

Damit ist die neue Layergruppe fertiggestellt.

Hinweis: die gleiche Funktion finden Sie auch unter "ToolBar:Datei/Neuer Eintrag" und unter "Kontextmenü/Neu/Layergruppe".

ALTERNATIVE VARIANTE mit Menüfunktion "Menü/Datei/Neu/Layergruppe":

Neben der oben beschriebenen Form steht eine alternative Methode zur Erstellung von Layergruppen bereit : markieren Sie hierzu die gewünschten Layer, welche Sie in eine Gruppe zusammenfassen möchten – nutzen Sie nun die Funktion "Neu/Layergrupe" über das Menü bzw. Kontext-Menü: es öffnet sich der Erstellungs-Dialog.

Hier können Sie alle Eigenschaften der neu zu erstellenden Layer-gruppe im Dialog einstellen – auch die Liste der beinhalteten Layer kann nach Wunsch ergänzt bzw. reduziert werden.

Als weitere Besonderheit besteht hier auch die Möglichkeit, die neue Layergruppe in eine wählbare Hierarchie einzugliedern – so können Sie ggf. einen separaten, weiteren Arbeitsschritt zum Eingliedern der Layergruppe in eine Hierarchie sparen.

Wird diese Option nicht benötigt, so deaktivieren Sie "In Hierarchie einfügen" und der erweiterte Dialog-Bereich wird "eingeklappt".

über "Drag-&-Drop":

Stellen Sie zuerst ein Anzeige-Fenster (am besten das rechte) auf einen der Layer-Darstellungsmodi; das andere Anzeige-Fenster (also meist das linke) stellen Sie auf den Anzeige-Modus "Layergruppen" ein. Markieren Sie die für die Layergruppe gewünschten Layer in jenem Anzeige-Fenster, welches die Layer enthält – klicken Sie mit der linken Maustaste auf einen der gewählten Layer, halten die Maustaste gedrückt, und ziehen Sie die markierten Layer in das andere Fenster, welches die Layergruppen anzeigt.

Bewegen Sie die Maus in einen leeren Bereich im Zielfensters und lassen dann die Maustaste wieder los – es erscheint ein kleines Drag-&-Drop-Menü mit den möglichen Funktionen; wählen Sie nun aus dem Drag-&-Drop-Menü die Funktion "Neu".

Im aktuellen Anzeige-Fenster wird ein neuer Eintrag mit Namen "Neue Layergruppe ..." angelegt und es erscheint das gelbe Editierfeld - geben Sie den gewünschten Namen der Layergruppe ein. Nach der Eingabe des Namens erscheint am unteren Bildschirmrand das gelbe Editierfeld mit dem Beschreibungstext der neuen Layergruppe – geben Sie den gewünschten Beschreibungstext ein.

Hinweis zu Drag-&-Drop: Es ist letztlich ohne Bedeutung, in welchem Anzeige-Fenster Sie die Layer auswählen, oder welchen Anzeige-Modus dieses Fenster nutzt – sobald Layer angezeigt werden, können Sie diese als Ausgang für Drag-&-Drop-Prozesse nutzen: so können Sie auch die unterhalb von Layergruppen (im linken Anzeige-Fenster) angezeigten Layer auswählen. Für das Zielfenster ist nur von Bedeutung, daß es sich im Anzeige-Modus "Layergruppen" oder "Abhängige Layergruppen" befindet und daß Sie die gezogenen Layer in den leeren Bereich fallen lassen. Eine umfassende Darstellung der Drag-&-Drop-Funktionalität finden Sie im Kapitel "Drag-&-Drop-Operationen" .

Allgemeiner Hinweis: Haben Sie im rechten Anzeige-Fenster den Modus "Abhängige Layergruppen" eingestellt, so muss im linken Fenster eine (oder mehere) Hierarchien markiert sein – eine im rechten Anzeige-Fenster neu erstellte Layergruppe wird dann automatisch in die gewählte(n) Hierarchie(n) eingefügt – Sie haben dadurch also gleich 2 Arbeitsschritte zusammengefasst.


Strukturierung der Zeichnung - Layergruppen erweitern

Layergruppen erweitern

Oft wird es notwendig, bestehende Layergruppen zu überarbeiten, d.h. die in der Layergruppe enthaltenen Layer zu ändern. Neben dem Entfernen von Layern aus der Layergruppe besteht natürlich ebenso die Möglichkeit, weitere Layer in Layergruppe(n) aufzunehmen.

über Menüfunktion : "Menü/Datei/Einfügen/Layer":

Markieren Sie eine (oder auch mehrere) Layergruppe(n), welche Sie mit neuen Layern erweitern wollen; hierbei spielt es keine Rolle, ob Sie sich im rechten oder linken Anzeige-Fenster befinden, oder welchen Ansichts-Modus das aktive Anzeige-Fenster nutzt.

Wählen Sie nun die Funktion "Menü/Datei/Einfügen/Layer" aus der Menüleiste oder dem Kontextmenü. Es öffnet sich der bekannte Objektfilter zur Layerauswahl - wählen Sie die gewünschten Layer aus und drücken "Anwenden". Es ist kein Problem, auch solche Layer zu wählen, welche bereits in der/den Layergruppe(n) enthalten sind – der LayerManager ist sehr tolerant, und führt intern permanente Plausibilitätsprüfungen durch; so können Sie also alle Layer wählen, die Sie in der Layergruppe haben möchten, ohne ständig selbst Obacht geben zu müssen, ob die Layer evtl. schon Bestandteil der Layergruppe sind.

Hinweis: Haben Sie mehrere Layergruppen markiert, so werden die im Objektfilter gewählten Layer in alle markierten Layergruppen eingefügt !

Hinweis: die gleiche Funktion finden Sie auch unter "ToolBar:Datei/Einfügen" und unter "Kontextmenü/Einfügen/Layer".

über "Drag-&-Drop":

Markieren Sie die Layer, welche Sie in eine Layergruppe einfügen wollen, in einem der Anzeige-Fenster; die Seite oder der Ansichts-Modus des Fensters spielen hierbei keine Rolle. Klicken Sie dann mit der linken oder rechten Maustaste auf einen der gewählten Layer, halten die Taste gedrückt und ziehen die markierten Layer dann auf ein Anzeige-Fenster, welches die Ziel-Layergruppe enthält. Bewegen Sie die Maus nun auf die Ziel-Layergruppe – die Ziel-Layergruppe wird daraufhin mit der blauen Auswahl-Markierung hinterlegt, um anzuzeigen, daß Sie mit dem Mauszeiger auf ein gültiges Drag-&-Drop-Zielobjekt zielen. Lassen Sie nun die Maustaste los und es erscheint das Drag-&-Drop-Menü : wählen Sie die Funktion "Einfügen".

Auch hier ist es kein Problem, bereits in der Layergruppe enthaltene Layer wiederholt einzufügen.

Hinweis zu Drag-&-Drop: Möchten Sie per Drag-&-Drop die gewählten Layer gleich in mehrere Ziel-Layergruppen einfügen, so geht auch das mit einem kleinen Trick : markieren sie VOR Beginn der Drag-&-Drop-Operation im Zielfenster alle Layergrupen, welche Sie erweitern wollen. Führen Sie dann den Drag-&-Drop-Vorgang wie beschrieben aus : im Drag-&-Drop-Menü wird nun zusätzlich die Funktion "Einfügen in Alle" aktiv. Nutzen Sie "Einfügen in Alle", so wird nicht nur die "angezielte" Layergruppe erweitert, sondern alle markierten Layergruppen im Ziel-Fenster. Eine umfassende Darstellung der Drag-&-Drop-Funktionalität finden Sie im Kapitel "Drag-&-Drop-Operationen" .


Hierarchien erstellen

Eine Hierarchie besteht aus dem Namen der Hierarchie (max. 255 Zeichen), einem ergänzenden Beschreibungstext (max. 255 Zeichen) und einer Anzahl von Sub-Hierarchien und Layergruppen, welche den Inhalt der Hierarchie bilden (diese kann aber auch leer sein). Die Namen der Hierarchien müssen eineindeutig sein, d.h. es können keine Hierarchienamen mehrfach vergeben sein. Spätere Bezugnamen auf weitere Hierarchien (und Layergruppen) erfolgen stets als Verweise (Links). Hierarchien werden, wie alle LayerManager-Objekte, direkt in der Zeichnung gespeichert und bleiben Bestandteil Ihrer Zeichnung.

Jede Hierarchie kann sowohl weitere (Sub-)Hierarchien als auch Layergruppen beinhalten. Wird eine neue Hierarchie erstellt, so muss die entsprechende übergeordnete Bezugs-Hierarchie gewählt sein – oder keine, um eine neue Hierarchie auf oberster Ebene zu erstellen. Unmittelbar beim Erstellen einer Hierarchie können nur die enthaltenen Layergruppen bestimmt werden; wollen Sie auch bereits bestehende (Sub-)Hierarchien einfügen, so nutzen Sie bitte später die Funktionen zum Einfügen von Hierarchien (und Layergruppen).

über Menüfunktion : "Menü/Datei/Neu/Hierarchie":

Stellen Sie zuerst das linkeLinkesAnzeige.Fenster>Main Anzeige-Fenster auf den Darstellungsmodus "Hierarchie" ein. Markieren Sie dann diejenige Hierarchie, unterhalb derer Sie eine neue (Sub-)Hierarchie erstellen möchten; oder markieren Sie nichts, um die neue Hierarchie auf der obersten Ebene zu erstellen. Wählen Sie die Funktion "Menü/Datei/Neu/Hierarchie" aus der Menüleiste oder dem Kontextmenü.

Die Erstellung der neuen (Sub-)Hierarchie erfolgt in 3 Schritten :

Im linken Anzeige-Fenster wird ein neuer Eintrag mit Namen "Neue Hierarchie ..." angelegt und es erscheint das gelbe Editierfeld - geben Sie den gewünschten Namen der Hierarchie ein.
Nach der Eingabe des Namens erscheint am unteren Bildschirmrand das gelbe Editierfeld mit dem Beschreibungstext der neuen Hierarchie – geben Sie den gewünschten Beschreibungstext ein.
Als letztes sind die Layergruppen zu bestimmen, welche die neue Hierarchie bilden – es öffnet sich der Objektfilter zur Layergruppenauswahl - wählen Sie die gewünschten Layergruppen aus und drücken "Anwenden".

Hinweis: die gleiche Funktion finden Sie auch unter "ToolBar:Datei/Neuer Eintrag" und "Kontextmenü/Neu/Hierarchie".

ALTERNATIVE VARIANTE mit Menüfunktion : "Menü/Datei/Neu/Hierarchie":

Neben der oben beschriebenen Form steht eine alternative Methode zur Erstellung von Hierarchien bereit : markieren Sie hierzu die gewünschten Layergruppen, welche Sie in eine Hierarchie zusammenfassen möchten – nutzen Sie nun die Funktion "Neu/Hierarchie" über das Menü bzw. Kontext-Menü: es öffnet sich der Erstellungs-Dialog.

Hier können Sie alle Eigenschaften der neu zu erstellenden Hierarchie im Dialog einstellen – auch die Liste der beinhalteten Layergruppen kann nach Wunsch ergänzt bzw. reduziert werden.

Als weitere Besonderheit besteht hier auch die Möglichkeit, die neue Hierarchie in eine andere, wählbare Hierarchie (als Sub-Hierarchie) einzugliedern – so können Sie ggf. einen separaten, weiteren Arbeitsschritt zum Eingliedern der Hierarchie in eine andere Hierarchie sparen.

Wird diese Option nicht benötigt, so deaktivieren Sie "Als Sub-Hierarchie" und der erweiterte Dialog-Bereich wird "eingeklappt".

über "Drag-&-Drop":

Stellen Sie zuerst das linke Anzeige-Fenster auf den Ansichtsmodus "Hierarchien" ein; das rechte Anzeige-Fenster ist auf einen der Layergruppen-Ansichtsmodi eingestellt. Markieren Sie im rechten Anzeige-Fenster die für die neue Hierarchie gewünschten Layergruppen – klicken Sie mit der linken Maustaste auf eine der gewählten Layergruppen, halten die Maustaste gedrückt, und ziehen Sie die markierten Layergruppen in das linke Fenster, welches die Hierarchien anzeigt.

Bewegen Sie die Maus in den leeren Bereich im Zielfensters, um die neue Hierarchie auf oberster Ebene zu erstellen, oder zielen Sie mit dem Mauszeiger auf eine Ziel-Hierarchie, wenn Sie eine neue Sub-Hierarchie als Inhalt der Ziel-Hierarchie erstellen wollen; lassen dann die Maustaste wieder los – es erscheint ein kleines Drag-&-Drop-Menü mit den möglichen Funktionen: wählen Sie nun die Funktion "Neu".

Im linken Anzeige-Fenster wird ein neuer Eintrag mit Namen "Neue Hierarchie ..." angelegt und es erscheint das gelbe Editierfeld - geben Sie den gewünschten Namen der neuen Hierarchie ein. Nach der Eingabe des Namens erscheint am unteren Bildschirmrand das gelbe Editierfeld mit dem Beschreibungstext der neuen Hierarchie – geben Sie den gewünschten Beschreibungstext ein.

Hinweis zu Drag-&-Drop: Es ist letztlich ohne Bedeutung, in welchem Anzeige-Fenster Sie die Layer-gruppen auswählen, oder welchen Anzeige-Modus das Fenster nutzt – sobald Layergruppen angezeigt werden, können Sie diese als Ausgang für Drag-&-Drop-Prozesse nutzen: so können Sie auch die unterhalb von Hierarchien (im linken Fenster) angezeigten Layergruppen wählen. Für das Zielfenster ist nur von Bedeutung, daß es den Anzeige-Modus "Hierarchien" nutzt und daß Sie die gezogenen Layergruppen entweder in den leeren Bereich oder auf einer Ziel-Hierarchie fallen lassen.

Eine umfassende Darstellung der Drag-&-Drop-Funktionalität finden Sie in "Drag-&-Drop-Operationen".


Strukturierung der Zeichnung - Hierarchien erweitern

Hierarchien erweitern

Bestehende Hierarchien können erweitert werden, indem einerseits neue/bestehende Sub-Hierarchien oder auch neue/bestehende Layergruppen in eine oder mehere gewählte Hierarchie(n) eingefügt werden. Es stehen verschiedene Methoden bereit, Hierarchien zu erweitern :

über Menüfunktion : "Menü/Datei/Einfügen/Hierarchie":

Mit dieser Funktion können Sie eine oder mehrere bestehende Hierarchien als Sub-Hierarchien unterhalb von gewählten Ziel-Hierarchien einfügen – so, als würden Sie in einem Datei-Verzeichnis ein neues Unter-Verzeichnis erstellen. Markieren Sie eine (oder auch mehrere) Hierarchie(n), in welche Sie bestehende Hierarchien einfügen wollen. Wählen Sie nun die Funktion "Menü/Datei/Einfügen/Hierarchie" aus der Menüleiste oder dem Kontextmenü. Es öffnet sich der bekannte Objektfilter zur Auswahl von Hierarchien - wählen Sie die gewünschte(n) Hierarchie(n) aus und drücken "Anwenden".

Es ist kein Problem, auch solche Hierarchien zu wählen, welche bereits in der/den markierten Ziel-Hierarchie(n) enthalten sind – LaymanPro ist sehr tolerant, und führt permanent Plausibilitäts-prüfungen durch; so können Sie alle Sub-Hierarchien wählen, die Sie in der/den Ziel-Hierarchie(n) haben möchten, ohne ständig Obacht geben zu müssen, ob die neuen Hierarchie(n) schon Bestandteil der Ziel-Hierarchie(n) sind.

Hinweis: Haben Sie mehrere Ziel-Hierarchien markiert, so werden die im Objektfilter gewählten Hierarchie(n) in alle markierten Ziel-Hierarchien eingefügt !
Hinweis: die gleiche Funktion finden Sie auch unter "ToolBar:Datei/Einfügen" und unter "Kontextmenü/Einfügen/Hierarchie".

über Menüfunktion : "Menü/Datei/Einfügen/Layergruppe":

Mit dieser Funktion können Sie eine oder mehrere bestehende Layergruppe als Bestandteil unterhalb von gewählten Ziel-Hierarchien einfügen. Markieren Sie eine (oder auch mehrere) Hierarchie(n), in welche Sie bestehende Hierarchien einfügen wollen. Wählen Sie nun die Funktion "Menü/Datei/Einfügen/Layergruppe" aus der Menüleiste oder dem Kontextmenü. Es öffnet sich der bekannte Objektfilter zur Auswahl von Layergruppen - wählen Sie die gewünschte(n) Layergruppe(n) aus und drücken "Anwenden".

Es ist kein Problem, auch Layergruppen zu wählen, welche bereits in der/den markierten Ziel-Hierarchie(n) enthalten sind – der LayerManager ist sehr tolerant, und führt intern permanent Plausibilitätsprüfungen durch; so können Sie alle Layergruppen wählen, die Sie in der/den Ziel-Hierarchie(n) haben möchten, ohne ständig Obacht geben zu müssen, ob diese Layergruppe(n) schon Bestandteil der Ziel-Hierarchie(n) sind.

Hinweis: Haben Sie mehrere Ziel-Hierarchien markiert, so werden die im Objektfilter gewählten Layergruppe(n) in alle markierten Ziel-Hierarchien eingefügt !
Hinweis: die gleiche Funktion finden Sie auch unter "ToolBar:Datei/Einfügen" und unter "Kontextmenü/Einfügen/Hierarchie".

Hierarchien einfügen über "Drag-&-Drop":

Markieren Sie diejenigen Hierarchien (im linken Anzeige-Fenster), welche Sie in eine Ziel-Hierarchie einfügen wollen. Klicken Sie dann mit der linken oder rechten Maustaste auf einen der gewählten Objekte, halten die Taste gedrückt und ziehen die markierten Objekte dann auf die Ziel-Hierarchie – die Ziel-Hierarchie wird daraufhin mit der blauen Auswahl-Markierung hinterlegt, um anzuzeigen, daß Sie mit dem Mauszeiger auf ein gültiges Drag-&-Drop-Zielobjekt zielen. Lassen Sie nun die Maustaste los und es erscheint das Drag-&-Drop-Menü : wählen Sie die Funktion "Einfügen".

Layergruppen einfügen über "Drag-&-Drop":

Markieren Sie in einem beliebigen Anzeige-Fenster diejenigen Layergruppen, welche Sie in eine Ziel-Hierarchie einfügen wollen. Klicken Sie dann mit der linken oder rechten Maustaste auf einen der gewählten Objekte, halten die Taste gedrückt und ziehen die markierten Objekte dann auf die Ziel-Hierarchie – die Ziel-Hierarchie wird daraufhin mit der blauen Auswahl-Markierung hinterlegt, um anzuzeigen, daß Sie mit dem Mauszeiger auf ein gültiges Drag-&-Drop-Zielobjekt zielen. Lassen Sie nun die Maustaste los und es erscheint das Drag-&-Drop-Menü : wählen Sie die Funktion "Einfügen".

Es ist kein Problem, bereits in der Ziel-Hierarchie enthaltene Layergruppen wiederholt einzufügen.

Allgemeiner Hinweis zu Drag-&-Drop: Möchten Sie per Drag-&-Drop die gewählten Objekte gleich in mehrere Ziel-Hierarchien einfügen, so geht auch das mit einem kleinen Trick : markieren sie VOR Beginn der Drag-&-Drop-Operation im Zielfenster alle Hierarchien, welche Sie erweitern wollen. Führen Sie dann den Drag-&-Drop-Vorgang wie beschrieben aus: im Drag-&-Drop-Menü wird nun zusätzlich die Funktion "Einfügen in Alle" aktiv. Nutzen Sie "Einfügen in Alle", so wird nicht nur die "angezielte" Hierarchie erweitert, sondern alle markierten im Ziel-Fenster. Eine umfassende Darstellung der Drag-&-Drop-Funktionalität finden Sie im Kapitel "Drag-&-Drop-Operationen" .


Objekte umbenennen

Um eines der genannten Objekte auf einen neuen Namen umzubenennen, markieren Sie dieses separat, d.h. es sollten keine weiteren Objekte im gleichen Anzeige-Fenster markiert sein. Nun stehen prinzipiell 2 Methoden bereit, um das gewählte Objekt umzubenennen:

Mit der Funktion "Menü/Datei/Umbennen" aus dem Menü bzw. Kontextmenü wird die Editierung des Objektnamens gestartet. Es öffnet sich das übliche, gelb hinterlegte, Editierfeld, und Sie können den Namen des Objektes ändern.

Alternativ kann die Editierung des Objektnamens auch durch einen erneuten Mausklick auf das markierte Objekt gestartet werden – das Editierfeld öffnet sich wie oben beschrieben.

Die Umbenennen-Funktion finden Sie ebenfalls in der ToolBar "Datei".

Bei erfolgreichem Umbenennen werden alle Abhängigkeiten bzgl. des umbenannten Objektes in den LayerManager-Daten und ggf. auch in der Zeichnung automatisch aktualisiert.

Hinweis: Haben Sie mehrere Objekte markiert, und nutzen die Funktion "Menü/Datei/Umbenennen", so wird anstelle des Umbenennens automatisch die Funktion "Objekte klonen" gestartet.


Objekte kopieren

Auf alle Objekte (Layer, Layergruppen und Hierarchien) anwendbar ist die "Kopieren"-Funktion, die Sie unter "Menü/Datei/Kopieren" im Pulldown-Menü, im Kontextmenü und in der ToolBar "Datei" finden.

Generell wird beim Kopieren eines Objektes dessen exakte Kopie erzeugt – das neue Objekt übernimmt alle Eigenschaften des Ausgangs-Objektes, inklusive der Layer-Eigenschaften, bei Layergruppen alle Layer und bei Hierarchien alle Sub-Hierarchien und Layergruppen.

Nach Anwenden der Kopieren-Funktion wird im aktiven Anzeige-Fenster ein neuer Eintrag angelegt und das bekannte Editierfeld mit dem neuen Eintrag geöffnet – geben Sie nun den Namen für das neu erstellte Objekt ein. Als nächster Schritt öffnet sich am unteren Bildrand das Editierfeld zur Bearbeitung des Beschreibungstextes für die Kopie – geben Sie bitte einen entsprechenden Beschreibungstext ein.

Speziell beim Kopieren eines Layers: Bevor ein neuer Layer-Eintrag angelegt wird, erscheint eine Anfrage, ob beim Kopieren des Layers auch die Zeichnungselemente auf den neuen Layer mitkopiert werden sollen – falls gewünscht, markieren Sie das Kontrollkästchen.

Hinweis: Haben Sie mehrere Objekte markiert, und nutzen die Funktion "Menü/Datei/Kopieren", so wird anstelle des Kopierens automatisch die Funktion "Objekte klonen" gestartet.


Objekte klonen

Eng verwandt mit den Funktionen "Umbenennen" und "Kopieren" ist die Funktion "Klonen". Sie werden die "Klonen"-Funktion weder im Pulldown-Menü noch im Kontextmenü finden – der LayerManager startet diese Funktion automatisch, wenn Sie mehr als 1 Objekt im aktiven Anzeige-Fenster markiert haben und "Umbenennen" oder "Kopieren" nutzen (aus Pulldown-Menü, Kontextmenü oder ToolBar) – dies liegt darin begründet, daß weder "Umbenennen" noch "Kopieren" mit mehreren Objekten unmittelbar möglich sind noch einen Sinn ergeben. Daher bietet LaymanPro die "Klonen"-Funktion, um der Situation eine dem "Umbenennen" bzw. "Kopieren" sinngemäß entsprechende Funktion anzubieten.

Bei "Klonen" basierend auf "Kopieren" wird für jedes Objekt eine Kopie erstellt; der Name wird je nach Modus durch Ergänzung mit Präfix- und Suffix-Text oder durch Suchen+Ersetzen eines Textes gebildet.
Bei "Klonen" auf Basis von "Umbenennen" wird der Name jedes Objektes selbst mit Präfix- und Suffix-Text ergänzt bzw. durch Suchen+Ersetzen eines Textes gebildet.

Speziell beim Klonen von Layern: Wenn Sie die "Klonen"-Funktion auf Basis von "Kopieren" bei markierten Layern nutzen, so erscheint eine Option, mit welcher auch die Zeichnungselemente der Ausgangs-Layer mitkopiert werden – wenn Sie dies wünschen, so setzen Sie bitte das Kontrollkästchen in der Anfrage aktiv.


Objekte verschieben

Das "Verschieben" von Objekten ist nur für Layergruppen und Hierarchien als Verschieben zwischen Hierarchien, im Zuge von Drag-&-Drop-Operationen, möglich. Ist das linke Anzeige-Fenster auf den Modus "Hierarchien" eingestellt, so markieren Sie bitte die zu verschiebenden Layergruppen oder Sub-Hierarchien. Klicken Sie dann erneut (linke oder rechte Maustaste) auf eines der markierten Objekte, halten die Maustaste gedrückt und ziehen Sie die Objekte auf die gewünschte Ziel-Hierarchie. Lassen Sie dann die Maustaste wieder los – es erscheint das kleine Drag-&-Drop-Menü; wählen Sie die Funktion "Verschieben" aus.

Hinweis: Die "Verschieben"-Funktion ist nicht im Pulldown-Menü und auch nicht im Kontextmenü enthalten – sie steht nur für Drag-&-Drop-Operationen (wie beschrieben) zur Verfügung.


Objekte löschen/entfernen

Für alle LayerManager-Objekte (Layer, Layergruppen, Hierarchien) verfügbar ist die Funktion zum Löschen oder Entfernen der Objekte. Sie finden die "Löschen"-Funktion sowohl im Pulldown-Menü "Menü/Datei/Löschen" als auch im Kontextmenü "Löschen", außerdem ist sie auch in der ToolBar "Datei" enthalten. Mit der Taste "Entfernen" wird ebenfalls die "Löschen"-Funktion aufgerufen.

Markieren Sie zunächst die zu löschenden Objekte in einem der Anzeige-Fenster, und wählen dann die Löschen-Funktion - es erscheint stets eine Sicherheits-Anfrage, bevor die Objekte gelöscht werden.

Je nach Modus des aktiven Anzeige-Fensters hat das Löschen der markierten Objekte verschiedene Wirkung; dies wird nachfolgend detailliert dargestellt.

1. Löschen von Layern:

im Anzeige-Modus "Alle Layer", "aktive Layer", "nicht aktive Layer" (alle im rechten Anzeige-Fenster):

Hier werden unmittelbar die Zeichnungslayer dargestellt – das Löschen der Layer bezieht sich daher auch direkt auf die Zeichnung. Das heißt, wenn Sie die Anfrage zum Löschen bestätigen, so werden die Layer in der Zeichnung gelöscht. Alle gelöschten Layer werden natürlich auch in den Layergruppen und sonstigen LayerManager-Daten (z.B. Beschreibungstexte) gelöscht.

im Anzeige-Modus "Abhängige Layer" (rechtes Fenster), "Layergruppen" (linkes Anzeige-Fenster):

Hier werden die Layer als Inhalt von Layergruppen dargestellt - in diesem Fall entfernen Sie also die Layer lediglich aus den betreffenden Layergruppen, nicht aus der Zeichnung selbst.

2. Löschen von Layergruppen:

im Anzeige-Modus "Alle Layergruppen" (linkes und rechtes Anzeige-Fenster):

Es werden unmittelbar alle Layergruppen angezeigt – das Löschen der Layergruppen bewirkt daher das echte Entfernen der markierten Layergruppen aus der Zeichnung und auch aus allen Hierarchien, in denen die entsprechenden Layergruppen enthalten sind.

im Anzeige-Modus "Abhängige Layergruppen" (rechtes Anzeige-Fenster), "Hierarchien" (linkes Fenster):

Hier werden die in den betreffenden Hierarchien enthaltenen Layergruppen angezeigt – daher bezieht sich das Löschen auch nur auf diese Hierarchien: die Layergruppen werden nur aus den betreffenden Hierarchien entfernt, nicht aus der Zeichnung selbst.

3. Löschen von Hierarchien und Sub-Hierarchien:

im Anzeige-Modus "Hierarchien" (nur linkes Anzeige-Fenster):

Hierarchien werden generell nur im linken Anzeige-Fenster dargestellt. Wenn Sie die markierten Hierarchien bzw. Sub-Hierarchien löschen, so wird lediglich der Verweis auf die markierten Objekte in der übergeordneten Hierarchie entfernt, die Objekte selbst bleiben erhalten. Erst wenn ein gelöschtes Objekt in keiner anderen Hierarchie mehr benutzt wird, dann wird das gelöschte Objekt wirklich aus der Zeichnung entfernt.

Hinweis: beim Löschen von Hierarchien besteht optional die Möglichkeit, die enthaltenen Layergruppenebenfalls zu löschen – wenn Sie die entsprechende Option aktivieren, so werden die in den zu löschenden Hierarchien enthaltenen Layergruppen ebenfalls gelöscht – diese Layergruppen sind dann vollständig, d.h. in der Zeichnung und allen Hierarchien, entfernt. Dies entspricht dem unmittelbaren Löschen von Layergruppen, wie in Punkt 1. beschrieben.


Strukturierung der Zeichnung - Auto-Strukturierung

Auto-Strukturierung

Eine der leistungsstärksten Funktionen stellt die "Auto-Strukturierung" (oder "automatische Strukturierung") dar, welche seit Version v4.1 besteht. Sie finden diese Funktion unter "Menü/Datei/Auto-Strukturierung". Die "Auto-Strukturierung" ermöglicht die nahezu vollständige Strukturierung Ihrer Zeichnungen mit geringstem Aufwand und erfolgt automatisch im Hintergrund, womit eine drastische Reduzierung des Strukturierungs-Aufwandes und gleichzeitige sehr hohe Sicherheit (gegen Fehlbedienung und Struktur-Fehler) einhergehen.

Einige Ausführungen zum Hintergrund der "Auto-Strukturierung" :

Bislang standen 2 prinzipielle Handlungsweisen zum Aufbau der Layer-Strukturen zur Verfügung :

  1. der Anwender musste seine Zeichnungen stets manuell strukturieren, d.h. alle neu in der Zeichnung entstandenen Layer mussten manuell in entsprechende Layergruppen einsortiert werden.

  2. Alternativ bzw. auch zusätzlich bestand die Möglichkeit, Prototyp-Daten in die Zeichnung zu laden, primär mit Hilfe der LayerManager-Import/Export-Dateien, oder über Block-Einfügungen mit entsprechenden LayerManager-Strukturen.

Beide Methoden stellen völlig entgegengesetzte Strategien mit ihren jeweiligen Vorteilen und Nachteilen dar :

  1. Nachteil: die manuelle Nachführung erforderte relativ viel Aufwand (jeder neue Layer muss wieder eingegliedert werden), und wiederholt sich mit jeder neuen Zeichnung, inklusive möglicher Strukturierungs-Fehler und Unsicherheiten; Vorteil: die LayerManager-Strukturen widerspiegeln perfekt die jeweilige Zeichnungs-Struktur.

  2. Nachteil: zwar können fertige (und komplette) Strukturen mit allen Layern und Gruppen importiert werden, jedoch sind gerade kleinere Zeichnungen damit "überfrachtet"; Vorteil: der manuelle Strukturierungs-Aufwand wird sehr stark reduziert.

Damit entsteht manchmal eine recht kuriose Situation (wenn viele Layer genutzt werden > 100) :

Der Anwender kann in einer neuen Zeichnung zwar fertige Strukturen mit der Import/Export-Funktion in die Zeichnung laden, hat jedoch noch kein einziges Element gezeichnet – beginnt nun die Zeichenarbeit, ist der Anwender mehr damit beschäftigt, die Layer zu schalten, als zu zeichnen. Oder: wird keine Strukturierung über die Import/Export-Dateien vorgenommen, ist eine permanente Strukturierung notwendig, bis die Zeichnung alle Layer und Layergruppen enthält – beides stellt letztendlich keine optimale Lösung dar !

Ausserdem ist der Anwender gezwungen, eine beispielhafte Zeichnung mit allen möglichen Layern anzulegen, sie zu strukturieren und eine Import/Export-Datei zu erstellen – kommt nun ein neuer, bislang nicht berücksichtigter Layer dazu, entsteht jedoch wieder manueller Aufwand, und das Spiel beginnt erneut …

Die Lösung des Problems :

Die Nutzung intelligente LayerManager-Templates mittels der Auto-Strukturierung !

Ein LayerManager-Template ist eine Sammlung formaler Definitionen darüber,

  1. welche Layer in welchen Layergruppen enthalten sein sollen

  2. welche Sub-Hierarchien und Layergruppen in welchen Hierarchien enthalten sein sollen,

und wird als Text-Dateien auf der Festplatte gespeichert und einer Zeichnung zugeordnet.

Funktions-Prinzip :

Durch die Definition von LayerManager-Templates erhält die Zeichnung das Wissen über die von Ihnen gewünschte Strukturierung der Zeichnung – mit diesem "Wissen" kann der LayerManager nun die Zeichnung permanent überwachen :

  1. entsteht ein neuer Layer in der Zeichnung, wird dieser mit den Definitionen der Template-Datei verglichen – und in alle entsprechenden Layergruppen eingegliedert, welche diesen Layer referenzieren

  2. entsteht eine neue Layergruppe in der Zeichnung, wird diese auch mit den Definitionen der Template-Datei verglichen – und in alle entsprechenden Hierarchien eingegliedert, die diese Gruppe referenzieren

Bereits beim Öffnen der Zeichnung sind die zugeordneten Template-Dateien aktiv und es erfolgt ein Abgleich der Zeichnungs-Layer mit den Template-Definitionen – die Gruppen und Hierarchien werden sofort gebildet. All diese Vorgänge laufen völlig transparent im Hintergrund ab – ohne manuellen Eingriff entstehen exakt die definierten und gewünschten Strukturen, ohne dabei den geringsten Struktur-Overhead zu erzeugen: es sind niemals unnötige Layer, Layergruppen oder Hierarchien in der Zeichnung vorhanden !

Bei der Definition der Templates besteht nicht nur die Möglichkeit, konkrete Layer und Layergruppen als einzuschließende Objekte anzugeben – auch die Nutzung von Wildcards ("*", "?" etc.) ist problemlos möglich ! Ausserdem können einer Zeichnung beliebig viele LayerManager-Template-Dateien gleichzeitig zugeordnet sein – diese Zuordnung kann beispielsweise schon in einer Template-Zeichnung (*.dwg, *.dwt) erfolgen ! Damit kann der Anwender beliebig fein gegliederte Templates mit hoher Flexibilität und Sicherheit erstellen – und die Zeichnungs-Struktur je nach Projekt-Vorgaben im "Baukasten-Prinzip" zusammenstellen.

Nebeneffekt: ein versehentliches Löschen einer Layergruppe hat keine negative Auswirkung: mit "Ansicht/Aktualisieren" wird diese automatisch neu erstellt, sofern in den LayerManager-Templates enthalten.

Ein kleines Beispiel soll dies verdeutlichen :

Architektur-Zeichnung mit Darstellung der Strom- und Gas-Planung für verschiedene Ausgaben – die Definition der Layergruppen erfolgt geschossweise, getrennt in die genannten Gewerke :

Layergruppe: 0G_Arch enthaltene Layer: 0G_Arch*, 0G_Bau*, 0G_Wand*, 0

Layergruppe: 1G_Arch enthaltene Layer: 1G_Arch*, 1G_Bau*, 1G_Wand*, 0 usw.

Layergruppe: 0G_Strom enthaltene Layer: 0G_Strom*, 0G_Kabel*, 0G_Schalt*, 0

Layergruppe: 1G_Strom enthaltene Layer: 1G_Strom*, 1G_Kabel*, 1G_Schalt*, 0usw.

Hierarchie: Erdgeschoss enthaltene Gruppen: 0G*, Terasse

Hierarchie: 1. Geschoss enthaltene Gruppen: 1G*usw.

Entsteht nun in der Zeichnung ein neuer Layer "1G_Wand_Durchbrüche", so wird dieser in die Layergruppe "1G_Arch" eingegliedert (und die Gruppe selbst ggf. erstellt), die ggf. neu erstellte Layergruppe "1G_Arch" wird in die Hierarchie "1. Geschoss" eingegliedert (und die Herarchie ggf. auch erstellt), usw …..

siehe auch :

Verwaltung von LayerManager-Templates

Template-Eintrag erstellen

Template-Eintrag bearbeiten


Verwaltung von LayerManager-Templates

Mit der Funktion "Menü/Datei/Auto-Strukturierung" öffnet sich der Template-Dialog, mit dem Sie alle Definitionen verwalten, diese bearbeiten, löschen, erstellen, kopieren und schließlich als Datei speichern und gespeicherte Template-Dateien der Zeichnung zuordnen können.

Jede Template-Datei kann Einträge zur Definition von Gruppen und Hierarchien enthalten. Jeder dieser Einträge legt fest, welche Inhalte in das Objekt aufgenommen werden: also welche Layer in welcher Gruppe, und welche Gruppen / Sub-Hierarchien wiederum in welchen Hierarchien enthalten sind.

Nach der Wahl einer Template-Datei können deren Definitionen eingesehen und bearbeitet werden.

Die enthaltenen Objekte können sowohl mit "festen" Namen als auch mit "Wildcards" festgelegt werden – damit sind Templates überaus flexibel.

Beschreibung der Dialog-Elemente :

Datei-Klappliste | Zeigt alle der Zeichnung zugeordneten Template-Dateien und wählt die aktive
Template-Definitionen aktiv | Aktiviert bzw. deaktiviert die Definitionen der angezeigten Template-Datei
Zuordnen | Ordnet der Zeichnung eine weitere Template-Datei zu und lädt diese
Lösen | Löst die (in der Klappliste) selektierte Template-Datei
Speichern | Ist die aktive Template-Datei verändert, wird der Button zum Speichern aktiv
Speichern als | Ermöglicht das Speichern der aktiven Template-Datei unter anderem Namen
Hierarchien/Layergruppen | Schaltet zwischen der Anzeige von Hierarchien und Layergruppen um
Neu | Öffnet den Dialog zum Erstellen eines neuen Template-Eintrages
Kopieren | Erstellt eine Kopie des markierten Template-Eintrages
Bearbeiten | Öffnet den Dialog zum Bearbeiten des markierten Template-Eintrages
Entfernen | Löscht den markierten Template-Eintrag
Alle aktuellen | Erstellt Template-Einträge aus den aktuell bestehenden Gruppen/Hierarchien


Template-Eintrag erstellen

Der Button "Neu" öffnet den Dialog zur Erstellung eines neuen Tempalte-Eintrages – damit wird die Definition einer weiteren Layergruppe/Hierarchie in der Template-Datei angelegt. Beachten Sie, daß mit Wildcards definierte Inhalte flexibler und sicherer sind – insbesondere bei Namens-Konventionen mit festen Regeln.

Ein Template-Eintrag besitzt folgende Bestandteile, die im gezeigten Dialog eingestellt werden können :

Layergruppe/Hierarchie: geben Sie hier den Namen der gewünschten Layergruppe/Hierarchie ein – in der Klappliste sind alle bestehenden Objekte eingetragen

"auf oberster Ebene": (nur bei Hierarchien) ist die Option aktiv, wird die Hierarchie auf der obersten (TopLevel-)Ebene erstellt, sonst nur als Sub-Hierarchie

Beschreibung: tragen Sie hier den Info-Text der Layergruppe/Hierarchie ein

Liste der Bestandteile: diese Liste enthält alle gewünschten Inhalte für die Layergruppe/Hierarchie – es können beliebig viele Elemente, auch mit Wildcards, angegeben werden. Die Klappliste enthält alle in der Zeichnung bestehenden Layer bzw. Layergruppen – damit können die realen Objekte direkt gewählt werden

"Alle aktuellen": dieser Button bewirkt, daß alle in der Zeichnung bestehenden Objekte (Layer, Layergruppen) als Bestandteil gewählt werden.


Template-Eintrag bearbeiten

Mit dem Button "Bearbeiten" öffnet sich der Dialog zur Bearbeitungs des markierten Template-Eintrages – Sie können hier alle Bestandteile des Template-Eintrages einsehen und bearbeiten.

Weitestgehend identisch mit der "Erstellung von Template-Einträgen" ist die Handhabung des Bearbeiten-Dialoges – so daß alle dortigen Ausführungen auch hier gelten.

Möchten Sie den Namen der Layergruppe/Hierarchie ändern, so tragen Sie einfach den gewünschten Namen ein – damit wird kein neuer Eintrag angelegt, sondern der angezeigte Eintrag umbenannt.

Hinweis: bitte beachten Sie, daß Definitionen mit Wildcards wesentlich flexibler und sicherer sind – besonders bei Namens-Konventionen mit festen Regeln


Einführung sowie Grundsätzliches

Der LayerManager wurde und wird mit der grundsätzlichen Zielsetzung entwickelt, nicht nur die Strukturierung und Übersichtlichkeit der Zeichnung mit komfortablen Funktionen zu verbessern – ebenso wichtig wie der Komplex "Zeichnungs-Strukturierung" und somit 2. Entwicklungsschwerpunkt ist der Komplex der "Zeichnungs-Steuerung" mittels der Layergruppen und Hierarchien. So folgt erst aus der Anwendung und Handhabung der LayerManager-Objekte der Effektivitätsgewinn für den Anwender: schnelle, sichere Handhabung und Steuerung selbst hunderter Layer mit wenigen Mausklicks, erhöhte Handlungssicherheit und die Beseitigung monotoner, zeitraubender und hohe Konzentration fordernder Bearbeitung im AutoCAD-Layerdialog sind nur einige der Vorteile des LayerManagers. Trotz der enormen Funktionsvielfalt und weitreichender Konzepte orientiert sich der LayerManager strikt (in den mit AutoCAD vergleichbaren Arbeitsschritten) an den Prinzipien und Bedienungsdetails von AutoCAD – so bleibt dem Anwender ein Umdenken und Umlernen praktisch erspart – all das, was bisher in AutoCAD's Layerdialog vorgenommen wird und möglich ist, finden Sie nahezu identisch auch im LayerManager wieder.

Alle Funktionen zur Zeichnungs-Steuerungen arbeiten grundsätzlich identisch mit allen Objekten: Layer, Gruppen und Hierarchien handhaben Sie vollkommen gleich – Sie finden sich schnell zurecht.

Als Erweiterung zur AutoCAD-üblichen Icon-Liste in den Layer-Eigenschaften stellt der LayerManager diese Icon-Liste auch für Layergruppen zur Verfügung. Dadurch haben Sie sehr schnell Zugriff und Übersicht zum jeweiligen Status der Layergruppen – mit folgender Besonderheit: da Layergruppen (meist) mehrere Layer enthalten, können Layergruppen auch einen weiteren Zustand einnehmen – teilweise sichtbar, teilweise gesperrt, teilweise plotbar, Farbe variierend, Linientyp variierend usw. Dieser Zustand variierender Eigenschaften wird durch entsprechende Icons bzw. durch den Text "Variiert" angezeigt.

In AutoCAD 2000(i) bietet Ihnen der LayerManager auch bei den grundlegenden Funktionen besonderen Komfort: bei (nahezu) allen Funktionen können Sie unmittelbar auch jene Zeichnungen steuern, die sich im Hintergrund befinden.


Überblick zu den verfügbaren Funktionen

Dieses Kapitel beschreibt im wesentlichen all jene Funktionen des LayerManagers, welche Sie letztlich auch in der AutoCAD-Layersteuerung vorfinden – d.h. es werden hier die grundlegenden Funktionen zur Layer-Steuerung behandelt.

Hierzu gehören im Wesentlichen die folgenden Funktionen für Layer, Layergruppen und Hierarchien:

· Layer aktuell setzen

· Objekte aktivieren/einschalten (mit den Modi: hinzufügen und exklusiv/isolieren)

· Objekte deaktivieren/ausschalten

· Objekte sperren und entsperren

· Farbe für Objekte setzen

· Linientyp für Objekte setzen

· Linienstärke für Objekte setzen (nur AutoCAD 2000(i))

· Plotstatus für Objekte setzen (nur AutoCAD 2000(i))

· Plotstil für Objekte setzen (nur AutoCAD 2000(i))

Die in der AutoCAD-Layersteuerung getrennten Einstellungen für "Ein/Aus" und Frieren/Tauen" sind im LayerManager zusammengefaßt als "Aktivieren" bzw. "Deaktivieren" – in den Programm-Optionen wird festgelegt, welche Methode ("Ein/Aus" oder "Frieren/Tauen") der LayerManager jeweils verwendet.

Mehr als ein Dutzend weiterer, sehr effektiver Anwendungsfunktionen, die in AutoCAD nichts Vergleichbares haben, werden im Kapitel "Spezielle Funktionen" beschrieben. Ausserdem stehen eine Vielzahl von "Drag-&-Drop-Operationen" zur Verfügung, welche ebenfalls im entsprechenden Kapitel beschrieben werden.


Layer aktuell setzen

Um einen markierten Layer in der Zeichnung zum aktuellen Layer zu machen, nutzen Sie die Funktion "Menü/Bearbeiten/Layer/Aktuell setzen" aus dem Pulldown-Menü bzw. "Aktuell setzen" aus dem Kontextmenü des Objektes: diese Funktion ist nicht in einer der ToolBars vorhanden.

Diese Funktion ist als Default auch für den Doppelklick auf einen Layer definiert – überprüfen Sie dies bitte ggf. in den LayerManager-Optionen.

Die Seite und der Modus des aktiven Anzeige-Fensters spielt hierbei keine Rolle – Sie können also auch den in einer Layergruppe enthaltenen Layer aktuell setzen. Allerdings wird diese Funktion aus Gründen der Eindeutigkeit deaktiviert (ausgegraut), wenn Sie mehr als 1 Layer markiert haben.


Objekte aktivieren/einschalten

Um die markierten Objekte in der Zeichnung zu aktivieren, d.h. sichtbar zu machen, nutzen Sie bitte die Funktion "Menü/Bearbeiten/Aktivieren/Exklusiv-Hinzufügen" aus dem Pulldown-Menü bzw. Kontextmenü oder auch die gleiche Funktion aus der ToolBar "Bearbeiten/Aktivieren".

Der LayerManager bietet bei der Aktivierung von Objekten 2 Modi an: Exklusiv und Hinzufügen.

Die Methode, mit welcher der LayerManager die Zeichnungs-Layer in AutoCAD aktiviert bzw. deaktiviert, wird in den Programm-Optionen festgelegt – überprüfen Sie dies bitte bei Bedarf.

Aktivierung "Exklusiv":

Bei der exklusiven Aktivierung von Objekten werden in der Zeichnung nur noch ausschließlich die markierten Objekte (bzw. deren Gesamtheit an Layern) aktiviert, alle sonstigen Layer werden automatisch deaktiviert, also ausgeschaltet. Diese Methode der Aktivierung wird oft auch als "Isolieren" bezeichnet.

Aktivierung "Hinzufügen":

Bei der Methode "Hinzufügen" wird die Gesamtheit der Layer aus den markierten Objekten zusätzlich in der Zeichnung aktiviert/eingeschaltet – die sonstigen Zeichnungslayer werden nicht beeinflusst.

Speziell bei Aktivierung von Layergruppen:

Wenn Sie Layergruppen aktivieren, welche eine benannte Ansicht /View und/oder ein benanntes BKS zugeordnet haben, öffnet sich zusätzlich der Ansichts/BKS-Dialog, mit dem Sie die (zusätzliche) Aktivierung von Ansicht bzw. BKS steuern können.

Speziell im rechten/unteren Anzeige-Fenster:

Mit einem Mausklick (linke Maustaste) auf das Sichtbarkeits-Icon können Layer und Layergruppen ebenfalls aktiviert werden. Haben Sie mehrere Objekte markiert, bezieht sich das Aktivieren auf alle markierten Objekte. Speziell bei Layergruppen: ist eine Layergruppe nur teilweise aktiv/sichtbar (zu erkennen am "halb aktiven/halb inaktiven" Lämpchen), so erscheint nach dem Mausklick ein kleines Kontextmenü mit der Wahl, die markierte(n) Layergruppe(n) zu aktivieren (exklusiv/hinzufügen) oder zu deaktivieren.

Hinweis: Wenn Sie Objekte in den Anzeige-Spalten markieren möchten, drücken Sie zusätzlich die Tasten <CTRL/STRG> oder <SHIFT>.

siehe auch :

Aktivierung von Objekten im Papierbereich

Aktivierung von 3D-View und BKS bei Layergruppen


Aktivierung von Objekten im Papierbereich

Besondere Leistungsmerkmale bietet der LayerManager beim Aktivieren von Objekten im Papierbereich bzw. in den verschiedenen Layouts : Sie können frei wählen, in welchen Viewports bzw. Viewport-Kombinationen die Objekte aktiviert werden ! Dabei stehen alle denkbaren Varianten, inklusive der manuellen Viewport-Auswahl und der Papierbereichs-Viewport selbst, zur Verfügung. Damit können Sie, insbesondere bei mehreren Viewports, Ihren Papierbereich extrem schnell und sicher einstellen.

Die betroffenen Layer werden Viewport-bezogen gesteuert – dies entspricht dem AutoCAD-Befehl "_vplayer".

Mit dem kleinen Auswahl-Dialog bestimmen Sie den Geltungsbereich des Aktivierens; zusätzlich können Sie auch den Modus "Exklusiv" bzw. "Hinzufügen" festlegen.

Beschreibung der Optionen zum Aktivieren im Papierbereich:

Nur aktueller Viewport : die Aktivierung erfolgt nur im aktuellen Viewport; dies kann auch der Papierbereichs-Viewport sein !

Nur Papierbereich: die Aktivierung erfolgt ausschließlich im Papierbereichs-Viewport (also auf dem "Papier").

Wahl Modellbereichs-Viewports: Sie können die Viewports manuell auswählen, in denen die Aktivierung erfolgt.

Alle Modellbereichs-Viewports: die Aktivierung erfolgt in allen Modellbereichs-Viewports.

Alle Modellbereichs-/Papierbereichs-Viewports: die Aktivierung erfolgt in allen Modellbereichs-Viewports und im Papierbereichs-Viewport (also zusätzlich auch auf dem "Papier")

Exklusiv: Objekte werden im Modus "Exklusiv" aktiviert (isolieren).

Hinzufügen: Objekte werden im Modus "Hinzufügen" aktiviert.


Aktivierung von 3D-View und BKS bei Layergruppen

Der LayerManager erlaubt es, einer Layergruppe zusätzlich auch einen 3D-View sowie ein benanntes BKS zuzuordnen – beim Aktivieren von Layergruppen besteht somit auch die Möglichkeit, diese zugeordnete Ansicht und/oder das zugeordnete BKS ebenfalls (zusammen mit der Layergruppe) zu aktivieren. Insbesondere bei Zeichnungen mit 3D-Objekten kann somit viel Zeit gespart werden, um den optimalen Blick auf die Zeichnungsobjekte einzustellen. Und Sie haben die Sicherheit, exakt die gleiche Ansicht wiederher-zustellen.

Die Verknüpfung von Layergruppen mit 3D-View und BKS ist in den Kapiteln "View zuordnen" und "BKS zuordnen" dargestellt. Die Aktivierung von 3D-View und BKS steht selbstverständlich auch im Papierbereich zur Verfügung.

3D-View: ist der/den Layergruppe(n) eine benannte 3D-View zugeordnet, so kann diese auf Wunsch ebenfalls aktiviert werden – ist keine 3D-View mit der/den Layergruppe(n) verbunden, so wird diese Option ausgegraut.

BKS: ist der/den Layergruppe(n) eine benannte BKS zugeordnet, so kann dieses auf Wunsch ebenfalls aktiviert werden – ist kein BKS mit der/den Layergruppe(n) verbunden, so wird diese Option ausgegraut.


Objekte deaktivieren/ausschalten

Unter dem "Deaktivieren" von Objekten wird das Ausschalten bzw. Frieren der Objekte verstanden, d.h. alle Layer der markierten Objekte sind in der Zeichnung graphisch nicht mehr sichtbar – daher ist "deaktivieren" auch als "nicht mehr sichtbar" zu bezeichnen.

Um markierte Objekte zu deaktivieren, nutzen Sie bitte die Funktion "Menü/Bearbeiten/Deaktivieren" aus dem Pulldown-Menü, "Deaktivieren" aus dem Kontextmenü oder auch ToolBar "Bearbeiten/Deaktivieren".

Die Methode, mit welcher der LayerManager die Zeichnungs-Layer in AutoCAD aktiviert bzw. deaktiviert, wird in den Programm-Optionen festgelegt – überprüfen Sie dies bitte bei Bedarf.

Speziell im rechten/unteren Anzeige-Fenster:

Mit einem Mausklick (linke Maustaste) auf das Sichtbarkeits-Icon können Layer und Layergruppen ebenfalls deaktiviert werden. Haben Sie mehrere Objekte markiert, bezieht sich das Deaktivieren auf alle markierten Objekte. Speziell bei Layergruppen: ist eine Layergruppe nur teilweise aktiv/sichtbar (zu erkennen am "halb aktiven/halb inaktiven" Lämpchen), so erscheint nach dem Mausklick ein kleines Kontextmenü mit der Wahl, die markierte(n) Layergruppe(n) zu aktivieren oder zu deaktivieren.

Hinweis: Wenn Sie Objekte in den Anzeige-Spalten markieren möchten, drücken Sie zusätzlich die Tasten <CTRL/STRG> oder <SHIFT>.

siehe auch :

Deaktivierung von Objekten im Papierbereich


Deaktivierung von Objekten im Papierbereich

Besondere Leistungsmerkmale bietet der LayerManager beim Deaktivieren von Objekten im Papierbereich: Sie können frei wählen, in welchen Viewports bzw. Viewport-Kombinationen die Objekte deaktiviert werden ! Dabei stehen alle denkbaren Varianten, inklusive der manuellen Viewport-Auswahl und der Papierbereichs-Viewport selbst, zur Verfügung. Damit können Sie, insbesondere bei mehreren Viewports, Ihren Papierbereich extrem schnell und sicher einstellen.

Mit dem kleinen Auswahl-Dialog bestimmen Sie den Geltungsbereich des Deaktivierens.

Beschreibung der Optionen zum Deaktivieren im Papierbereich:

Nur aktueller Viewport : die Deaktivierung erfolgt nur im aktuellen Viewport; dies kann auch der Papierbereichs-Viewport sein !

Nur Papierbereich: die Deaktivierung erfolgt ausschließlich im Papier-bereichs-Viewport (also auf dem "Papier").

Wahl Modellbereichs-Viewports: Sie können die Viewports manuell auswählen, in denen die Deaktivierung erfolgt.

Alle Modellbereichs-Viewports: die Deaktivierung erfolgt in allen Modellbereichs-Viewports.

Alle Modellbereichs-/Papierbereichs-Viewports: die Deaktivierung erfolgt in allen Modellbereichs-Viewports und im Papierbereichs-Viewport (also zusätzlich auch auf dem "Papier").


Objekte sperren und entsperren

Um die markierten Objekte zu sperren bzw. zu entsperren, nutzen Sie bitte die Funktion "Menü/Bearbeiten/Sperren" bzw. ".../Entsperren" aus dem Pulldown-Menü, oder "Sperren" bzw. "Entsperren" aus dem Kontextmenü oder auch ToolBar "Bearbeiten/Sperren".bzw. ".../Entsperren".

Speziell im rechten/unteren Anzeige-Fenster:

Mit einem Mausklick (linke Maustaste) auf das Sperren-Icon können Layer und Layergruppen ebenfalls gesperrt bzw. entsperrt werden. Haben Sie mehrere Objekte markiert, bezieht sich das Sperren und Entsperren auf alle markierten Objekte. Speziell bei Layergruppen: ist eine Layergruppe nur teilweise gesperrt (zu erkennen am "Schloss ohne Bügel" Icon), so erscheint nach dem Mausklick ein kleines Kontextmenü mit der Wahl, die markierte(n) Layergruppe(n) zu sperren oder zu entsperren.

Hinweis: Wenn Sie Objekte in den Anzeige-Spalten markieren möchten, drücken Sie zusätzlich die Tasten <CTRL/STRG> oder <SHIFT>.


Farbe für Objekte setzen

Um für die markierten Objekte die Farbe zu setzen, nutzen Sie bitte die Funktion "Menü/Bearbeiten/Farbe" aus dem Pulldown-Menü oder "Farbe" aus dem Kontextmenü oder auch ToolBar "Bearbeiten/Farbe". Es öffnet sich der bekannte AutoCAD-Farbdialog zur Auswahl eines Farbwertes.

Speziell im rechten/unteren Anzeige-Fenster:

Mit einem Mausklick (linke Maustaste) auf das Farb-Icon können Sie Layern und Layergruppen eine neue Farbe zuordnen. Haben Sie mehrere Objekte markiert, erhalten alle markierten Objekte die im Farbdialog gewählte Farbe. Speziell bei Layergruppen: falls die in einer Layergruppe enthaltenen Layer verschiedene Farbwerte nutzen, so erscheint anstelle von Farbname/Farbnummer der Text "Variiert"; außerdem ist das Icon farblos.

Hinweis: Wenn Sie Objekte in den Anzeige-Spalten markieren möchten, drücken Sie zusätzlich die Tasten <CTRL/STRG> oder <SHIFT>.


Linientyp für Objekte setzen

Um für die markierten Objekte einen anderen Linientyp zu setzen, nutzen Sie bitte die Funktion "Menü/Bearbeiten/Linientyp" aus dem Pulldown-Menü oder "Linientyp" aus dem Kontextmenü oder auch ToolBar "Bearbeiten/Linientyp". Es öffnet sich ein Popup-Fenster mit den aktuell in AutoCAD verfügbaren Linientypen.

Möchten Sie neue Linientypen (aus einer AutoCAD-Linientyp-Datei *.LIN) laden, so steht im Kontextmenü, wie abgebildet, ein entsprechender Dialog bereit – dieser entspricht dem von AutoCAD bekannten.

Speziell im rechten/unteren Anzeige-Fenster:

Mit einem Mausklick (linke Maustaste) in die Linientyp-Spalte können Sie Layern und Layergruppen einen Linientyp zuordnen. Sind mehrere Objekte markiert, erhalten alle markierten Objekte den in der Auswahl-Liste gewählten Linientyp.

Speziell bei Layergruppen: falls die in einer Layergruppe enthaltenen Layer verschiedene Linientypen nutzen, so erscheint anstelle eines Linientyp-Namens der Text "Variiert".

Hinweis: Die Größe des Auswahl-Fensters kann frei skaliert werden – es nutzt die zuletzt verwendete Fenstergröße; so kann ggf. ein Scrollen der Liste vermieden werden. Um das Fenster zu schliessen, wählen Sie ein Element der Liste, oder drücken <ESCAPE> oder klicken ausserhalb des Fensters.

Hinweis: Wenn Sie Objekte in den Anzeige-Spalten markieren möchten, drücken Sie zusätzlich die Tasten <CTRL/STRG> oder <SHIFT>.


Linienstärke für Objekte setzen

(nur ab AutoCAD 2000(i))

Um für die markierten Objekte eine andere Linienstärke einzustellen, nutzen Sie bitte die Funktion "Menü/Bearbeiten/Linienstärke" aus dem Pulldown-Menü oder "Linienstärke" aus dem Kontextmenü. Es öffnet sich ein Popup-Fenster mit den verfügbaren Linienstärke-Werten.

Speziell im rechten/unteren Anzeige-Fenster:

Mit einem Mausklick (linke Maustaste) in die Linienstärke-Spalte können Sie Layern und Layergruppen eine neue Linienstärke zuordnen. Haben Sie mehrere Objekte markiert, erhalten alle markierten Objekte die in der Auswahl-Liste gewählte Linienstärke.

Speziell bei Layergruppen: falls die in einer Layergruppe enthaltenen Layer verschiedene Linienstärken nutzen, so erscheint anstelle eines Linienstärke-Wertes der Text "Variiert".

Hinweis: Die Größe des Auswahl-Fensters kann frei skaliert werden – es nutzt die zuletzt verwendete Fenstergröße; so kann ggf. ein Scrollen der Liste vermieden werden. Um das Fenster zu schliessen, wählen Sie ein Element der Liste, oder drücken <ESCAPE> oder klicken ausserhalb des Fensters.

Hinweis: Wenn Sie Objekte in den Anzeige-Spalten markieren möchten, drücken Sie zusätzlich die Tasten <CTRL/STRG> oder <SHIFT>.


Plotstatus für Objekte setzen

(nur ab AutoCAD 2000(i))

Um für die markierten Objekte den Plotstatus zwischen "Ein" und "Aus" zu wechseln, nutzen Sie bitte die Funktion "Menü/Bearbeiten/Plotstatus/Ein-Aus" aus dem Pulldown-Menü oder "Plotstatus/Ein-Aus" aus dem Kontextmenü.

Speziell im rechten/unteren Anzeige-Fenster:

Mit einem Mausklick (linke Maustaste) auf das Plotstatus-Icon können Sie den Plotstatus der markierten Layern und Layergruppen wechseln. Haben Sie mehrere Objekte markiert, erhalten alle markierten Objekte den entsprechend neuen Plotstatus.

Speziell bei Layergruppen: besitzen die in einer Layergruppe enthaltenen Layer einen verschiedenen Plotstatus, so ist das Drucker-Icon zusätzlich mit einem Fragezeichen versehen, und nach dem Mausklick es erscheint ein kleines Kontextmenü mit der Auswahl "Plotstatus:Ein" und "Plotstatus:Aus".

Hinweis: Wenn Sie Objekte in den Anzeige-Spalten markieren möchten, drücken Sie zusätzlich die Tasten <CTRL/STRG> oder <SHIFT>.


Plotstil für Objekte setzen

(nur ab AutoCAD 2000(i))

Um für die markierten Objekte den gewünschten Plotstil einzustellen, nutzen Sie bitte die Funktion "Menü/Bearbeiten/Plotstil" aus dem Pulldown-Menü oder "Plotstil" aus dem Kontextmenü. Es öffnet sich ein Popup-Fenster mit den verfügbaren Plotstilen.

Speziell im rechten/unteren Anzeige-Fenster:

Mit einem Mausklick (linke Maustaste) in die Plotstil-Spalte können Sie Layern und Layergruppen einen neuen Plotstil zuordnen. Haben Sie mehrere Objekte markiert, erhalten alle markierten Objekte den in der Auswahl-Liste gewählten Plotstil.

Speziell bei Layergruppen: falls die in einer Layergruppe enthaltenen Layer verschiedene Plotstile nutzen, so erscheint anstelle eines Plotstil-Namens der Text "Variiert".

Hinweis: Die Größe des Auswahl-Fensters kann frei skaliert werden – es nutzt die zuletzt verwendete Fenstergröße; so kann ggf. ein Scrollen der Liste vermieden werden. Um das Fenster zu schliessen, wählen Sie ein Element der Liste, oder drücken <ESCAPE> oder klicken ausserhalb des Fensters.

Hinweis: Wenn Sie Objekte in den Anzeige-Spalten markieren möchten, drücken Sie zusätzlich die Tasten <CTRL/STRG> oder <SHIFT>.

Hinweis: Da die AutoCAD-Programmier-Schnittstellen gegenwärtig keine Möglichkeiten bieten, die in einer Plotstiltabelle enthaltenen Plotstilnamen zu erfragen, und die Plotstiltabellen-Dateien sinnigerweise (?) komprimiert gespeichert sind, können in der Auswahl-Liste leider nur die aktuell verwendeten Plotstile angeboten werden – leider.


Blättern in der Zeichnung

Mit der "Blättern"-Funktion (auch als "Display"-Funktion bezeichnet), haben Sie die Möglichkeit, einzeln oder auch gemeinsam, direkt in der Zeichnung durch die markierten Objekte (also Layer, Layergruppen, Hierarchien) zu blättern, d.h Sie gehen schrittweise durch die markierten Objekte. Diese Funktion eignet sich daher insbesondere zur Analyse fremder Zeichnungen (als Layer-Display) oder auch, um eine Art Vorschau auf die markierten Objekte zu erhalten (z.B. vor dem Aktivieren von Objekten). Die "Blättern"-Funktion finden Sie unter "Menü/Bearbeiten/Display", analog auch im Kontextmenü und in der ToolBar "Bearbeiten".

Die "Blättern"-Funktion arbeitet auch im Papierbereich sowie in wählbaren Viewports.

Nach dem Aufruf erscheint ein Auswahl-Dialog, mit dem Sie angeben, Wo (Anwendungsbereich) und Wie (Display-Modus) das Blättern erfolgen soll:

Wo: diese Option ist nur im Papierberich aktiv, im Modellbereich ist der Bereich "Anwendungsbereich für Display" ausgegraut – geben Sie hiermit an, in welchem Viewport das Blättern erfolgen soll.

Wie: diese Option bestimmt, ob die markierten Objekte jeweils einzeln oder alle gemeinsam (als Summe) angezeigt werden.

Weitere Detaills zu diesem Dialog finden Sie in "Aktivierung von Objekten im Papierbereich".

Nach dieser Auswahl beginnt das "Blättern", und das erste Objekt (bzw. alle Objekte im Modus "Gesamt-Anzeige") wird am Bildschirm aufgebaut. Nach jedem einzelnen "Blättern"-Schritt erscheint das "Zoom Optionen"-Menü, mit welchem Sie das weitere "Blättern" steuern können :

"<<<" / ">>>": geht einen Schritt rückwärts bzw. vorwärts im "Blättern"

"Layer <0> Ein/Aus": schaltet den Layer <0> Ein bzw. Aus – nützlich, um auch den Inhalt von Blöcken zu sehen, welche auf Layer <0> definiert sind

"Setzen": behält den angezeigten (Layer-)Zustand und beendet das "Blättern" (dies entspricht dem Aktivieren/Exklusiv für das Objekt).

"Aus": schaltet alle Layer der aktuellen Anzeige aus und beendet das "Blättern" (entspricht dem Deaktivieren für das Objekt).

"Markieren": das angezeigte Objekt wird als markiert vorgemerkt; nach Beenden des "Blätterns" werden die vorgemerkten Objekte als Auswahl im Anzeige-Fenster markiert.

"Editieren": ruft den Bearbeitungs-Dialog für das aktuelle Objekt auf.

Hinweis: es empfiehlt sich, vor dem "Blättern" die Methode der Layer-Steuerung in den LayerManager-Optionen auf "Ein/Aus" zu setzen, falls Sie sonst mit "Frieren/Tauen" arbeiten – mit "Ein/Aus" erfolgt das "Blättern" wesentlich schneller, da keine Regenerierung notwendig ist.


Vordergrund-Hintergrund-Steuerung

LaymanPro bietet Ihnen nicht nur die elementbezogene Vordergrund-/Hintergrund-Steuerung (mit den Funktionen "Zeichnungselemente in Vordergrund" und "Zeichnungselemente in Hintergrund") – als ein wesentliches Leistungsmerkmal kann LaymanPro die Anzeige-Reihenfolge auch auf Basis der Layer, Layergruppen und Hierarchien steuern – und geht damit weit über die durch AutoCAD gebotenen Möglichkeiten hinaus.

Sie finden die Funktion "Vordergrund-/Hintergrund-Steuerung unter "Menü/Extras/Anzeige-Reihenfolge".

Die definierten Reihenfolgen werden als "benannte Reihenfolge" getrennt für jeden Sortierungs-Modus (Hierarchien, Layergruppen, Layer) gespeichert. Wird die Zeichnung geöffnet, so kann mit "Anwenden" eine Reihenfolge erneut in der Zeichnung eingestellt werden (da AutoCAD die Reihenfolge wohl öfters mal vergißt). So wird ein definierter Grundzustand bzgl. der Anzeige-Reihenfolge schnell eingestellt. Insbesondere besteht die Möglichkeit, verschiedene Reihenfolgen zB. für verschiedene Layouts zu verwenden.

 Die Auswahl-Schalter (Hierarchien, LayerGruppen, Zeichnungs-Layer) bestimmen den Anzeige-Modus.

"Anwenden" erstellt die angezeigte Reihenfolge in der Zeichnung.

"Speichern" sichert die Reihenfolge in der Zeichnung..

Mit "in Vordergrund" und "in Hintergrund" können Sie die markierten Objekte ganz nach oben bzw. unten positionieren.

Die Pfeil-Knöpfe bewegen die markierten Objekte schrittweise in Richtung Vordergrund / Hintergrund. Mit "Export/Import" können Sie die Reihenfolgen zwischen Zeichnungen austauschen.

"Import/Export" ermöglichen den Austausch von Reihenfolgen.

Das Löschen-Icon entfernt eine Reihenfolge aus der Zeichnung.

Speziell "harte Methode : Elemente neu erstellen": wird die aktuelle Zeichnung als XRef in einer "Master"-Zeichnung verwendet, so ignoriert AutoCAD die in der (XRef-)Zeichnung zuletzt eingestellte Anzeige-Reihenfolge. Die gegenwärtig einzig bekannte Möglichkeit, die Anzeige-Reihenfolge dennoch verwenden zu können, besteht darin, die Zeichnungs-Elemente zu löschen und in der gewünschten Reihenfolge neu zu erstellen – ist diese Option also aktiviert, werden die Zeichnungs-Elemente gelöscht und identisch neu erstellt. Es gehen jedoch alle Element-Handle-basierenden Referenzierungen verloren, EEDs bleiben bestehen !

Wichtiger Hinweis: Es wird eindringlich darauf hingewiesen, diese Option unbedingt in einer Zeichnungs-Kopie zu testen, und zu prüfen, ob Ihre Zeichnung damit voll funktionstüchtig bleibt !

Die seit dem letzten Speichern neu hinzugekommenen Layer, Layergruppen und Hierarchien werden zunächst jeweils automatisch in den Vordergrund gesetzt. Sie können diese dann entsprechend einreihen.

Hinweis: Haben Sie ein/mehrere Objekte markiert, kann mit der rechten Maustaste das Kontextmenü aufgerufen werden – hier finden Sie die Funktionen, um die markierten Objekte in den Vordergrund bzw. Hintergrund zu setzen (also nach ganz oben bzw. ganz unten). Außerdem steht die Funktion "Anzeigen" hier ebenfalls bereit. Sie können die Objekte auch per Drag-&-Drop mit der linken Maustaste verschieben – beim Loslassen der Maustaste erscheint ein entsprechendes Kontextmenü.

siehe auch :

Anzeige-Reihenfolgen exportieren und importieren


Anzeige-Reihenfolgen exportieren und importieren

Mit den "Import/Export" Funktionen können Sie die einml erstellten Anzeige-Reihenfolgen zwischen Ihren Zeichnungen übertragen – und sich damit jede Menge Zeit und konzentrierte Arbeit ersparen, bei deutlich höherer Sicherheit ! Beim Export werden stets alle Reihenfolgen in eine wählbare Ausgabedatei geschrieben.

Mit den Kontroll-Kästchen können Sie exakt bestimmen, welche Anzeige-Reihenfolgen Sie importieren möchten – in der aktuellen Zeichnung bereits bestehende Reihenfolgen werden mit einem roten Icon dargestellt.

Vor dem Import können Sie bei Bedarf die Reihenfolge-Namen editieren – markieren Sie das Element und klicken erneut darauf, um das Editier-Feld zu öffnen. Nach dem Editieren wird ggf. ein weißes Icon gezeigt.

In der gespeicherten Reihenfolge vorhandene, in der aktuellen jedoch nicht bestehende Layer, Gruppen bzw. Hierarchien werden beim Import ignoriert – sie werden nicht angelegt !


Export und Import von LayerManager-Daten

Um einmal definierte Layergruppen und Hierarchien bzw. deren Definition auch für anderer Zeichnungs-Dateien zugänglich zu machen, bietet der LayerManager die Export-/Import-Funktionen an.

In der Exportdatei (Textdatei) speichert LaymanPro die Eigenschaften aller Layergruppen bzw. Hierarchien. Sie können dann diese Informationen in jede beliebige andere Zeichnung mit der Import-Funktion laden und dort identische Layergruppen bzw. Hierarchien bilden lassen, inklusive alle Layer mit ihren ursprünglichen Layer-Eigenschaften.

Dadurch eignen sich Exportdateien nicht nur zum Transfer von LayerManager-Daten: Sie können die Export-Dateien beispielsweise auch im Sinne von Vorlagen oder Prototyp-Dateien nutzen, verschiedene Layer-Norm-Systeme darin archivieren, interne Standards damit vorgeben und dergleichen mehr. Die Import-Funktion bietet hierbei auch den Komfort, ledglich beliebige Teildaten aus der Exportdatei zu laden.

Da es sich bei der Exportdatei um puren ASCII-Text handelt, können Sie ggf. solche Dateien auch mit einem beliebigen (Text-)Editor bearbeiten; sichern Sie dabei ab, daß der Editor wirklich nur reinen Text (ohne jede Formatierungs- und Steuercodes !) speichert. Eine mauelle Bearbeitung der Exportdateien sollten Sie aber wirklich nur dann vornehmen, wenn Sie die Strukturen in einer Export-Datei gut kennen !

Wichtiger Hinweis zu AutoCAD 2000(i): Der LayerManager unterstützt das "Multiple-Document-Environment" sehr umfassend – und erlaubt problemlos auch mehrfache LayerManager-Fenster . Zusätzlich werden Drag-&-Drop-Operationen verschiedenster Art unterstützt. Dadurch wird es möglich, LayerManager-Daten zwischen verschiedenen Zeichnungen sehr einfach per Drag-&-Drop zu übertragen – ohne Umweg über eine Export-Datei. Stellen Sie hierzu 2 LayerManager-Fenster jeweils auf die Ausgangs- bzw. Ziel-Zeichnung ein ( "Zeichnungs-Auswahl" ). Wählen Sie dann in der Ausgangs-Zeichnung die gewünschten Objekte und ziehen diese mit gedrückter Maustaste einfach in das LayerManager-Fenster mit der Ziel-Zeichnung – das war's dann auch schon.

Eine detaillierte Darstellung des Übertragens von LayerManager-Daten in AutoCAD 2000(i) finden Sie im Kapitel "Drag-&-Drop-Operationen" .

siehe auch :

Erstellen einer LayerManager-Export-Datei

Importieren einer LayerManager-Export-Datei


Erstellen einer LayerManager-Export-Datei

Nutzen Sie die die Export-Funktion unter "Menü/Datei/Export". Sie werden lediglich nach dem Namen der Exportdatei (Typ "*.lmg" ist zwangsweise vorgeschrieben) gefragt und die Export-Datei wird mit allen Layergruppen und mit allen Hierarchien erzeugt. Zusätzlich werden auch alle Layer-Informationen aller derjenigen Layer mit in die Export-Datei geschrieben, welche NICHT in einer/mehreren Layergruppen verwendet werden. Sie können dann beim Import angeben, ob diese (nicht in Layergruppen verwendeten) Layer samt zugehöriger Infotexte und Eigenschaften ebenfalls importiert werden sollen.

Hinweis: Die Export-Funktion arbeitet generell nur und mit allen Layergruppen und Hierarchien; gewählte Layer, Layergruppen bzw. Hierarchien haben keinen Einfluss. Beim Import einer LayerManager-Export-Datei können Sie dann gezielt bestimmt werden, welche Layergruppen und Hierarchien importiert werden sollen.


Importieren einer LayerManager-Export-Datei

Um Layergruppen oder Hierarchien aus einer vorhandene Exportdatei in die Zeichnung zu importieren, rufen Sie die Import-Funktion unter "Menü/Datei/Import" auf; die Einstellung der beiden Anzeige-Fenster oder markierte Objekte haben für den Import keine Bedeutung. Sie werden zunächst aufgefordert, mit dem üblichen Dateiauswahl-Dialog eine Export-Datei (*.lmg oder *.lmt) von der Festplatte zu wählen. Nach der Auswahl wird diese vom LayerManager analysiert und die in der Exportdatei enthaltenen Layergruppen und Hierarchien im Import-Dialog zur Auswahl und Bestätigung angeboten.

Wichtiger Hinweis: Es können auch Dateien vom Typ “*.LMT" importiert werden – dies sind ganz normale Export-Dateien, jedoch werden sie nicht direkt mit der Export-Funktion erstellt – Sie können aber normale “*.LMG" Dateien entsprechend umbenennen oder eine “*.LMT"-Datei mit einem Editor erstellen – die “*.LMT"-Dateien sollen als nicht-überschreibbare Templates (Vorlagen) dienen.

Beschreibung des Import-Dialoges:

Beim Import können Sie exakt festlegen, welche Objekte in die Zeichnung importiert werden sollen; standardmäßig sind alle Objekte für den Import markiert, zu erkennen am angekreuzten Kästchen vor jedem Objekt. Mit einem Mausklick auf das Kontrollkästchen kann jedes Objekt angewählt oder abgewählt werden. Wird ein übergeordnetes Objekt ab-gewählt, so werden alle unter-geordneten ebenfalls ab-gewählt; wird ein unter-geordnetes Objekt angewählt, so wird das über-geordnete automatisch mit angewählt.

Schalter "Hierarchien"/"Layergruppen":

Steuert, ob der Import im Hierarchie-Modus oder im Layergruppen-Modus erfolgt;

Im Hierarchie-Modus sehen Sie die in der Exportdatei enthaltenen Hierarchien, Sub-Hierarchien sowie die jeweils enthaltenen Layergruppen – Sie können daher Hierarchien, Sub-Hierarchien und Layergruppen an- und abwählen, jedoch keine einzelnen Layer.

Im Layergruppen-Modus sehen Sie die in der Exportdatei enthaltenen Layergruppen sowie die darin enthaltenen Layer – Sie können daher die Layergruppen und Layer an- und abwählen, jedoch keine Hierarchien. Zusätzlich besteht aber die Möglichkeit, mit der Option "Importiere Hierarchien" auch den Import von Hierarchien zu aktivieren bzw. zu unterdrücken.

Auswahl "Bei vorhandenen Elementen":

Vorhandene behalten: bestehende LayerManager-Objekte werden nicht durch importierte überschrieben

Neue behalten: bestehende LayerManager-Objekte werden durch importierte überschrieben

Anfrage: für jedes bestehende LayerManager-Objekt erscheint eine Anfrage zu Behandlung

Diese Einstellung gilt nur für die zu importierenden Layergruppen und Hierarchien, nicht für Layer selbst.

Option "Importiere Hierarchien":

Diese Option ist nur aktiv, wenn Sie den Import im Layergruppen-Modus durchführen. Ist diese Option markiert, so werden auch im Layergruppen-Modus all jene Hierarchien ebenfalls importiert, in denen die zu importierenden Layergruppen benutzt werden (d.h. die minimal notwendigen); ist diese Option nicht markiert, so werden generell keine Hierarchien importiert.

Option "Importiere sonstige Layer":

In den Exportdateien sind ggf. auch alle Layer der Ursprungszeichnung gespeichert (mit ihren Eigenschaften), welche zum Zeitpunkt der Erstellung der Exportdatei nicht Bestandteil von Layergruppen waren, aber Bestandteil der Ursprungszeichnung. Ist die Option markiert, werden diese (Nicht-Layergruppen-)Layer ebenfalls importiert und in der aktuellen Zeichnung angelegt; anderenfalls werden nur jene Layer angelegt, die Bestandteil der Layergruppen sind. Sie können diese Option nutzen, um die Layer-Situation aus der Ursprungszeichnung vollständig in der aktuellen Zeichnung wiederherzustellen – ist dies nicht notwendig, so schalten Sie bitte diese Option aus.

Option "Originaler Layer-Zustand":

Alle in den Exportdateien aufgeführten Layer beinhalten zusätzlich auch alle Layer-Eigenschaften – dadurch besteht die Möglichkeit, einen importierten Layer auch dann, wenn der Layer bereits in der Zeichnung besteht, auf die in der Exportdatei angegebenen Layer-Eigenschaften (Linientyp, Farbe, Zustand etc.) einzustellen, und somit auch das ursprüngliche graphische Layout wiederherzustellen.

Option "Import: nur bestehende Layer":

Ist diese Option aktiviert, so filtert und verwendet der LayerManager nur diejenigen Layer aus der Import-Export-Datei, welche bereits in der Zeichnung bestehen – alle sonstigen Layer werden nicht importiert. Dies hat insgesamt 2 Effekte:

  1. die importierten Layergruppen nutzen ebenfalls nur bestehende Layer, sonstige werden nicht genutzt

  2. zusammen mit der Option "Originaler Layer-Zustand" können die bestehenden Zeichnungs-Layer bzgl. ihrer Eigenschaften auf jene aus der Import-Export-Datei abgeglichen werden

Umbenennen von Objekten vor dem Import:

Sind in der Export/Import-Datei Layergruppen und/oder Hierarchien enthalten, welche in der aktuellen Zeichnung bereits vorhanden sind, so werden solche Objekte mit einem roten Icon angezeigt – Sie erkennen diese Objekte also sehr schnell, Alle angezeigten Layergruppen/Hierarchien können problemlos umbenannt werden – markieren Sie dazu das entsprechende Objekt und klicken ein zweites Mal darauf – es öffnet sich das übliche Editierfeld, und Sie können einen neuen Namen vergeben (entsprechend wird dadurch ein rotes Icon wieder weiß, um zu signalisieren, daß ein derartiges Objekt noch nicht besteht)


Layer-Listings erstellen

Für die verschiedensten Zwecke sinnvoll und oft benötigt ist eine Datei, welche die Layer einer Zeichnung auflistet. Unter "Menü/Bearbeiten/Layer/Layerliste in Datei" kann eine solche Layer-Liste in eine wählbare Datei, mit einstellbaren Angaben zu den Layern, erstellt werden. Wählen Sie bitte vor dem Aufruf der Layer-Listing-Funktion diejenigen Layer, Layergruppen und / oder Hierarchien aus, deren Layer in der Listing-Datei protokolliert werden sollen.

Neben der Festlegung der Listingdatei können Sie einstellen, welche der folgenden Eigenschaften für jeden Layer in der Listing-Datei angegeben werden sollen:

Farbe und Linientyp, Sichtbarkeit (Ein/Aus, Gefroren/Getaut), Plot-Status und Plot–Stil, Linienstärke, Layer-Beschreibungstext, Zugehörigkeit zu Layergruppen und Hierarchien


WBlocks erstellen

Eine sehr effektive Methode, WBlocks zu erstellen, finden Sie unter "Menü/Extras/WBlock" und in der ToolBar "Extras". Die WBlock-Funktion des LayerManagers ermöglicht es, die Zeichnungselemente, welche sich auf den gewählten Layern, oder auch auf den Layern gewählter Layergruppen und/oder Hierarchien, befinden, als WBlock-Zeichnung zu speichern.

Das heißt, Sie wählen nicht mehr die Zeichnungselemente selbst, sondern nutzen die Layer, Layergruppen und Hierarchien, um die WBlock-Zeichnung mit den Zeichnungselementen auf den enthaltenen/gewählten Layern zu erstellen. Wählen Sie bitte vor dem Aufruf der WBlock-Funktion diejenigen Layer, Layergruppen und / oder Hierarchien aus, deren Zeichnungselemente als WBlock gespeichert werden sollen. Dabei können Sie Hierarchien, Layergruppen und Layer beliebig gemischt wählen – der LayerManager ermittelt automatisch die Gesamtheit aller Layer und die darauf befindlichen Zeichnungselemente.

Nach dem Speichern der WBlock-Zeichnung erhalten Sie eine Anfrage, ob die als WBlock gespeicherten Zeichnungselemente in der Zeichnung wieder restauriert werden sollen. Es wird auch die Anzahl der im WBlock gespeicherten Elemente angegeben.

Hinweis: Haben Sie ausschließlich Layergruppen bzw. Hierarchien gewählt, so erscheint zusätzlich eine Anfrage, ob auch die Layergruppen-/Hierarchie-Daten im WBlock mitgespeichert werden sollen – mit dem Effekt, daß die WBlock-Zeichnung auch die entsprechenden LayerManager-Daten enthält.
Hinweis: Im Gegensatz zu AutoCAD können die betreffenden Layer problemlos auch ausgeschaltet oder gefroren sein – die Zeichnungselemente werden nicht graphisch, sondern über die Layernamen in der Zeichnungs-Datenbank ermittelt.


Auswahlsatz erstellen

Eine weiteres Hilfsmittel zur Zeichnungssteuerung finden Sie unter "Menü/Extras/Auswahlsatz erzeugen" sowie in der ToolBar "Extras/Auswahlsatz erstellen": hiermit bietet der LayerManager die Möglichkeit, Auswahlsätze basierend auf Layern, Layergruppen und Hierarchien zu erstellen, und diese dann in der Zeichnung anzuwenden bzw. einzusetzen.

Wählen Sie bitte vor dem Aufruf der Auswahlsatz-Funktion diejenigen Layer, Layergruppen und / oder Hierarchien aus, deren Zeichnungselemente den Auswahlsatz bilden sollen. Dabei können Sie Hierarchien, Layergruppen und Layer beliebig gemischt wählen – der LayerManager ermittelt automatisch die Gesamtheit aller Layer und der darauf befindlichen Zeichnungselemente.

Anwendung des erstellten Auswahlsatzes: Sie können den erstellten Auswahlsatz mit jedem AutoCAD-Befehl und auch mit jedem Befehl aus ADS/ARX/AutoLISP-Programmen verwenden.

Geben Sie bei der Objektwahl-Anfrage "Objekte wählen:" bitte ein: "!LMSET" oder "VORHER", falls Sie eine Fehlermeldung erhalten.

Hinweis: Im Gegensatz zu AutoCAD können die betreffenden Layer problemlos auch ausgeschaltet oder gefroren sein – die Zeichnungselemente werden nicht graphisch, sondern über die Layernamen in der Zeichnungs-Datenbank ermittelt.


BKS zuordnen

Ein weiteres Hilfsmittel zur Handhabung von 3D-Zeichnungen ermöglicht es, zusammen mit einer Layergruppe auch ein bestimmtes Benutzer-Koordinatensystem (BKS) automatisch zu aktivieren. Um einer Layergruppe solch ein BKS zuzuordnen, wählen Sie bitte die entsprechende Layergruppe (als alleinige Auswahl) in einem der beiden Anzeige-Fenster aus.

Starten Sie nun die Funktion "Menü/Extras/Zugeordnetes BKS" aus dem Pulldown-Menü; die View-Funktion ist ebenfalls in der ToolBar "Extras/BKS zuordnen" vorhanden.

LaymanPro zeigt Ihnen dann alle in der Zeichnung definierten BKS; Sie können eines davon wählen und dieses der Layergruppe zuordnen. Gleichzeitig kann ein zugeordnetes BKS auch gelöst bzw. geändert werden.

Wenn Sie später genau eine Layergruppe anwählen und diese mit "Aktivieren" aktivieren, so setzt LaymanPro auch ein ggf. mit der Layergruppe verbundenes BKS (nach Anfrage) aktiv.

Hinweis: wenn Sie mehrere Objekte wählen, so steht die Funktion nicht zur Verfügung (aus Gründen der Eindeutigkeit); wählen Sie daher immer 1 Layergruppe aus, um die BKS-Funktion anzuwenden.


3D-View zuordnen

Insbesondere bei 3D-Zeichnungen kann es sehr sinnvoll sein, zusammen mit einer Layergruppe auch einen bestimmten 3D-View (benannte Ansicht) automatisch zu aktivieren. Um einer Layergruppe solch eine benannte Ansicht zuzuordnen, wählen Sie bitte die entsprechende Layergruppe (als alleinige Auswahl) in einem der beiden Anzeige-Fenster aus.

Starten Sie nun die Funktion "Menü/Extras/Zugeordneter View" aus dem Pulldown-Menü; die View-Funktion ist ebenfalls in der ToolBar "Extras/View zuordnen" vorhanden.

LaymanPro zeigt alle in der Zeichnung definierten Ansichten; Sie können eine davon wählen und diese der Layergruppe zuordnen. Andererseits kann eine zugeordnete Ansicht auch gelöst bzw. geändert werden.

Wenn Sie später genau eine Layergruppe anwählen und diese mit "Aktivieren" aktivieren, so setzt LaymanPro auch eine ggf. mit der Layergruppe verbundene Ansicht (nach Anfrage) aktiv.

Hinweis: wenn Sie mehrere Objekte wählen, so steht die Funktion nicht zur Verfügung (aus Gründen der Eindeutigkeit); wählen Sie daher immer 1 Layergruppe aus, um die View-Funktion anzuwenden.


3D-Orbit-View

(nur ab AutoCAD 2000)

Eine besonders leistungsfähige Funktion wird mit dem 3D-Orbit-View geboten – im Gegensatz zu AutoCAD finden Sie den Orbit hier in einem eigenen, beliebig skalierbaren Fenster wieder – parallel zu AutoCAD ! Nach dem Öffnen zeigt der 3D-Orbit-View stets die gesamte Zeichnung: positionieren Sie zuerst den gewünschten Bildbereich und stellen den Anzeige-Modus ein. Der 3D-Orbit-View arbeitet stets synchron zur Zeichnung, alle neu erstellten Elemente werden sofort gezeigt, gelöschte Elemente entsprechend entfernt.

Mit dem "Online/Offline"-Schalter bietet der 3D-Orbit-View die Möglichkeit, Ihre im LayerManager-Fenster aktive Auswahl zu zeigen - werden im linken/rechten Fenster Objekte (in beliebiger Kombination) markiert, so zeigt der 3D-Orbit-View den Zeichnungs-Inhalt der beinhalteten Layer in Echtzeit an – Sie erhalten somit einen sofortigen Einblick auf den Inhalt der markierten Objekte, ohne die Zeichnung selbst zu beeinflussen !

Spezieller Anzeige-Modus: sind im LayerManager keine Objekte markiert, so ist bereits das "Berühren" der Layer, Layergruppen, Hierarchien mit dem Mauszeiger ausreichend, um den Inhalt des Objektes zu sehen (wenn sich der 3D-Orbit-View im "Online" Modus befindet) !

Sie finden den 3D-Orbit-View unter "Menü/Ansicht/3D-View" im Pulldown- bzw. Kontext-Menü.

Klappliste "Modus": Auswahl des Darstellungsmodus

Winkel-Anzeige: zeigt die Winkel in und über der XY-Ebene

Online/Offline: setzt die Direkt-Anzeige der Layer aktiv bzw. inaktiv

Button "O" (rot): lädt die Zeichnung neu

Button "<<": aktuelle Zeichnungs-Ansicht in den 3D-Orbit-View übertragen

Button "<": Referenz-Punkt (Blickpunkt) in der Zeichnung picken (Ofang)

Button ">": Ansicht aus dem 3D-Orbit-View in die Zeichnung übertragen

Schiebe-Regler: zur der Einstellung des horizontalen (unten) bzw. vertikalen (links) Blickwinkels sowie des Zoom-Faktors (rechts)

Bedienungs-Hinweise:

Orbit-Rotieren: linke Maustaste

Pan: rechte Maustaste

Zoom: rechte Maustaste + STRG-Taste

Der 3D-Orbit-View startet stets mit dem zuletzt benutzten Render-Modus und mit der zuletzt verwendeten Größe und Position – sehr komfortabel insbesondere für Doppel-Monitor-Systeme …

Hinweis: Der LayerManager verwendet für jede Zeichnung einen separaten 3D-Orbit-View, um nicht bei jedem Zeichnungs-Wechsel eine Re-Initialisierung des 3D-Orbit-Views durchführen zu müssen. Das heißt, das 3D-Orbit-Fenster ist nicht je LayerManager-Fenster, sondern je Zeichnung vorhanden, so daß sich auch mehrere LayerManager-Fenster einen 3D-Orbit-View teilen können.

Hinweis: Nutzen Sie mehrere Zeichnungen, und ggf. auch mehrere LayerManager-Fenster, parallel, so können Sie problemlos mehrere 3D-Orbit-Views öffnen : dadurch haben Sie die Möglichkeit, auch die nicht-aktiven Zeichnungen (im Hintergrund) zu betrachten, indem Sie ein entsprechendes Layer-Manager-Fenster auf die Zeichnung einstellen, und dann die gewünschten Objekte markieren bzw. mit der Maus "berühren".

Hinweis: Beim ersten Öffnen des 3D-Orbit-Views wird dieser auf die entsprechende Zeichnung initialisiert – dies kann je nach Zeichnungsgröße einen Moment (oder auch 2…) dauern. Sie können den 3D-Orbit-View jedoch problemlos schließen – beim erneuten Öffnen des 3D-Orbit-View entfällt diese Initialisierung (das 3D-Orbit-Fenster wird nur "unsichtbar" gesetzt).


Spezielle Funktionen - Layer-History

Layer-History

Mit der "Layer-History" bietet der LayerManager eine weitere, sehr flexible und leistungsstarke Funktion an: auf Knopfdruck können Sie den aktuellen Sichtbarkeits-Zustand der Zeichnungs-Layer als "benannte Layer-History" speichern – und zu einem beliebigen Zeitpunkt später wieder exakt restaurieren. Damit besteht eine elegante Möglichkeit, die momentane Layer-Situation im Sinne eines "SchnappSchusses" schnell und einfach zu speichern und jederzeit wiederherzustellen, ohne daß Layergruppen und Hierarchien definiert werden müssen. Die Layer-History stellt eine ideale Ergänzung zum Prinzip der Layergruppen/Hierarchien dar – und ist primär zum Speichern/Restaurieren "temporärer" oder auch sehr komplexer, mit Layergruppen und Hierarchien nur aufwendig zu realisierender Zeichnungs-Zustände gedacht.

In der Layer-History wird generell nur die Layer-Sichtbarkeit gespeichert (Zustand Ein/Aus, Gefroren/Getaut etc.) – selbstverständlich inklusive der Zugehörigkeit zu Modellbereich, Papierbereich, Layout und Viewport ! Somit wird durch das Restaurieren auch für ein Papierbereichs-Layout exakt die gespeicherte Layer-Situation wiederhergestellt.

Der LayerManager verwaltet alle Layer-History-Einträge nach deren Zugehörigkeit zu Modellbereich, Papier-bereich bzw. Layouts – wechseln Sie von einem Layout zu einem anderen, wechselt auch der Inhalt der History-Liste entsprechend dem aktuellen Bereich/Layout.

Handhabung und Anwendung: haben Sie Ihre Zeichnung aktuell in einem Zustand, welchen Sie aufheben möchten, so speichern Sie diesen einfach mit dem Icon-Button, und geben dieser Layer-History-Position einen Namen. Nun können Sie in der weiteren Bearbeitung die Zeichnungs-Layer ohne Bedenken ändern – bei Bedarf restaurieren Sie die gespeicherte Layer-History-Position wieder, ohne daß Ihre Bearbeitung dadurch rückgängig gemacht wird …

Für die Layer-History-Verwaltung stehen alle üblichen Funktionen bereit – so können History-Einträge gelöscht und deren Info-Texte umbenannt werden. Die Aktualisierung bestehender Einträge ist ebenfalls möglich.

Mit den Funktionen "Vorherige Position" und "Nächste Position" können Sie durch die Liste der History-Einträge navigieren – die Übersichts-Liste zeigt alle Einträge direkt an.

Das Kontext-Menü steht identisch für alle 4 Layer-History-Buttons in der Statuszeile zur Verfügung – einfach die rechte Maustaste drücken …

Sobald sich der Mauszeiger auf einem der 4 Layer-History-Buttons befindet, wird der Info-Text der aktuellen Position in der Statuszeile angezeigt.

Beschreibung der Layer-History-Buttons:

"Position wählen und restaurieren" : öffnet die Übersichtsliste und restauriert die gewöhlte Position

"Vorherige Position" : scrollt in der Layer-History eine Position zurück (ohne Restaurieren !)

"Aktuellen Zustand speichern" : aktuellen Zustand der Zeichnungs-Layer speichern

"Nächste Position" : scrollt in der Layer-History eine Position vorwärts (ohne Restaurieren !)

"Position restaurieren": restauriert die angezeigte Layer-History-Position (Anzeige: Aktuell/Gesamt))

Hinweis: Sobald sich der Mauszeiger auf einem der Layer-History-Buttons befindet, wird in der Statuszeile der Info-Text des aktuell positionierten Layer-History-Eintrages angezeigt.

Hinweis: alle Layer-History-Positionen werden direkt und dauerhaft in der Zeichnung gespeichert, und stehen mit dem nächsten Öffnen der Zeichnung wieder zur Verfügung.

Gespeicherte Layer-Histories lassen sich zudem in andere Layouts bzw. in andere Zeichnungen übertragen – hierzu stehen die Transfer- und die Import-/Export-Funktionen bereits. Insbesondere bei der Konfiguration weiterer, ähnlicher Layouts kann so enorm Zeit gespart und die Anwendungs-Sicherheit verbessert werden.

siehe auch :

Layer-History übertragen

Export und Import von Layer-Histories


Layer-History übertragen

Mit "History übertragen" steht eine Methode bereit, um History-Positionen und Layout-abhängige Layer-Eigenschaften innerhalb der Zeichnung zwischen Layouts zu übertragen.

Unabhängig davon, in welchem konkreten Layout Sie sich befinden, ermöglicht der Dialog das Kopieren von History-Positionen und Layout-abhängiger Layer-Eigenschaften für alle in der Zeichnung bestehenden Layouts.

Optional kann die zu kopierenden History-Position im Ziel-Layout auch mit einem anderen Namen erstellt werden, um Kollisionen zu vermeiden.

Das Listenfeld zeigt im Ziel-Layout bestehende History-Positionen an, um die Orientierung zu erleichtern.

Ist ein Ziel-Layout bestimmt, wird der Options-Schalter aktiv, um das Übertragen der Layout-abhängigen Layer-Eigenschaften zu aktivieren.


Export und Import von Layer-Histories

Export von Layer-Histories :

Um die definierten Layer-Histories zu exportieren wählen Sie einfach die Funktion "Export History" aus dem Kontextmenü – nach der Bestimmung des Dateinamens werden alle History-Positionen aus allen Layouts gespeichert, unabhängig davon, in welchem konkreten Layout Sie sich befinden. Nach der Erstellung der Export-Datei erscheint lediglich ein kurzer Hinweis zur erfolgreichen Speicherung.

In der Export-Datei werden ausserdem für alle Layouts die Layout-abhängigen Layer-Eigenschaften gespeichert, so daß Sie auch diese Layer-Eigenschaften in andere Zeichnungen importieren können.

Import von Layer-Histories :

Die Import-Funktion ermöglicht es Ihnen, gespeicherte Layout-Konfigurationen inklusive der zugehörigen Layout-abhängigen Layer-Eigenschaften in andere Zeichnungen zu importieren. Nach dem Aufruf der Funktion "Import History" aus dem Kontextmenü öffnet sich zunächst der übliche Dateiauswahl-Dialog zur Bestimmung der zu importierenden Datei – diese wird geladen und alle enthaltenen Definitionen im Import-Dialog zur detaillierten Bestimmung der zu importierenden Layer-History-Positionen dargestellt.

Rote Icons: alle Positionen, welche in einem Layout bereits vorhanden sind, werden mit einem roten Icon gekennzeichnet. Durch ein zweifaches Anklicken des Names können Sie die entsprechende Position bei Bedarf direkt umbenennen um Kollisionen zu vermeiden. Das Icon wird ggf.. wieder normal dargestellt.

Zusätzlich können Sie bestimmen, für welche Layouts die gespeicherten Layout-abhängigen Layer-Eigenschaften importiert werden sollen

Alle Layouts anzeigen: ist diese Option aktiv, werden alle in der Import-Datei enthaltenen Layouts angezeigt – anderenfalls nur diejenigen Layouts, welche auch in der Zeichnung vorhanden sind. Positionen aus nicht angezeigten Layouts werden nicht importiert !

Mit "Importiere >>>" erfolgt dann die Übernahme der markeirten Elemente in die aktuelle Zeichnung.

Hinweis: Sie können auch History-Positionen aus nicht bestehenden Layouts (sozusagen "auf Vorrat") importieren – sobald ein solches Layout erstellt wird, stehen auch die entsprechenden History-Positionen wieder zur Verfügung; alternativ können Sie aber auch den Import wiederholen.


Spezielle Funktionen - Layout-abhängige Layer-Eigenschaften

Layout-abhängige Layer-Eigenschaften

Ab Version v4.1 bietet der LayerManager die "Layout-abhängigen Layer-Eigenschaften" als leistungsstarkes Merkmal zur Unterstützung des Anwenders bei der Arbeit mit Modellbereich, Papierbereich und Layouts an.

Grundlagen: AutoCAD nutzt für jeden Layer nur globale Layer-Eigenschaften, wodurch sich Layouts stets gegenseitig beeinflussen – hier setzt der LayerManager an: für alle Modell-/Papierbereiche und für alle Layouts speichert der LayerManager komplett die aktuell verwendeten Layer-Eigenschaften, um diese (konfigurierbar) im jeweiligen Bereich automatisch wieder zu restaurieren. Beim Verlassen eines Bereiches/Layouts erfolgt die Speicherung der aktuell eingestellten Layer-Eigenschaften, beim Eintritt in einen anderen Bereich/Layout wird dieser mit seinen spezifischen Eigenschaften automatisch wieder restauriert.

Schnellen Zugriff auf die Aktivierung/Deaktivierung der "Layout-abhängigen Layer-Eigenschaften" und der zu restaurierenden Eigenschaften bietet diese Toolbar.

Wechselt der Anwender in einen anderen Bereich, werden dessen zuletzt verwendeten Layer-Eigenschaften wieder eingestellt – Voraussetzung ist die Aktivierung der Option "M-P-Bereich automatisch restaurieren" (Konfiguration bzw. Toolbar). Einstellbar ist auch, welche Layer-Eigenschaften restauriert werden sollen.

Hinweis: Das bisherige Verfahren zur separaten Steuerung (ausschließlich) der Layer-Sichtbarkeit in M-/P-Bereich und Layouts wurde komplett durch dieses, umfassendere Verfahren ersetzt.


Funktionen mit Zeichnungselementen

Sehr hilfreiche Funktionen zur Handhabung von Zeichnungs-Elementen finden Sie im Pulldown-Menü unter "Menü/Extras/Zeichnungselemente" und in der ToolBar "Extras". Allen gemeinsam ist, daß der Anwender beliebig Layer, Layergruppen und/oder Hierarchien (auch in Kombination) wählen kann – LaymanPro ermittelt automatisch die Gesamtheit aller (enthaltenen) Layer und der darauf befindlichen Elemente und wendet die entsprechende Funktion dann auf diese Zeichnungs-Elemente an..

Bei allen Funktionen wird automatisch ein Auswahlsatz der betreffenden Elementen gebildet, den Sie später mit AutoCAD-Befehlen nutzen können ( "Auswahlsatz erstellen" ). Alle nachfolgenden Funktionen arbeiten zwar auch mit XRef-Layern, jedoch werden dort keine Elemente gefunden !

siehe auch :

Elemente anzeigen

Elemente auf Layer kopieren

Elemente auf Layer verschieben

Elemente in Vordergrund setzen

Elemente in Hintergrund setzen

Elemente auf Farbe setzen

Elemente auf Linientyp setzen

Elemente auf Linienstärke setzen

Elemente auf Plotstil setzen


Elemente anzeigen

Die Funktion "Elemente anzeigen" ("Menü/Extras/Zeichnungselemente/Anzeigen") ermöglicht eine sehr schnelle Anzeige der Zeichnungselemente, welche sich auf den gewählten Objekten (Layer, Gruppen, Hierarchien) befinden.

Die Anzeige der Elemente erfolgt hierbei auf leerem Bild-Hintergrund ohne Änderung des Zoom-Faktors im Bild. Es erscheint zusätzlich eine Meldung über die Anzahl der insgesamt gefundenen Zeichnungselemente. Nach Bestätigung der Meldung wird die ursprüngliche Zustand der Zeichnung wiederhergestellt.


Elemente auf Layer kopieren

Die Funktion "Elemente kopieren" ("Menü / Extras / Zeichnungselemente / Kopieren auf Layer") ermöglicht das Duplizieren der Zeichnungselemente, welche sich auf den gewählten Objekten (Layer, Layergruppen, Hierarchien) befinden, auf einen wählbaren Ziellayer.

Nach Aufruf der Funktion erscheint der bekannte Objektwahl-Filter zur Auswahl eines Layers, auf welchen die Zeichnungselemente kopiert werden.


Elemente auf Layer verschieben

Die Funktion "Elemente verschieben" ("Menü / Extras / Zeichnungselemente / Verschieben auf Layer") ermöglicht das Verschieben der Zeichnungselemente, welche sich auf den gewählten Objekten (Layer, Layergruppen, Hierarchien) befinden, auf einen wählbaren Ziellayer.

Nach Aufruf der Funktion erscheint der bekannte Objektwahl-Filter zur Auswahl eines Layers, auf welchen die Zeichnungselemente kopiert werden.


Elemente in Vordergrund setzen

Die Funktion "Elemente in Vordergund" ("Menü/Extras/Zeichnungselemente/in Vordergrund") bietet die Möglichkeit, alle Zeichnungselemente, welche sich auf den gewählten Objekten (Layer, Layergruppen, Hierarchien) befinden, in den Zeichnungs-Vordergrund zu setzen (wie "Ganz oben" im AutoCAD-Menü).

Hinweis: Es kann (selten) vorkommen, daß die Funktion "Vordergrund" keinen Erfolg zeigt; Ursache ist das teilweise instabile Verhalten von AutoCAD bzgl. Vordergrund/Hintergrund. Versuchen Sie es mit der AutoCAD-Funktion, und geben am Prompt "Objekte wählen:" ein: <Vorher> oder <!LMSET>.

Hinweis: "Elemente in Vordergrund" steuert im Gegensatz zur Funktion "Anzeige-Reihenfolge" lediglich die Zeichnungselemente der markierten Objekte !


Elemente in Hintergrund setzen

Die Funktion "Elemente in Vordergund" ("Menü/Extras/Zeichnungselemente/in Hintergrund") bietet die Möglichkeit, alle Zeichnungselemente, welche sich auf den gewählten Objekten (Layer, Layergruppen, Hierarchien) befinden, in den Zeichnungs-Hintergrund zu setzen (wie "Ganz unten" im AutoCAD-Menü).

Hinweis: Es kann (selten) vorkommen, daß die Funktion "Vordergrund" keinen Erfolg zeigt; Ursache ist das teilweise instabile Verhalten von AutoCAD bzgl. Vordergrund/Hintergrund. Versuchen Sie es mit der AutoCAD-Funktion, und geben am Prompt "Objekte wählen:" ein: <Vorher> oder <!LMSET>.

Hinweis: "Elemente in Hintergrund" steuert im Gegensatz zur Funktion "Anzeige-Reihenfolge" lediglich die Zeichnungselemente der markierten Objekte !


Elemente auf Farbe setzen

Die Funktion "Elemente auf Farbe setzen" ("Menü/Extras/Zeichnungselemente") bietet die Möglichkeit, alle Zeichnungselemente, welche sich auf den gewählten Objekten (Layer, Layergruppen, Hierarchien) befinden, expliziet auf einen bestimmten Farbwert oder auch auf "VonLayer" zu setzen.


Elemente auf Linientyp setzen

Die Funktion "Elemente auf Linientyp setzen" ("Menü/Extras/Zeichnungselemente") bietet die Möglichkeit, alle Zeichnungselemente, welche sich auf den gewählten Objekten (Layer, Layergruppen, Hierarchien) befinden, expliziet auf einen bestimmten Linientyp oder auch auf "VonLayer" zu setzen.


Elemente auf Linienstärke setzen

Die Funktion "Elemente auf Linienstärke setzen" ("Menü/Extras/Zeichnungselemente") bietet die Möglichkeit, alle Zeichnungselemente, welche sich auf den gewählten Objekten (Layer, Layergruppen, Hierarchien) befinden, expliziet auf einen bestimmten Linienstärke oder auch auf "Vorgabe" zu setzen.


Elemente auf Plotstil setzen

Die Funktion "Elemente auf Plotstil setzen" ("Menü/Extras/Zeichnungselemente") bietet die Möglichkeit, alle Zeichnungselemente, welche sich auf den gewählten Objekten (Layer, Layergruppen, Hierarchien) befinden, expliziet auf einen bestimmten Plotstil zu setzen, sofern sich die Zeichnung nicht im Modus "farbabhängiges Plotten" befindet).


LayerManager Re-Initialisieren

Unter Umständen kann es sinnvoll sein, den LayerManager neu zu initialisieren. Die Re-Initialisierung ist immer dann angebracht, wenn neue LAYMAN-Daten in die aktuelle Zeichnung "von aussen" eingebracht wurden; wenn also Daten auf dem Layer "$LAYMAN" nicht vom LayerManager selbst modifiziert worden sind. Bei der Re-Initialisierung werden alle LayerManager-Daten komplett neu aus der Zeichnung ausgelesen. Zugleich wird mit der Re-Initialisierung eine Konsistenzprüfung gestartet; diese deckt Diskrepanzen zwischen den LayerManager-Daten und den in der Zeichnung vorhandenen Daten auf, und bietet entsprechende Behandlungs-Möglichkeiten.

Normalerweise sollte die Programm-Option "Rx-Automation aktivieren" eingeschaltet sein, so daß LaymanPro alle relevanten Vorgänge in der Zeichnung verfolgen kann – ist diese Option eingeschaltet, so wird eine Re-Initialisierung höchst selten erforderlich sein. Ist die Option "Rx-Automation aktivieren" nicht eingeschaltet, so wird die Re-Initialisierung empfohlen:

  1. nach DXFIN

  2. nach EINFÜGE/aufgelöst

  3. wenn LayerManager-Daten in XRef-Zeichnungen modifiziert wurden

  4. wenn Blöcke mit Layergruppen re-definiert und diese neu in die Zeichnung eingefügt werden

Eingefügte Blöcke und XRefs erkennt LaymanPro normalerweise automatisch und durchsucht diese einmalig nach Layergruppen/Hierarchie-Daten; ändern sich später die in den Blöcken und XRefs enthaltenen Layergruppen-Daten, so würde LaymanPro diese Änderungen nicht mehr automatisch erkennen (um Zeit zu sparen) - in diesen Fällen ist eine Re-Initialisierung ebenfalls notwendig, um wieder alle Layergruppen/Hierarchien-Daten in der Zeichnung zu aktualisieren.

Beim Start der "Re-Initialisierung" geben Sie an, ob auch Blöcke und Xrefs nach LayerManager-Daten durchsucht werden sollen – wenn Sie sicher sind, daß die verwendeten Blöcke keine LayerManager-Daten enthalten, so können Sie die Option "Blöcke" abschalten; Gleiches gilt analog auch für XRefs.

Hinweis: die Optionen zum Durchsuchen von Blöcken und XRefs werden deaktiviert (ausgegraut), wenn keine Blöcke bzw. XRefs vorhanden sind.

Sie finden diese Funktion ausschließlich unter "Menü/Datei/Re-Initialisierung".


LayerManager-Daten bereinigen

Die Funktion entfernt unbenutzte Layer aus den Layergruppen – dies ist Voraussetzung für den AutoCAD-Befehl "Bereinig"; solange unbenutzte Layer in Layergruppen enthalten sind, kann der "Bereinig"-Befehl diese nicht entfernen. "Unbenutzt" bedeutet, daß auf dem Layer keine Zeichnungselemente vorhanden sind. Möchten Sie solche unbenutzten und leeren Layer mit dem Bereinig-Befehl aus der Zeichnung entfernen lassen, so nutzen Sie diese Funktion im LayerManager unter "Menü/Extras/Bereinigen".

Die "Bereinigen"-Funktion zeigt zunächst diese Anfrage: Sie können mit dem Kontrollkästchen einstellen, ob für jeden ungenutzten Layer die Anfrage zum Entfernen des Layers aus den Layergruppen erscheinen soll. In diesem Fall erscheint eine Anfrage für jeden einzelnen Layer.


LayerManager-Daten entfernen

Die in der Zeichnung (auf dem Layer "$LAYMAN") gespeicherten LayerManager-Daten sind zum einen graphisch unsichtbar, zum anderen für AutoCAD und andere Applikationen völlig normale Zeichnungselemente – dadurch sind keinerlei negative Auswirkungen auf die Zeichnung zu befürchten. Jedoch mag es im konkreten Fall (z.B. Datenaustausch via DXF oder Ähnliches) notwendig sein, die LayerManager-Daten aus der Zeichnung vollständig zu entfernen – hierzu dient diese Funktion, welche Sie unter "Menü/Extras/Entferne Daten" finden. Damit werden alle LayerManager-Daten gelöscht und das Programm automatisch beendet.

Danach speichern und schließen Sie die Zeichnung, und öffnen Sie diese bitte erneut. Nutzen Sie dann den AutoCAD-Befehl "Bereinig", und bereinigen Sie damit

  1. zuerst: die Blöcke "Layman$MS_*" und "Layman$PS_*" (bitte mit Wildcard "*")

  2. dann den Layer "$LAYMAN"
Es erscheint eine Sicherheits-Anfrage zum Entfernen der LayerManager-Daten. Hierbei können optional (duch Setzen des Kontrollkästchens) vor dem Löschen die aktuellen Layer-Manager-Daten in eine "Export"-Datei (im Sinne eines Backup) gesichert werden.


Allgemeines

Für viele Bearbeitungsvorgänge ist die "Drag-&-Drop"-Technik (dt. "Ziehen und Loslassen") eine sehr effektive Methode – werden doch Ausgangsobjekt(e) und Zielobjekt(e) bereits im Vornherein bestimmt. So sind vor allem die Funktionen zur Zeichnungs-Strukturierung (wie Neuerstellen, Einfügen, Verschieben etc.), aber auch die Funktionen bzgl. der Zeichnungselemente (Elemente von Layern, Gruppen, Hierarchien auf Ziellayer kopieren/verschieben etc.) sehr elegant und einfach über Drag-&-Drop nutzbar. Entscheidend für den Drag-&-Drop-Vorgang und die im Drag-&-Drop-Menü angezeigten Funktionen sind Art und Anzahl der Ausgangsobjekte und des Zielobjektes.

Der LayerManager unterstützt Drag-&-Drop in folgenden Varianten:

· 1. innerhalb des gleichen Anzeige-Fensters

· 2. zwischen den Anzeige-Fenstern eines LayerManager-Fensters

· 3. zwischen den LayerManager-Fenstern

Durchführung von Drag-&-Drop-Operationen:

Den Drag-&-Drop-Vorgang können Sie mit der rechten wie auch mit der linken Maustaste ausführen – klicken Sie auf eines der bereits markeirten Objekte, halten die Maustaste gedrückt und bewegen den Mauszeiger auf das Ziel-Objekt bzw. in das Zielfenster. Während des Ziehens mit der Maus erscheint am Cursor ein kleines ToolTip-Fähnchen mit Hinweisen zu möglichen Zielobjekten; in Abhängigkeit von Ausgangs- und Zielobjekt(en) variiert die Form des Mauszeigers. Befindet sich der Mauszeiger auf einem erlaubten Ziel, so wird dieses mit der (meist blauen) Auswahl-Markierung hinterlegt. Beim Loslassen der Maustaste auf dem Ziel bzw. im Ziel-Fenster erscheint generell ein Drag-&-Drop-Kontextmenü mit den möglichen Funktionen. In diesem Kapitel werden alle verfügbaren Drag-&-Drop-Operationen beschrieben. Die Aufstellung erfolgt entsprechend der gewählten Ausgangsobjekte – getrennt in Kapitel für "Drag-&-Drop mit Layern", "Drag-&-Drop mit Layergruppen", "Drag-&-Drop mit Hierarchien" sowie "Drag-&-Drop zwischen Zeichnungen".

Hinweis: in AutoCAD 2000(i) ist Drag-&-Drop auch zwischen verschiedenen Zeichnungen möglich, welche den LayerManager-Fenstern zugeordnet sind – die eleganteste Methode, LayerManager-Daten zwischen den Zeichnungen zu übertragen.

Hinweis: Drag-&-Drop finden Sie auch in "Strukturierung der Zeichnung" und "Steuerung der Zeichnung" erklärt.


Drag-&-Drop mit Layern

Markieren Sie zunächst die gewünschten Objekte; klicken dann mit der Maustaste erneut auf ein markiertes Objekt, halten die Taste gedrückt und bewegen diese dann auf ein Ziel-Objekt bzw, in das Ziel-Fenster.

Hinweis: "Ziel-Fenster" ist der leere Bereich eines Fensters, d.h. der Mauszeiger ist nicht auf einem Objekt ! Alle dargestellten Drag-&-Drop-Methoden arbeiten innerhalb eines LayerManager-Fensters !

Folgende Ziel-Objekte bzw. Ziel-Fenster sind für "gezogene" Layer möglich:

Objekt: Layer | "Layer kopieren" bzw. "Layer klonen", bei mehreren Ausgangs-Objekten "Zeichnungs-Elemente kopieren" auf Ziel-Layer und "Zeichnungs-Elemente verschieben" auf Ziel-Layer
Objekt: Layergruppe (es können auch mehrere Gruppen zuvor markiert sein) | Der/die Ausgangs-Layer werden in die Ziel-Layergruppe bzw. in alle markierten Layergruppen eingefügt ("Layergruppe erweitern")
Objekt: Hierarchie (es können auch mehrere Hierarchien zuvor markiert sein) | Mit der/den Ausgangs-Layern wird eine neue Layergruppe gebildet und diese in die Ziel-Hierarchie bzw. in alle markierten Hierarchien eingefügt ("Hierarchien erweitern")
Fenster: Alle Layer Fenster: Aktive Layer Fenster: Nicht aktive Layer | Wie "Objekt: Layer"; bei "Zeichnungs-Elemente kopieren/verschieben" erscheint der Layer-Auswahldialog zur Bestimmung eines Ziel-Layers, da ja kein Ziel-Layer als Drag-&-Drop-Ziel gezeigt wird.
Fenster: Abhängige Layer | Wie "Objekt: Layergruppe"; d.h. es werden die Ausgangs-Layer stets in alle markierten Layergruppen eingefügt.
Fenster: Layergruppe Abhängige Layergruppe | Mit den gezogenen Layern wird die Funktion "Layergruppe neu erstellen" ausgeführt, jedoch ohne Aufruf des Layer-Auswahldialoges, da die Ausgangs-Layer den Inhalt der Layergruppe bilden.
Fenster: Hierarchien | Die Ausgangs-Layer können nicht direkt in die Hierarchie eingefügt werden – es besteht die Möglichkeit, mit den Layern eine neue Layergruppe zu bilden und als neue Hierarchie einzufügen ("Hierarchie erstellem").


Drag-&-Drop mit Layergruppen

Markieren Sie zunächst die gewünschten Objekte und klicken dann erneut auf ein markiertes Objekt, halten die Taste gedrückt und bewegen diese dann auf ein Ziel-Objekt bzw, in das Ziel-Fenster.

Hinweis: "Ziel-Fenster" ist der leere Bereich eines Fensters, d.h. der Mauszeiger ist nicht auf einem Objekt ! Die dargestellten Drag-&-Drop-Methoden arbeiten innerhalb eines LayerManager-Fensters !

Folgende Ziel-Objekte bzw. Ziel-Fenster sind für "gezogene" Layergruppen möglich:

Objekt: Layer | Auf die Zeichnungselemente der gezogenen Layergruppen können die Funktionen "Zeichnungs-Elemente kopieren" und "Zeichnungs-Elemente verschieben" angewendet werden. Der Ziel-Layer wird als Ziel-Objekt mit der Maus gezeigt.
Objekt: Hierarchie | "Neu": erstellt eine Neue Hierarchie aus den gezogenen Layergruppen und fügt diese in die Ziel-Hierarchie ein "Einfügen": die Layergruppe(n) werden in die Ziel-Hierarchie eingefügt "Einfügen in Alle": die Layergruppe(n) werden in alle markierten Hierarchien eingefügt
Fenster: Layergruppe | Mit "Kopieren" kann eine neue Layergruppe als Kopie angelegt werden; sind mehrere Ausgangs-Objekte markieirt, wird statt "Kopieren" die "Klonen"-Funktion verwendet.
Fenster: Hierarchien | "Neu": erstellt eine Neue Hierarchie aus den gezogenen Layergruppen und fügt diese neue Hierarchie auf der obersten Ebene (als TopLevel) ein.


Drag-&-Drop mit Hierarchien

Markieren Sie zunächst die gewünschten Objekte; klicken dann mit der Maustaste erneut auf ein markiertes Objekt, halten die Taste gedrückt und bewegen diese dann auf ein Ziel-Objekt bzw, in das Ziel-Fenster.

Hinweis: "Ziel-Fenster" ist der leere Bereich eines Fensters, d.h. der Mauszeiger ist nicht auf einem Objekt ! Die hier dargestellten Drag-&-Drop-Methoden arbeiten innerhalb eines LayerManagers !

Folgende Ziel-Objekte bzw. Ziel-Fenster sind für "gezogene" Hierarchien möglich:

Objekt: Layer | Auf die Zeichnungselemente der gezogenen Hierarchien können die Funktionen "Zeichnungs-Elemente kopieren" und "Zeichnungs-Elemente verschieben" angewendet werden. Der Ziel-Layer wird als Ziel-Objekt mit der Maus gezeigt.
Objekt: Hierarchie | Mit "Kopieren" werden die Ausgangs-Hierarchien (als Links) in die Ziel-Hierarchie eingefügt (siehe auch "Hierarchien erweitern"); mit "Verschieben" werden die Ausgangs-Objekte in die Ziel-Hierarche verschoben.
Fenster: Hierarchien | Mit "Kopieren" werden die Ausgangs-Hierarchieen als echte Kopien mit neuem Namen auf oberster Ebene angelegt; sind mehrere Ausgangs-Objekte gewählt, so wird die "Klonen"-Funktion verwendet.


Drag-&-Drop zwischen Zeichnungen

(nur ab AutoCAD 2000)

Mit der Drag-&-Drop-Technik können LayerManager-Daten sehr einfach und elegant zwischen verschiedenen Zeichnungen ausgetauscht werden. Somit wird der Umweg über eine Export-/Import-Datei erspart.

Voraussetzung

für den Datenaustausch zwischen Zeichnungen ist, daß Sie mehrere LayerManager-Fenster öffnen (also mindestens 2), wobei zumindest ein LayerManager-Fenster einer Zeichnung zugeordnet ist – das zweite Fenster kann sich auch im Modus "Aktuelle Zeichnung" befinden.

Ein Beispiel hierzu:

Sie möchten LayerManager-Strukturen aus der Zeichnung "A.dwg" in die Zeichnung "B.dwg" übertragen. Öffnen Sie zunächst ein 2. LayerManager-Fenster mit "Menü/Ansicht/Neues Fenster" und fixieren Sie dieses mit der Funktion "Menü/Datei/Zeichnung" (oder mit der Zeichnungsliste) auf die Zeichnung "B.dwg". Das ursprüngliche Fenster stellen Sie analog auf die Ausgangs-Zeichnung "A.dwg" ein.

Durchführung des Daten-Transfers:

Markieren Sie dann in der Ausgangszeichnung ("A.dwg") die zu übertragenden LayerManager-Objekte; dies können beliebige Layer, Layergruppen und Hierarchien sein (auch gemischt !). Klicken Sie dann mit der (linken oder rechten) Maustaste erneut auf eines der markierten Objekte, halten die Taste gedrückt und bewegen dann den Mauszeiger in das andere LayerManager-Fenster mit der Ziel-Zeichnung ("B.dwg"). Lassen Sie nun die Maustaste in diesem Ziel-Fenster wieder los.

Hinweis: Es hat keinen Einfluß auf den Drag-&-Drop-Vorgang, in welchem Anzeige-Fenster Sie die Maustaste loslassen, oder in welchem Modus sich das entsprechende Anzeige-Fenster befindet.

Es erscheint das Drag-&-Drop-Menü mit den möglichen Funktionen:

"Kopieren": kopiert die Ausgangs-Objekte in die Ziel-Zeichnung mit allen Eigenschaften; es werden alle Objekte identisch wie in der Ausgangs-Zeichnung erstellt.

"Verschieben": wie "Kopieren", jedoch werden die Ausgangs-Objekte nach dem Kopieren in der Ausgangs-Zeichnung gelöscht.

Bestehen in der Ziel-Zeichnung bereits gleiche Objekte, so erscheint der "Drag-&-Drop-Auswahl-Dialog".

Hinweis: Bei dieser Drag-&-Drop-Operation werden die Ausgangs-Objekte in der Ziel-Zeichnung lediglich erstellt – es ist nicht möglich, die Objekte in der Ziel-Zeichnung gleichzeitig neu anzulegen und neu zu strukturieren. Beispiel: Sie können Layer übertragen, aber nicht gleichzeitig eine neue Layergruppe daraus erstellen lassen. Alle Strukturierungen mit den übertragenen Daten können jedoch im Anschluß ganz normal ausgeführt werden.

siehe auch :

Objekte in der Ziel-Zeichnung überschreiben/aktualisieren


Objekte in der Ziel-Zeichnung überschreiben/aktualisieren

Bestehen in der Ziel-Zeichnung bereits einige oder alle der zu übertragenden Ausgangs-Objekte (aus der Ausgangs-Zeichnung), so erscheint der abgebildete Dialog, um das weitere Übertragen zu steuern.

"Layer überschreiben": es werden alle bestehenden Layer-auf die Eigenschaften der Ausgangs-Layer gesetzt

"Layergruppen überschreiben": es werden alle bestehenden Layergruppen auf die Eigenschaften der Ausgangs-Layergruppen gesetzt (inkl. enthaltener Layer)

"Hierarchien überschreiben": es werden alle bestehenden Hierarchien auf die Eigenschaften der Ausgangs-Hierarchien gesetzt (inkl. enthaltener Sub-Hierarchien und Layergruppen)

Jede Option wird nur dann aktiviert, wenn dementsprechende Objekte (also Layer, Layergruppen Hierarchien) schon in der Ziel-Zeichnung vorhanden sind; anderenfalls ist die zugehörige Option deaktiviert.

Hinweis: Werden die Layer-, Layergruppen- bzw. Hierarchie-Objekte "überschrieben", so bezieht sich das ausschließlich auf die Eigenschaften der Objekte !

Hinweis: Mit dem "Überschreiben" der bereits bestehenden Objekte mit den aktuellen Eigenschaften der Ausgangs-Objekte haben Sie eine sehr einfache Möglichkeit, 2 Zeichnungen miteinander abzugleichen, d.h. es können die Layer, Layergruppen und Hierarchien in der Ziel-Zeichnung vollständig auf deren Eigenschaften in der Ausgangs-Zeichnung eingestellt werden.


Die LayerTools - Einführung

Einführung

Die LayerTools dienen der schnellen Einstellung der Zeichnungslayer mittels grafischer Auswahl. Das bedeutet, daß Sie alle Layer-Operationen wie Frieren/Aus/Sperren etc. direkt in der Zeichnung vornehmen können, indem Sie Referenzelemente picken. Hierbei können auch Subelemente, wie z.B. Blockattribute gewählt werden, wenn Sie anstelle der Elementwahl mit <Return> antworten. Sie sehen dann eine neue Elementanfrage in der Befehlszeile.

Weiterhin können einige wichtige Editieroperationen layerbezogen ausgeführt werden.

Ein besonderes Leistungs-Merkmal ist es, alle Layer-Operationen auf Wunsch auch mit den NICHT (über Referenz-Elemente) referenzierten Layern auszuführen zu können.

Das Programm speichert bei jeder Änderung von Layern automatisch den vorherigen Zustand, so daß dieser mit der Funktion Restaurieren wieder zurück geholt werden kann. Dies erfolgt in unbegrenzter Tiefe sowohl im Modell- als auch im Papierbereich ! Obwohl die LayerTools direkt in den LayerManager integriert sind, handelt es sich hierbei um ein vollständig autonomes Programm, welches unabhängig vom LayerManager arbeitet, selbst wenn der LayerManager beendet wird.


Starten der LayerTools

Befehl : DDLTOOLS

Sie finden die LayerTools ausschließlich im Pulldown-Menü unter "Menü/Bearbeiten/Layer/LayerTools...".

Nach dem Start erscheint das kleine Dialog-Fenster der LayerTools; dieses Dialog-Fenster bleibt ebenso wie das LayerManager-Fenster permanent im Vordergrund und arbeitet parallel zu AutoCAD. Haben Sie die LayerTools beendet, so können Sie das Programm mit dem Befehl "DDLTOOLS" oder aus dem LayerManager-Pulldown-Menü erneut starten.

Hinweis: Möchten Sie die LayerTools generell verfügbar haben, ohne dafür den LayerManager starten zu müssen, so können Sie wie folgt vorgehen:

Öffnen Sie die Datei "acad.rx", welche sich normalerweise im gleichen Verzeichnis wie die AutoCAD-Programm-Datei "acad.exe" befindet (oder zumindest in einem der AutoCAD-Support-Pfade) mit einem einfachen Texteditor, z.B. "notepad.exe" oder "wordpad.exe". Ist die Datei "acad.rx" nicht vorhanden, so legen Sie diese bitte neu an, z.B. im Pfad "...\Support" ihrer AutoCAD-Installation.

Tragen Sie in die Datei bitte eine Zeile ein: "...\<LayerManager-Pfad>\lm_tools.arx", wobei <LayerManager-Pfad> für das Installations-Verzeichnis des LayerManagers steht. Speichern Sie die Datei – mit dem nächsten Start von AutoCAD steht Ihnen der Befehl "ddltools" zur Verfügung, um die LayerTools zu starten.


Anwendung und Bedienung

Werfen Sie zunächst bitte einen Blick auf die Programm-Optionen. Klicken Sie hierzu mit der rechten Maustaste in einen leeren Bereich des Dialoges – es erscheint das abgebildete Kontextmenü.

"Automatisch minimieren": reduziert den Dialog auf die Titelzeile, wenn Sie in AutoCAD arbeiten; ist analog zur Layer-Manager-Option "Fenster automatisch auf Titelzeile reduzieren".

"Maus-Verfolgung aktivieren": ist diese Option aktiv, so beobachtet das Programm die Maus und aktiviert je nach Mausposition entweder AutoCAD oder die LayerTools automatisch.

Alle Funktionen der LayerTools arbeiten mit den Layern von gewählten Referenz-Elementen.

Nach der Auswahl einer Funktion werden Sie daher zur Elementwahl aufgefordert: wählen Sie mit einer der Objektwahl-Methoden einige Zeichnungselemente, die sich auf den gewünschten Layern befinden. Alternativ können Sie auch mit Leereingabe (<Return>-Taste) antworten: Sie können dann Sub-Elemente wählen, um die Layer zu bestimmen, z.B. Attribute von Blöcken.

Layer:

Aktuell: setzt den aktuellen Layer auf den eines Referenz-Elementes

Aus: schaltet die Layer der Referenz-Elemente aus

Frieren: friert die Layer der Referenz-Elemente

AF-Frieren: friert die Layer der Referenz-Elemente im aktuellen VPort

Sperren: sperrt die Layer der Referenz-Elemente aus

Entsperren: entsperrt die Layer der Referenz-Elemente aus

Elemente:

Kopieren: kopiert die Elemente von den Referenz-Element-Layern auf einen ebenfalls mit Referenz-Element wählbaren Ziellayer

Ändern: verschiebt die Elemente von den Referenz-Element-Layern auf einen ebenfalls mit Referenz-Element wählbaren Ziellayer

Anzeigen: Schnellansicht aller Elemente auf den Layern der Referenz-Elemente

Löschen: löscht alle Elemente auf den Layern der Referenz-Elemente

Vordergrund: setzt die Elemente auf den Referenz-Element-Layern in den Vordergrund der Zeichnung

Hintergrund: setzt die Elemente auf den Referenz-Element-Layern in den Hintergrund der Zeichnung

Restauriere: stellt den vorherigen Layerzustand wieder her

Nicht gewählte Layer: ist diese Option aktiv, so werden die NICHT GEWÄHLTEN Layer in den Layer-Operationen verwendet.

Hierzu einige Beispiel:

  1. "Sperren" & "Nicht gewählte Layer": es wird Layer "XYZ" über Referenzelemente gewählt – es werden alle sonstigen Layer gesperrt, der Layer "XYZ" bleibt entsperrt, und dessen Elemente können bearbeitet werden.

  2. "Aus" & "Nicht gewählte Layer": es wird Layer "XYZ" über Referenzelemente gewählt – es werden alle sonstigen Layer ausgeschaltet, der Layer "XYZ" bleibt sichtbar.

Das Restaurieren von Layerzuständen ist ohne Einschränkung der Undo-Tiefe möglich, d.h. Sie können beliebig weit, auch bis zum Anfang, alle Änderungen an den Layerzuständen rückgängig machen. Dabei betrifft das Restaurieren ausschließlich die Änderungen an den Layer-Zuständen, nicht die sonstige Editierung in der Zeichnung !


Übersicht und Hinweise

Dieses Kapitel soll Ihnen helfen, Antworten zu finden auf die wichtigsten Fragen, die sich beim (anfänglichen) Umgang mit dem LayerManager ergeben – in diesem Sinne kann es auch als Tutorial bzw. Schnelleinstieg verstanden werden.

Dieses Kapitel wird fortlaufend erweitert – entsprechend den Wünschen von Anwendern werden hier oft gestellte Fragen beantwortet. Wenn immer möglich, finden Sie im Text zu den einzelnen Themen auch gleich den Verweis auf das eigentliche Kapitel im Handbuch bzw. in der Online-Hilfe, so daß Sie mit einem Klick auf den hervorgehobenen Text (Hyperlink) in der Online-Hilfe dorthin wechseln können.


Layer bearbeiten und anwenden

Es steht eine sehr grosse Vielfalt an Operationen bereit, um Layer zu bearbeiten – auch, aber nicht nur, jene von AutoCAD bekannten Standardfunktionen.

Stellen Sie ein LayerManager-Fenster (sinnvollerweise das rechte/untere) auf einen der Layer-Modi ein – z.B. "Alle Layer", "Sichtbare Layer", "Nicht sichtbare Layer". Markieren Sie dann einen oder mehrere Layer und klicken auf die rechte Maustaste – hier finden Sie (nahezu) alle verfügbaren Funktionen auf 2 Menüseiten, zwischen denen Sie wechseln können ("Anderes Menü").

Das rechten/unteren Anzeige-Fenster entspricht im wesentlichen dem Aufbau der AutoCAD-Layersteuerung – die wichtigsten Funktionen sind daher mit nur 1,2 Mausklicks verfügbar.

Bearbeiten von Layern Funktionen zur Bearbeitung markierter Layer finden Sie unter "Menü/Datei" sowie unter "Menü/Bearbeiten".

Anwenden von Layern Funktionen zur Anwendung markierter Layer finden Sie unter "Menü/Bearbeiten" sowie unter "Menü/Extras".


Layergruppen erstellen und anwenden

Zur Anwendung bestehender Layergruppen ist lediglich anzumerken, daß alle Funktionen zur Anwendung von Layern völlig identisch auch mit Layergruppen anwendbar sind – alle diese Funktionen arbeiten daher sinngemäß mit den in der Layergruppe enthaltenen Layern.

Die gleichartige Handhabung zeigt sich auch darin, daß das rechte/untere Anzeige-Fenster im Modus "Alle Layergruppen" und "Abhängige Layergruppen" exakt den gleichen Aufbau wie bei der Anzeige von Layern nutzt – so sehen Sie beispielsweise, ob eine Layergruppe (teilweise/vollständig) sichtbar ist oder welchen Linientyp die Layergruppe nutzt, usw.

Alle Funktionen finden Sie in bekannter Weise auf dem Kontextmenü (mit 2 Menüseiten) der markierten Layergruppen sowie im Pulldown-Menü.

Um Layergruppen zu erstellen, bestehen die verschiedensten Methoden – hier die wichtigsten:

  • mit "Menü/Datei/Neu/Layergruppe": ist das linke/rechte Anzeige-Fenster in einem der Layergruppen-Modi, so nutzen Sie diese Funktion; der LayerManager führt Sie schrittweise durch den Erstellungsprozess

  • mit Drag-&-Drop: Drag-&-Drop mit Layern Sie können markierte Layer mit der (linken oder rechten) Maustaste in ein anderes Anzeige-Fenster "ziehen" und dort im leeren Bereich "fallenlassen" oder auch auf einer anderen Layergruppen "fallenlassen" – so können neue Layergruppen erstellt oder bestehende Layergruppen erweitert werden. Das Zielfenster sollte sich in einem der Layergruppen-Modi befinden.

  • über Import von LayerManager-Strukturen: Layergruppen können auch erstellt werden, indem die in Export-/Import-Dateien gespeicherten LayerManager-Strukturen in die aktuelle Zeichnung importiert werden.

Je nach Art und Anzahl markierter Layer- und Layergruppen-Objekte und in Details abhängig vom Anzeige-Modus des Fensters bestehen weitere Methoden, um Layergruppen zu erstellen oder Layergruppen zu erweitern – dies ist sehr ausführlich in den entsprechenden Kapiteln dargestellt.


Hierarchien erstellen und anwenden

"Hierarchien" stellen die strukturierte Anordnung von Sub-Hierarchien und Layergruppen dar – und entsprechen weitgehend dem Prinzip der Datei-Ordner/Verzeichnisse auf der Festplatten. Somit bestehen sehr komfortable Möglichkeiten, selbst komplexeste Layergruppen-Systeme in den Griff zu bekommen, da Hierarchien keine Limitierung bzgl. Anzahl und Tiefe der beinhalteten Sub-Hierarchien und Layergruppen kennen.

Mit Hierarchien können Sie daher problemlos Dutzende Layergruppen mit Hunderten von beinhalteten Layern durch wenige Mausklicks in der Zeichnung steuern.

Zur Anwendung von Hierarchien gilt Gleiches wie bei Layern und Layergruppen: alle Funktionen zur Anwendung von Layern und Layergruppen sind völlig identisch auch mit Hierarchien und Sub-Hierarchien anwendbar – alle diese Funktionen arbeiten sinngemäß mit den in den Hierarchien enthaltenen Sub-Hierarchien und Layergruppen (d.h. mit der Summe der enthaltenen Layer).

Alle Funktionen finden Sie in bekannter Weise auf dem Kontextmenü (mit 2 Menüseiten) der markierten Hierarchien sowie im Pulldown-Menü.

Um Hierarchien zu erstellen, bestehen die verschiedensten Methoden – hier die wichtigsten:

  • mit "Menü/Datei/Neu/Hierarchie": ist das linke Anzeige-Fenster im Hierarchie-Modus, so nutzen Sie diese Funktion; der LayerManager führt Sie schrittweise durch den Erstellungsprozess

  • mit Drag-&-Drop: Sie können markierte Layergruppen mit der (linken oder rechten) Maustaste in ein anderes Anzeige-Fenster "ziehen" und dort im leeren Bereich "fallenlassen" oder auch auf einer anderen Hierarchie "fallenlassen" – so können neue Hierarchien erstellt oder bestehende Hierarchien erweitert werden. Das Zielfenster muß sich im "Hierarchie"-Modi befinden.

  • über Import von LayerManager-Strukturen: Hierarchien können auch erstellt werden, indem die in Export-/Import-Dateien gespeicherten LayerManager-Strukturen in die aktuelle Zeichnung importiert werden.

Je nach Art und Anzahl markierter Layer- und Layergruppen-Objekte und in Details abhängig vom Anzeige-Modus des Fensters bestehen weitere Methoden, um Hierarchien zu erstellen oder Hierarchien zu erweitern – dies ist sehr ausführlich in den entsprechenden Kapiteln dargestellt.


Wie erhalte ich mehrere LayerManager-Fenster ?

Wenn Sie auf dem AutoCAD-Befehlsprompt den LayerManager mit dem Befehl "LmPro" (oder "LaymanPro") erneut starten wollen, sehen Sie zunächst einmal – Nichts ! Denn es wird damit kein weiters LayerManager-Fenster gestartet, sondern verdeckte, minimierte oder sonstwie nicht sichtbare Programm-Fenster werden dadurch wieder sichtbar gemacht und in den Vordergrund gesetzt.

Um weitere LayerManager-Fenster zu öffnen, nutzen Sie bitte die Funktion "Menü/Ansicht/Neues Fenster" jedes neue LayerManager-Fenster startet als identische Kopie, ist aber dann völlig unabhängig und kann nach Wunsch konfiguriert werden.


Wie zeigt der LayerManager eine bestimmte Zeichnung in AutoCAD 2000 ?

Jedem LayerManager-Fenster kann entweder stets die aktuelle AutoCAD-Zeichnung zugeordnet sein oder aber eine vom Anwender festgelegte Zeichnung (aus den in AutoCAD geöffneten).

Mit der Funktion "Menü/Datei/Zeichnung" erscheint ein Auswahl-Dialog mit den geöffneten Zeichnungen – wählen Sie eine dieser Zeichnungen aus oder wählen Sie den Eintrag "<AKTUELL>", um im LayerManager stets die aktuelle Zeichnung anzuzeigen. Eine dem LayerManager-Fenster zugeordnete Zeichnung wird dadurch nicht in den Vordergrund gesetzt, d.h. die Zeichnung wird nicht zur aktuellen AutoCAD-Zeichnung !

Alternativ: Aktivieren Sie mit "Menü/Ansicht/Dwg-Liste" die Anzeige der Zeichnungsliste (als Popup- oder Klappliste) direkt im LayerManager-Fenster. Vorteil hierbei: Sie sehen in der Popup-Liste immer auch den vollständigen Pfad der Zeichnung.


Wie übertrage ich LayerManager-Daten in eine andere Zeichnung ?

Zum Übertragen von LayerManager-Strukturen in andere Zeichnungen besteht prinzipiell immer die Möglichkeit zur Nutzung der Export-/Import-Dateien. Aus der aktuellen Zeichnung können gewählte Layergruppen und Hierarchien in eine Export-Datei (ASCII-Textdatei) gespeichert werden, um diese dann in einer anderen Zeichnung wieder zu importieren. Beim Import bestehen umfassende Möglichkeiten, LayerManager-Daten vollständig oder nur teilweise zu importieren.

In AutoCAD 2000(i) besteht ist es ausserdem möglich, LayerManager-Daten zwischen geöffneten Zeichnungen per Drag-&-Drop auszutauschen – dazu ordnen Sie den (mindestens 2) LayerManager-Fenstern jeweils eine Zeichnung (Ausgangs- und Zielzeichnung) zu.

Die Export-/Import-Dateien können ausserdem mit jedem (einfachen !) Texteditor (Notepad.Exe) editiert werden; weiterhin dienen sie auch als Backup ihrer definierten LayerManager-Strukturen !


Einige Hinweise zum Kapitel "Tips und Tricks"

In diesem Kapitel erhalten Sie eine ganze Anzahl von Hinweisen, Tips und Tricks zu Details, welche vielleicht etwas tiefer im Programm versteckt sind, jedoch in der alltäglichen Arbeit sehr hilfreich sein können.

Auch dieses Kapitel wird fortlaufend erweitert – entsprechend den Fragen und Anregungen von Anwenden finden Sie hier eine Sammlung der interessantesten Ideen und Techniken, um den LayerManager so effektiv wie möglich einzusetzen. Wenn immer möglich, finden Sie im Text zu den einzelnen Themen auch gleich den Verweis auf das eigentliche Kapitel im Handbuch bzw. in der Online-Hilfe, so daß Sie mit einem Klick auf den hervorgehobenen Text (Hyperlink) in der Online-Hilfe dorthin wechseln können.


Voreingestellte Zeichnungs-Strukturierung

Die Layer-Strukturen müssen oft vorgegebenen Normierungen, büro-internen bzw.- übergreifenden Standards oder auch von anderen Gewerken, Auftraggebern und Kunden geforderten Strukturen entsprechen – oft sind es aber auch Forderungen des Datentransfers in andere CAD-Systeme, welche eine spezifische Layer-Struktur erfordern.

Daher ergibt sich die Notwendigkeit, derartige fixe Strukturen zu erstellen und einzuhalten – nur möchte wohl niemand dafür einen 20-seitigen Katalog mit Layernamen durchblättern. LaymanPro bietet verschiedene Methoden, solche Standards festzulegen und zu verwalten.

Nutzung der Auto-Strukturierung | Verwendet Template-Dateien, um Layergruppen und Hierarchien automatisch und im Hintergrund zu erstellen
Nutzung der Export-/Import-Dateien | Verwendet die LayerManager-Daten aus zu ladenden Dateien
Nutzung von Prototyp-Zeichnungen | Verwendet Prototyp-Zeichnungen mit LayerManager-Daten
Nutzung von Prototyp-Blöcken | Verwendet Zeichnungsblöcke mit LayerManager-Daten

Alle diese Methoden haben ihre jeweiligen Vorteile – prüfen Sie daher, welche Methode Ihrem Arbeitsumfeld am besten entspricht. Die aufgeführten Methoden können natürlich auch nach Bedarf kombiniert verwendet werden !

siehe auch :

Auto-Strukturierung

Prototyp-Zeichnungen

Prototyp-Blöcke


Tips und Tricks - Voreingestellte Zeichnungs-Strukturierung - Auto-Strukturierung

Auto-Strukturierung

Ab der Version v4.1 kann mit der Auto-Strukturierung definiert werden, welche Layergruppe welche Layer, und welche Hierarchie welche Sub-Hierarchien und Layergruppen enthalten soll. Diese Definitionen werden in einer Template-Datei gespeichert – einer Zeichnung können dann eine oder mehrere dieser Template-Dateien zugeordnet sein. Damit besitzt dann die Zeichnung das vollständige Wissen über die gewünschte Zeichnungs-Struktur und der LayerManager kann nun die Zeichnung beobachten :

Sobald in der Zeichnung ein neuer Layer angelegt ist, werden alle aktiven Template-Dateien analysiert und alle entsprechenden Layergruppen und ggf. Hierarchien automatisch erstellt. Durch die Möglichkeit, auch Wildcards für die zu nutzenden Layer, Layergruppen und (Sub-)Hierarchien zu verwenden, ist die Auto-Strukturierung die wohl leistungsstärkste und flexibelste Form der Zeichnungs-Strukturierung.


Prototyp-Zeichnungen

Die einfachste Form, vordefinierte LayerManager-Strukturen permanent in Ihre Zeichnungen einzufügen, besteht in der bereits durch AutoCAD selbst angebotenen Möglichkeit, Prototyp-Zeichnungen (auch als "Template-Zeichnungen" bezeichnet) zu verwenden. Diese Template-Zeichnungen sind normale Zeichnungen, welche sich nur durch den Dateityp "*.DWT" unterscheiden.

In diesen Template-Zeichnungen, welche üblicherweise beim Erstellen einer neuen Zeichnung zur Auswahl angeboten werden, können Sie problemlos mit dem LayerManager arbeiten und die gewünschten Strukturen erstellen – speichern Sie die so vorbereitete Zeichnung unbedingt als Template !

Wenn Sie später eine neue Zeichnung erstellen, dann wählen Sie die von Ihnen erstellte Template-Datei – Ihre Zeichnung enthält somit alle in der Template-Datei definierten Layer, Layergruppen und Hierarchien. Es empfiehlt sich, diese Methode für die absolut grundlegenden LayerManager-Objekte zu verwenden, da sie nicht das hohe Maß an Flexibilität bietet wie beispielsweise der Import aus den Export-/Import-Dateien.


Prototyp-Blöcke

Eine weitere Methode zum (dynamischen) Einbinden vordefinierter LayerManager-Strukturen besteht in der Nutzung von Zeichnungsblöcken mit darin enthaltenen LayerManager-Objekten.

Erstellen Sie (wie bei den Prototyp-Zeichnungen) eine Zeichnung mit den gewünschten Layern, Layergruppen und Hierarchien und speichern Sie diese als normale Zeichnung/WBlock ab. Später, in Ihrer eigentlichen Zeichnung, fügen Sie die vorbereitete Zeichnung als Block ein. Wichtig: fügen Sie die Zeichnung als aufgelösten Block ein – Position und Skalierung sind beim Einfügen völlig ohne Bedeutung.

Das Einfügen als aufgelöster Block wird aus folgendenden Gründen dringend empfohlen:

  1. Sie vermeiden so eine unnötige Blockreferenz (Blockeinfügung) sowie unnötige Blockdefinition

  2. Die Anzeige von in Blöcken und XRefs enthaltenen Layergruppen und Hierarchien erfolgt mit dem (für XRefs) üblichen Trennzeichen ("|") – dieses würde in diesem Zusammenhang nur irritieren (da die Darstellung von LayerManager-Objekten aus echten Blöcken und XRefs sehr sinnvoll damit gekennzeichnet sind).

Diese Methode empfiehlt sich insbesondere, um Layer, Layergruppen und Hierarchien dynamisch, d.h. nach Bedarf, in die Zeichnung zu laden – Sie können die LayerManager-Strukturen sozusagen nach dem "Baukasten-Prinzip" Schritt für Schritt erstellen, und ist insgesamt flexibler als die Methode der Prototyp-Zeichnungen. Wird jedoch eine eher "starre" Layer-Struktur gefordert, ist letztere Methode wohl sinnvoller.

Je nach Einstellung in den LayerManager-Optionen erfolgt die Erkennung der neuen LayerManager-Objekte vollständig automatisch oder auch nach Rückfrage mit Bestätigung.


Tips und Tricks - Layergruppen erweitern

Layergruppen erweitern

Eine weitere, sehr übersichtliche Methode zum Erweitern von Layergruppen soll hier dargestellt werden – sie basiert auf der Nutzung von 2 LayerManager-Fenstern.

  1. Öffnen Sie zunächst (falls nicht vorhanden) ein weiteres LayerManager-Fenster und stellen Sie dessen linkes/oberes Anzeige-Fenster auf den Modus "Layergruppen" ein. Das rechte Fenster stellen Sie bitte auf den Modus "Abhängige Layer" ein (in AutoCAD 2000(i) auch gleiche Zeichnung einstellen !).

  2. Markieren Sie im linken/oberen Fenster diejenige (oder auch mehrere !) Layergruppe(n), welche Sie mit weiteren Layern ergänzen wollen – Sie sehen im rechten/unteren Fenster (ggf. summarisch) alle Layer, die in den markierten Layergruppen enthalten sind.

  3. Wählen Sie in einem anderen LayerManager-Fenster die Layer aus, welche Sie in die Layergruppen einfügen wollen – Sie können die Layer in einem beliebigen Anzeige-Modus markieren.

  4. Ziehen Sie nun die markierten Layer per Drag-&-Drop in das rechte/untere Anzeige-Fenster (also das Fenster mit den "Abhängigen Layern") des 2. LayerManagers und lassen Sie die Layer dort fallen. Alle markierten Layergruppen werden um die "gezogenen" Layer erweitert.

Der neue Layergruppen-Inhalt wird automatisch in allen entsprechenden LayerManager-Fenstern angezeigt.


Tips und Tricks - Hierarchien erweitern

Hierarchien erweitern

Eine weitere, sehr übersichtliche Methode zum Erweitern von Hierarchien soll hier dargestellt werden – sie basiert auf der Nutzung von 2 LayerManager-Fenstern.

  1. Öffnen Sie zunächst (falls nicht vorhanden) ein weiteres LayerManager-Fenster und stellen Sie dessen linkes/oberes Anzeige-Fenster auf den Modus "Hierarchien" ein. Das rechte Fenster stellen Sie bitte auf den Modus "Abhängige Layergruppen" ein (in AutoCAD 2000(i) auch gleiche Zeichnung einstellen !).
    2. Markieren Sie im linken/oberen Fenster diejenige (oder auch mehrere !) Hierarchie(n), welche Sie mit weiteren Layergruppen ergänzen wollen – Sie sehen im rechten/unteren Fenster (ggf. summarisch) alle Layergruppen, die in den markierten Hierarchien enthalten sind.
  3. Wählen Sie in einem anderen LayerManager-Fenster die Layergruppen aus, welche Sie in die Hierarchien einfügen wollen – Sie können die Layergruppen in einem beliebigen Anzeige-Modus markieren.

  4. Ziehen Sie nun die markierten Layergruppen per Drag-&-Drop in das rechte/untere Anzeige-Fenster (also das Fenster mit den "Abhängigen Layergruppen") des 2. LayerManagers und lassen Sie die Layergruppen dort fallen. Alle markierten Hierarchien werden um die "gezogenen" Layergruppen erweitert.

Der neue Hierarchie-Inhalt wird automatisch in allen entsprechenden LayerManager-Fenstern angezeigt.


Häufige Wechsel zwischen Modell- und Papierbereich

Eines der gravierendsten Probleme in AutoCAD's Layerverwaltung besteht in der getrennten Steuerung der Layer zwischen Modellbereich und Papierbereich (bzw. den Layouts in AutoCAD 2000(i)).

Um Layer im Papierbereich getrennt für die Viewports einstellen zu können, muss der Befehl "AFLayer" (bzw. die Spalte "in Ansichtsfenstern frieren" im Layerdialog) verwendet werden – gleichzeitig müssen die Layer aber auch Ein und Getaut geschaltet werden, sonst sind diese Layer im Papierbereich nicht nutzbar, da nicht aktiv.

Genau hierin liegt das Problem: damit Sie die Layer im Papierbereich überhaupt mit "AFLayer" sinnvoll (d.h. Viewport-bezogen) steuern können, müssen die Layer im Modellbereich Ein und Getaut sein. Das bedeutet, daß Ihre Modellbereichs-Layerkonfiguration damit hinfällig ist. Wechseln Sie aus dem Papierbereich wieder in den Modellbereich zurück, müssen Sie die Layer komplett neu einstellen.

Ein weiters Problem in AutoCAD 2000(i) besteht darin, daß es nun zwar mehrere Papierbereiche (Layouts) gibt, jedoch nur eine globale Eigenschaft für "Ein/Aus" und "Frieren/Tauen". Damit kann eben nicht ein- und derselbe Layer "xyz" im Layout "Layout1" Ein+Getaut gesetzt sein, in einem anderen Layout "LayoutX" jedoch Aus+Gefroren sein ! Nach jedem Wechsel in ein anderes Layout müssen diese Einstellungen neu vorgenommen werden – genau das muss aber in der Praxis als absolut indiskutabel bezeichnet werden, ganz abgesehen von den potentiellen Fehlermöglichkeiten sowie der Zeitverschwendung !

Mit dem LayerManager wird dieses Problem elegant gelöst:

Der LayerManager ist in der Lage, bei jedem Wechsel zwischen Modell- und Papierbereich bzw. zwischen den Layouts (in AutoCAD 2000(i)) die Layer-Konfiguration des vorherigen Bereiches zu speichern – auch permanent zwischen den AutoCAD-Sitzungen ! Sobald Sie in den jeweils anderen Bereich wechseln, bietet der LayerManager an, die zuletzt benutzte Layer-Konfiguration für den neuen Bereich wiederherzustellen.

Aus gleichem Grund wird beim 1. Wechsel in den Papierbereich nachgefragt, ob alle Layer freigegeben werden sollen (d.h. eingeschaltet und getaut) – wenn Sie die Layersituation des Modellbereiches als Ausgangsbasis für den Papierbereich verwenden wollen, so bestätigen Sie die Anfrage mit "Nein" und alle im Modellbereich ausgeschalteten/gefrorenen Layer stehen im Papierbereich nicht zur Verfügung - beantworten Sie die Anfrage mit "Ja", dann werden alle Layer eingeschaltet und getaut, so daß Sie im Papierbereich zunächst alle Layer sichtbar haben, und Sie diese dann je Viewport schalten können.

Bei jedem Wechsel zwischen Modellbereich und Papierbereich bzw. bei jedem Wechsel zwischen Layouts (in AutoCAD 2000(i)) wird die Layersituation des eben verlassenen Bereiches gespeichert (Sie erkennen das an der Ausschrift am Befehlsprompt); zudem wird bei diesem Wechsel auch die Layersituation im Modellbereich mit jener aus dem Papierbereich verglichen – treten Unterschiede bei den eingeschaltenen/getauten Layern auf, besteht die Möglichkeit, den jeweils letzten Layerzustand zu restaurieren – je nach Einstellung in den LayerManager-Optionen erfolgt die Restaurierung automatisch oder es erscheint eine Anfrage hierzu.

Durch diese Methoden können Sie die Layer in allen Bereichen absolut unabhängig voneinander handhaben – das lästige Einstellen der Layer nach einem Wechsel zwischen Modell- und Papierbereich entfällt dadurch.

Neu ab Version v4.1 (ab Release Juni 2001):

Der LayerManager speichert alle Layer-Eigenschaften von Modellbereich, Papierbereich und allen Layouts automatisch beim Wechsel zwischen diesen Bereichen – und restauriert wählbare Layer-Eigenschaften wieder, wenn der Anwender in einen anderen Bereich gewechselt ist. Damit sind Modellbereich, Papierbereich und Layouts nun erstmals vollständig voneinander unabhängig, und die Nutzung der Layer in den Layouts (insbesondere ja zum Plotten) wird drastisch vereinfacht.


Einige Hinweise zu diesem Kapitel

In diesem Kapitel finden Sie einige Hinweise zu Problemsituationen und Störungen sowie zu deren Behebung. Es werden auch die gegenwärtig bekannten Programmfehler und Beschränkungen dargestellt sowie ggf. vorhandene Möglichkeiten oder Alternativen aufgezeigt, um diese zu umgehen.


Probleme im Zusammenhang mit Windows95/98/NT/2000

Der LayerManager arbeitet als AutoCAD-Applikation mit Windows-Oberfläche. Dadurch ist das Programm auch von der Konfiguraton des Betriebssystemes abhängig.

Insbesondere unter Windows NT mit den verschiedenen ServicePacks (z.Zt. SP1...SP6a) in Zusammenhang mit verschiedenen Generationen des "MS Internet Explorers" (welche alle jeweils für sich allein ca. 50%...70% des Betriebssystemes erneuern !) können sehr viele Probleme verursachen – installierte MS-Office-Software hat ebenfalls erheblichen Einfluß auf das Gesamtsystem. Sie kennen das sicherlich ...

Die hier gegebenen Empfehlungen entsprechen den oft leidvollen Erfahrungen (nicht nur) des Programm-Autors – sie sind jedoch keineswegs notwendig oder verbindlich, sondern dienen lediglich der Absicht, ein möglichst kompatibles, und fehlerbereinigtes Umfeld zu gewährleisten.

Unter Windows 95 wird die Installation des "MS Internet Explorer 5.0" oder neuer (im Sinne eines System-Updates) empfohlen.

Unter Windows 98/98SE sind bislang keine derartigen Probleme bekannt. Hier scheint bereits durch den "MS Internet Explorer 4.0/5.0" das erforderliche Maß an Aktualität und Kompatibilität gegeben zu sein.

Unter Windows NT 4.0 wird die Installation des ServicePacks 6a (SP6a) sowie des "MS Internet Explorer 5.0" oder neuer (beides im Sinne eines System-Updates) dringend empfohlen.

Unter Windows 2000 sind keine weiteren Voraussetzungen notwendig


Bekannte Fehler und Beschränkungen

Aufgrund der Komplexität heutiger Betriebssysteme und Anwendersoftware sowie der Vielfalt möglicher Hardware inkl. der Treiber-Software und vieler oft kleinerer Kompatibilitätsprobleme zwischen allen Seiten ist es äußerst schwierig, Software auch nur annähernd unter allen Bedingungen zu testen. Der LayerManager wurde sehr intensiv unter Windows NT 40, Windows 98SE und Windows2000 getestet – leider ist das aber keine Garantie für ein generell fehlerfreies Programm.

Gegenwärtig sind folgende Fehler und Beschränkungen bekannt:

  • ToolTips erscheinen nicht: die für ToolBars üblichen ToolTips (die kleinen Textfahnen mit Kurzinfos zu Buttons) erscheinen möglicherweise auf Ihrem PC mit Windows NT nicht – ab ServicePack 5 (SP5) oder höher sowie installiertem "MS IE 5.0" oder neuer ist das Problem von seiten Windows behoben. Unter Windows 98/98SE und Windows2000 tritt dieses Problem nicht auf.

  • Allgemein: treten bei der Bearbeitung einer Zeichnung Probleme mit dem LayerManager auf, ist es sehr empfehlenswert, die Zeichnung zunächst mit "Wiederherstellen" zu öffnen, um evtl. vorhandene Defekte in der Zeichnung zu korrigieren – da der LayerManager sehr intensiv mit AutoCAD "verzahnt" ist, reagiert das Programm auch recht empfindlich auf derartige Fehler in der Zeichnungs-Datenbank.

  • Allgemein: Bestehen die Probleme nach diesem Schritt weiterhin, so kann Folgendes ebenfalls noch versucht werden: beenden Sie AutoCAD und löschen die Dateien "Layman.cfx" und "Layman.wpx" im LayerManager-Programm-Verzeichnis; dann können Sie AutoCAD wieder starten – möglicherweise waren defekte Options-Werte die Ursache, welche durch den LayerManager in diesen Dateien gespeichert sind.
Erscheinen die Probleme weiterhin, so treten Sie bitte mit dem Programm-Autor in Kontakt (eMail/Telefon/Fax etc.), um die Ursache zu lokalisieren und evtl. vorhandenen Programmfehler im Interesse aller Anwender schnellstmöglich zu beheben – hierfür bereits im Voraus herzlichen Dank.


LayerManager-Fenster ist verschwunden ?

Es kann unter (relativ seltenen) Umständen vorkommen, daß das LayerManager-Fenster nach dem Programm-Start nicht erscheint oder auch bei normaler Anwendung "verschwindet". Um das LayerManager-Fenster wieder sichtbar zu machen, bestehen verschiedenen Möglichkeiten:

LayerManager-Fenster erscheint nicht nach

dem Programmstart

 Geben Sie zunächst am AutoCAD-Prompt bitte sicherheitshalber den Layer-Manager-Befehl "lmpro" ein – alle evtl. im Hintergrund befindlichen oder minimierten oder verdeckten Fenster werden dadurch wieder in den Vordergrund geholt.

Erscheint kein Fenster, so befindet es sich wahrscheinlich ausserhalb Ihres Bildschirmes – das kann durch AutoCAD-/LayerManager-Programmabstürze verursacht worden sein, oder auch durch das Kopieren der LayerManager-Programmdateien von einem anderen Rechner, z.B. vom PC auf den Laptop; da sich LaymanPro alle Fensterpositionen merkt.

Lösung: Beenden Sie AutoCAD und löschen dann bitte die Dateien "Layman.Wpx" im LayerManager-Verzeichnis (oder lassen Sie diese Dateien Suchen, und löschen Sie alle gefundenen Dateien).

Beim nächsten Programmstart verwendet der LayerManager dann interne Default-Werte – überprüfen Sie bitte daher auch die LayerManager-Optionen.
LayerManager-Fenster ist

Im Arbeitsprozeß

verschwunden

 Geben Sie am AutoCAD-Prompt bitte ein: "lmpro" ein; alle in den Hintergrund gerutschten, minimierten oder sonstwie verdeckten Programm-Fenster werden auf ihre originale Größe restauriert und in den Vordergrund gesetzt.

Dies kann passieren, wenn Sie beispielsweise das Minimieren-Icon anklicken, wodurch das LayerManager-Fenster als Icon auf dem Desktop oder in der Taskleite liegt – auf dem Desktop kann dieses Icon aber von anderen Fenstern (z.B. vom AutoCAD-Textfenster) verdeckt werden.


Dialog-Fenster sind beschädigt oder unvollständig ?

Sehr selten kann der Effekt eintreten, daß Programm-Dialoge unvollständig erscheinen – Sie erkennen das z.B. an fehlenden Buttons oder zu kleinem bzw. zu großem Dialog-Fenster.

Die Ursachen hierfür können verschieden sein :

  1. Unsauberes Beenden oder Abstürze von AutoCAD oder LayerManager

  2. Manuelles Übertragen von LayerManager-Installationen zwischen verschiedenen Rechnern

Lösung des Problems:

  1. Funktion "Menü/Extras/Dialoge reparieren" : damit werden alle Dialog-Fenster auf ihre originale Grösse und Position zurückgesetzt

- oder -

  2. Beenden Sie AutoCAD und löschen die Datei "…\Ini\<User>\Layman.wpx" im LayerManager-Verzeichnis (<User> ist Ihr Login-Name). Falls Sie diese Datei nicht finden, so löschen Sie alle Dateien "Layman.wpx" unterhalb des LayerManager-Installationsverzeichnises. Die Datei "Layman.wpx" speichert die Fensterpositionen und –grössen aller LayerManager-Dialoge; meist ist diese Datei beschädigt oder enthält falsche Datenwerte.

Beim nächsten Programmstart erscheinen alle Dialoge und Fenster wieder in originaler Grösse und Position.


AutoCAD kann Layer nicht bereinigen ?

Durch den LayerManager kann es verursacht werden, daß AutoCAD manche Layer nicht bereinigen bzw. löschen kann. Dieser Fall tritt immer dann ein, wenn solche Layer in Layergruppen sind und/oder diese Layer mit einem Beschreibungstext versehen sind.

Um die Layer dennoch bereinigen/löschen zu können, bieten sich prinzipiell 2 Methoden an:

  1. Entfernen Sie die Layer aus allen betreffenden Layergruppen und löschen Sie deren Beschreibungstexte. Speichern Sie dann im LayerManager den aktuellen Stand ab (unter "Menü/Datei/Sichern") ! Danach können diese Layer durch AutoCAD bereinigt/gelöscht werden.

  2. Einfacher und effektiver ist es, die Layer direkt im LayerManager zu löschen. Der LayerManager löscht hierbei die Beschreibungstexte, entfernt die Layer aus allen Layergruppen, löscht alle auf den Layern befindlichen Zeichnungs-Elemente und löscht danach die Layer auch in AutoCAD.

Hinweis: falls der/die Layer weiterhin vorhanden sind, wiederholen Sie das Löschen der Layer – manchmal werden 2. Durchläufe benötigt, ehe AutoCAD einen Layer als unbenutzt erkennt.


Installation von LayerManager-Updates

Die Installation eines LayerManager-Updates erfolgt sehr einfach. Beachten Sie hierbei aber bitte die zugrunde liegende AutoCAD-Version, da eine LayerManager-Versionen für AutoCAD R14 nicht in R2000(i) arbeiten kann und umgekehrt.

Update für das gleiche AutoCAD-Release:

Installieren Sie das Programm-Update einfach in Ihr bestehendes LayerManager-Verzeichnis – der Lizenz-status Ihrer bisherigen Programmversion bleibt dabei bestehen.

Update für ein höheres/tieferes AutoCAD-Release:

Installieren Sie das Programm-Update unbedingt in ein neues LayerManager-Verzeichnis – zum Lizenzstatus beachten Sie bitte den unten stehenden Hinweis.

Wenn Sie verschiedene AutoCAD-Versionen parallel verwenden (auch im Netzwerk):

Da die AutoCAD-ARX-Programmdateien mit jeder AutoCAD-Version nicht kompatibel zueinander sind, wird dringendst empfohlen, die jeweiligen LayerManager-Versionen (je nach AutoCAD-Release) in getrennte Verzeichnisse zu installieren – anderenfalls überschreiben Sie die ja noch benötigte altere Programm-Version des LayerManagers ! Durch die Installation der LayerManager-Versionen in getrennte Verzeichnisse haben Sie keine Nachteile zu befürchten – bei einer neu installierten LayerManager-Version überprüfen Sie bitte beim ersten Programmstart in AutoCAD die Einstellung der Optionen (unter "Menü/Datei/Konfiguration").

Hinweis: Normalerweise werden Programm-Updates stets nur als Demo-Version ausgeliefert – dies sind Programm-Pakete ohne Lizensierungsdaten. Beim Installieren des Updates in ein bestehendes LayerManager-Verzeichnis gilt daher die Regel: Demo bleibt Demo, Lizenz bleibt Lizenz.

Hinweis zur Programm-Lizensierung bei Installation in ein neues LayerManager-Verzeichnis:

Normalerweise sollte die Installation eines Updates in das bestehende LayerManager-Verzeichnis.erfolgen – dadurch bleibt der bestehende Lizensierungsstatus (Demo-/Lizenz-Version) erhalten. Steht Ihnen für ein neues, höheres AutoCAD-Release nur eine Demo-Version des LayerManagers zur Verfügung und Sie haben den LayerManager für das ältere AutoCAD-Release als Lizenzversion, so gehen Sie bitte wie folgt vor:

Kopieren Sie die Datei "Layman.dax" aus dem LayerManager-Verzeichnis der älteren Programm-Version in das LayerManager-Verzeichnis der neu installierten LayerManager-Version – damit werden die für Ihren PC gültigen Lizenzdaten übernommen.

Starten Sie AutoCAD neu – der LayerManager sollte nun wieder als Lizenzversion arbeiten.


Kompatibilität zu älteren LayerManager-Versionen

Bei der (stetigen) Weiterentwicklung hat die Kompatibilität zu den jeweils früheren LayerManager-Versionen höchste Priorität.

Das zeigt sich auch darin, daß die vorliegende Programm-Version kompatibel bis hinunter zu sehr frühen Versionen (AutoCAD R12/DOS) gegeben ist. Die Kompatibilität bezieht sich hierbei auf die in den Zeichnungen gespeicherten LayerManager-Daten.

Sie können also auch sehr alten Zeichnungen mit dem LayerManager verwenden, ohne die in der Zeichnung bestehenden LayerManager-Daten zu verlieren. Das gilt auch in umgekehrter Richtung: Sie können beispielsweise in AutoCAD 2000(i) eine Zeichnung im R13-Format speichern – die LayerManager-Daten bleiben vollständig erhalten und sind auch in AutoCAD R13 (mit der entsprechenden LayerManager-Version) problemlos nutzbar.

Durch die interne Form der Daten-Speicherung wird der LayerManager auch in absehbarer Zukunft die Kompatibilität innerhalb seiner eigenen Daten nicht verlieren – garantiert !